Project

General

Profile

Feature #11768

Improve our handling of new contractors

Added by u over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
09/03/2016
Due date:
% Done:

30%

Feature Branch:
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:

Description

  • Gather information in one place
  • send them the documentation
  • send them a welcome

History

#1 Updated by u over 3 years ago

  • Assignee changed from u to intrigeri
  • QA Check set to Info Needed

Intrigeri, you said that you already started to gather these docs, could you please point me to them? Then reassign this ticket to me please. Thanks.

#2 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to u

Intrigeri, you said that you already started to gather these docs, could you please point me to them?

Sure! Now, these documents are in the accounting Git repo (that's basically the content of the processes directory there), so I don't know how we shall proceed. I could of course send you a copy, but then we'll end up with two versions evolving separately. Or you could get access to that repo (which you might need for other reasons soonish anyway). Or we could move them to a new, dedicated repo, that all contractors would have (at least read-) access to, and you would have write access to so you could improve these docs and add whatever else is needed. What do you prefer?

#3 Updated by u about 3 years ago

  • Assignee changed from u to intrigeri

intrigeri wrote:

Intrigeri, you said that you already started to gather these docs, could you please point me to them?

Sure! Now, these documents are in the accounting Git repo (that's basically the content of the processes directory there), so I don't know how we shall proceed. I could of course send you a copy, but then we'll end up with two versions evolving separately. Or you could get access to that repo (which you might need for other reasons soonish anyway). Or we could move them to a new, dedicated repo, that all contractors would have (at least read-) access to, and you would have write access to so you could improve these docs and add whatever else is needed. What do you prefer?

I very much like the idea of giving contractors read access to these docs and me write access.
Could you ask for this repo (encrypted i guess)? Last time i tried to set up this encrypted repo it did not work for some reason, so i wonder if you could either do it or send me some documentation?

#4 Updated by intrigeri almost 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to u
  • Target version set to Tails_2.11
  • % Done changed from 0 to 10
  • QA Check deleted (Info Needed)

Sure. Here's what I did after having a Git repo created (usually one would ask the sysadmins team):

git clone gcrypt::tails@git-tails.immerda.ch:workers-handbook.git
cd workers-handbook
git config gcrypt.publish-participants true
git config gcrypt.participants "LIST OF OPENPGP FINGERPRINTS" 
cp ../fundraising/README .
editor README # adjust the line about gcrypt.participants
git add README
git commit -m 'Add setup documentation.'
git push -u origin master

Next step: I should migrate some content from other repositories to this new one. I won't do that right now, so keeping on my plate and adding a target version.

#5 Updated by intrigeri almost 3 years ago

  • Assignee changed from u to intrigeri

#6 Updated by intrigeri almost 3 years ago

u wrote:

Could you ask for this repo (encrypted i guess)? Last time i tried to set up this encrypted repo it did not work for some reason, so i wonder if you could either do it or send me some documentation?

#12172 :)

#7 Updated by u almost 3 years ago

Great, so please reassign to me once you've added some initial content there.

#8 Updated by intrigeri almost 3 years ago

  • Assignee changed from intrigeri to u
  • % Done changed from 10 to 20

u wrote:

Great, so please reassign to me once you've added some initial content there.

Done!

#9 Updated by intrigeri almost 3 years ago

(Note that I had set the current target version for my own sake, so of course feel free to adjust it to whatever ETA suits you well.)

#10 Updated by sajolida almost 3 years ago

I tried to clone that repo and got `gcrypt: Failed to decrypt manifest!`. Is it encrypted for me already? Or maybe I should be more patient and wait for it to be announced to everybody...

#11 Updated by sajolida almost 3 years ago

But hey, that's a super cool idea!!!

#12 Updated by intrigeri almost 3 years ago

I tried to clone that repo and got `gcrypt: Failed to decrypt manifest!`.

I've checked my config and pushed some new commits. Please retry?

#13 Updated by anonym almost 3 years ago

  • Target version changed from Tails_2.11 to Tails_2.12

#14 Updated by intrigeri almost 3 years ago

I've just added some more content to the repo.

#15 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_2.12 to Tails_3.0

#16 Updated by u over 2 years ago

I do now have access to the repository.

#17 Updated by u over 2 years ago

  • Assignee changed from u to sajolida

Reassigning to sajolida in case he still needs to export this git repository.
From now on I can take over the handling of new contractors using the information stored in the repo.

#18 Updated by sajolida over 2 years ago

  • Assignee changed from sajolida to u
  • QA Check set to Info Needed

I've got that repo now. Shall we close this ticket then?

#19 Updated by intrigeri over 2 years ago

  • QA Check changed from Info Needed to Dev Needed

I've got that repo now. Shall we close this ticket then?

Having a repo that 3 people know about does not fully address what this ticket is about; see the ticket description for details :)

Now, I don't understand what u meant with "Reassigning to sajolida in case he still needs to export this git repository".

#20 Updated by u over 2 years ago

  • Target version deleted (Tails_3.0)
  • QA Check deleted (Dev Needed)

intrigeri wrote:

I've got that repo now. Shall we close this ticket then?

Having a repo that 3 people know about does not fully address what this ticket is about; see the ticket description for details :)

Ack.

Now, I don't understand what u meant with "Reassigning to sajolida in case he still needs to export this git repository".

I simply wanted to know if we all have access, because there were problems previously.

I will keep this ticket open without a target version. I'm currently not aware of new contractors who have not yet received this information.

#21 Updated by intrigeri over 2 years ago

I'm currently not aware of new contractors who have not yet received this information.

Three data points that might affect your prioritization of this task:

  • In theory, all existing contractors have received this info at least once, but that was spread over multiple messages and over many years; in practice, pretty often (if not "most of the time"), they are unable to find this info when they need it, and then they ask the accounting team that is forced to act as document store'n'retrieve service, which is kinda dull. Making this repo available to all contractors (without waiting for new ones) would fix this.
  • Very likely, we'll soon have a new contractor on the sysadmin team.
  • Now that the repo is ready, I expect that giving access to it to all contractors (I could do that) and sending them an email to let them know about it should be pretty quick. And then we have one less open issue on our plate :) Unless I missed something and we already pointed workers to this repo?

#22 Updated by u over 2 years ago

  • Assignee changed from u to intrigeri

intrigeri wrote:

I'm currently not aware of new contractors who have not yet received this information.

Three data points that might affect your prioritization of this task:

  • In theory, all existing contractors have received this info at least once, but that was spread over multiple messages and over many years; in practice, pretty often (if not "most of the time"), they are unable to find this info when they need it, and then they ask the accounting team that is forced to act as document store'n'retrieve service, which is kinda dull. Making this repo available to all contractors (without waiting for new ones) would fix this.

ack.

  • Very likely, we'll soon have a new contractor on the sysadmin team.

ack. you might want to send me an email with the address of this contractor, so that I can send him or her relevant information.

  • Now that the repo is ready, I expect that giving access to it to all contractors (I could do that) and sending them an email to let them know about it should be pretty quick. And then we have one less open issue on our plate :) Unless I missed something and we already pointed workers to this repo?

This sounds like a good idea. Reassigning to you then.

Please reassign to me when done and I'll send an email to all people that are concerned by this. And then we can close the ticket.

#23 Updated by intrigeri over 2 years ago

  • Target version set to Tails_3.0

My radar++ :)

#24 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to u
  • % Done changed from 20 to 30

#28 Updated by intrigeri over 2 years ago

FWIW Tor people should document similar things on https://trac.torproject.org/projects/tor/wiki/org/onboarding soon.

#29 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_3.0 to Tails_3.1

(I'm closing the 3.0 target version.)

#31 Updated by u over 2 years ago

So how do I get to know if I should point any new contractor to these documents?

#32 Updated by intrigeri over 2 years ago

u wrote:

So how do I get to know if I should point any new contractor to these documents?

I expect any new contractor will have a conversation with the accounting team before being officially hired, at least to clarify daily rate etc. So you'll be in the loop. Does this answer your question?

#34 Updated by u over 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF