Project

General

Profile

Feature #11759

Feature #10034: Translation web platform

Install & configure a fresh weblate on the VM

Added by u over 3 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/11/2015
Due date:
% Done:

100%

Spent time:
(Total: 1.70 h)
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

While waiting to test other platforms against our requirements you proposed to install a fresh weblate on a new VM in order to continue to be able to translate with this while proposing to new contributors to write git hooks which could satisfy our plan.


Subtasks

Feature #10802: Investigate states of Weblate translationsResolved

Bug #10901: Repair Git repo on Weblate VMResolved

Feature #12221: Install packages needed to build our website in tails::weblateResolved

Feature #12223: Puppetize machine translation service on translate.lizardResolved

Feature #15190: Cronjobs for translate.lizard are not runningResolved

Feature #15308: Cannot update database schemes in translate.lizardResolved

Bug #15361: Implement automatic checking & correction of inconsistent strings in WeblateResolved

Bug #15365: Check if voting mechanism in Weblate WRT validity of stringsResolved

Bug #15406: Backup Weblate configurationResolved

Bug #15409: Configure addons in WeblateResolved

Bug #15479: Clean up / document VCS used in weblate installationResolved

Bug #15481: Weblate bash UTF8 brokenResolved

Bug #15620: Redirect weblate@translate.lizard email somewhere relevantResolved

Bug #15624: Please install python-git, python3-git, python-pathlib on Weblate VMResolved

Bug #15651: Make sure we push Weblate's Git repo to https://git-tails.immerda.ch/weblate/tails/ once a dayRejected

Bug #15679: update puppet-tails to have scripts in weblate vmResolved

Feature #15721: Access to translate-server.gitResolved

Bug #15906: Frequent memory issues on translate.lizardResolved

Feature #16065: Grant hefee ability to disable puppetResolved

Bug #16106: Add hefee to list of recipients of cron mails of translation serverResolved

Bug #16109: Make suggestions-cronjob.sh work againResolved

Bug #16115: Remove "u" from list of recipients of cron mails of translation serverResolved

Bug #16152: Default python version must remain 2.x even on translate.lizardResolved

Feature #16225: merge hefee/dev/translation-serverResolved

Feature #16250: fixes for translations-serverResolved


Related issues

Duplicated by Tails - Feature #15074: Set up and configure the web interface of the translation platform Resolved 03/01/2018
Blocks Tails - Feature #12220: Set up monitoring for weblate Resolved 02/11/2017

History

#1 Updated by u over 3 years ago

  • Subject changed from Install a fresh weblate on the VM to Install & configure a fresh weblate on the VM

#3 Updated by u over 3 years ago

Don't forget to configure the roles and commits as shown in #11265

#4 Updated by u over 3 years ago

  • Blocks Feature #11762: Try to get the farsi translation back into shape added

#5 Updated by BitingBird about 3 years ago

  • Status changed from New to Confirmed

#6 Updated by intrigeri almost 3 years ago

  • Status changed from Confirmed to In Progress

I did all I could on the reverse proxy side. https://translate.tails.boum.org/ is a thing. reverse proxy set up, with TLS cert. But Apache created an endless redirection loop (it redirected http to https, but it should not because we terminate TLS on the reverse proxy, and we already have such a redirection in place there), so I've fixed it. Also, I think that most the /var/lib/weblate paths in the apache config are wrong.

#7 Updated by intrigeri almost 3 years ago

#8 Updated by intrigeri almost 3 years ago

For the Apache ServerAdmin setting: we need a single email address that points to the admins. Get a mailing list or an alias for the admin team?

#9 Updated by u almost 2 years ago

  • Assignee changed from emmapeel to intrigeri

#10 Updated by u almost 2 years ago

  • Target version set to Tails_3.5

#11 Updated by intrigeri almost 2 years ago

  • Assignee changed from intrigeri to u
  • QA Check set to Info Needed

Assignee changed from emmapeel to intrigeri

Oops, I don't understand what's expected from me here.

From my point of view, the only task that's been assigned to me on this project is "2.1. Create and configure a VM", with 0 days, because I did that already: that's #10180. My understanding is that this very ticket is rather about "2.2. Set up and configure the web interface", which is on emmapeel's plate. I'm happy to keep Puppet'izing whatever emmapeel needs for the basic Weblate setup, but for the moment I'm waiting for info I've requested a while ago on this ticket and some other related ones.

Now, if things look different from your point of view, please help me understand what work I'm supposed to do :)

#12 Updated by u almost 2 years ago

  • Status changed from In Progress to Resolved

I am simply doing some cleaning, and wanted to unparent, then close this ticket :) But you're too fast for me!

#13 Updated by emmapeel almost 2 years ago

  • Status changed from Resolved to In Progress
  • Assignee changed from u to emmapeel
  • Target version changed from Tails_3.5 to Tails_3.6

I have been adding some subtasks to this issue for a while, so i decided to open it again, as the original install is not finished yet from my POV.

#14 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#15 Updated by emmapeel over 1 year ago

  • Duplicated by Feature #15074: Set up and configure the web interface of the translation platform added

#16 Updated by emmapeel over 1 year ago

  • Blocks deleted (Feature #11762: Try to get the farsi translation back into shape)

#17 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#18 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#19 Updated by u over 1 year ago

  • Status changed from In Progress to Resolved

#20 Updated by intrigeri 5 months ago

  • Assignee deleted (emmapeel)

Also available in: Atom PDF