Project

General

Profile

Bug #11742

Feature #11916: Update doc for 3.0

Update doc screenshots for 3.0

Added by spriver about 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
08/29/2016
Due date:
% Done:

0%

Feature Branch:
spriver:doc/11742-update-stretch-doc-screenshots
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

  • Doc:
    • doc/advanced_topics/virtualization/tails-in-jessie.png
    • doc/first_steps/upgrade/upgrader.png

Related issues

Related to Tails - Feature #12366: Upgrade screenshot of Tails in virtual machine Resolved 03/18/2017
Related to Tails - Bug #12365: Upgrade automatic and manual upgrade screenshots Resolved 03/18/2017
Blocked by Tails - Bug #11789: Have GNOME with a black theme on Tails Stretch Resolved 09/11/2016

History

#1 Updated by intrigeri about 3 years ago

  • Status changed from New to Confirmed

#2 Updated by intrigeri about 3 years ago

Sure! spriver: next step is probably to start listing the exact filenames of the screenshots that need updating. The description of this ticket seems a good place to do that.

#3 Updated by spriver about 3 years ago

  • Assignee set to spriver

#4 Updated by spriver about 3 years ago

Pages with images that need to be changed:

Installation Assistant:

  • install/inc/steps/restart_first_time.inline
    install/inc/screenshots/desktop.png
  • install/linux/usb
    install/inc/screenshots/gnome_disks_drive.png
    install/inc/screenshots/gnome_disks_system.png
  • install/download/openpgp
    install/inc/screenshots/notification_in_tails.png
    probably: install/inc/screenshots/verifying_in_tails.png
  • inc/steps/install_final.inline
    install/inc/screenshots/tails_installer_in_tails.png

Doc:

  • doc/first_steps/introduction_to_gnome_and_the_tails_desktop
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/applications.png
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/accessibility.png
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/applications.png
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/florence.png
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/nautilus.png
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/openpgp_applet.png
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/places.png
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/system.png
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/tor-status.png
  • doc/first_steps/accessibility
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/accessibility.png
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/florence.png
  • doc/tails/website/doc/first_steps/upgrade
    doc/first_steps/upgrade/upgrader.png
  • doc/tails/website/doc/first_steps/reset/linux
    lib/emblem-system.png
  • doc/anonymous_internet/networkmanager
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/system.png
  • doc/anonymous_internet/tor_status
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/tor-status.png
    doc/anonymous_internet/tor_status/onion-circuits.png
  • doc/anonymous_internet/Tor_Browser
    doc/anonymous_internet/Tor_Browser/riseup.png
    doc/anonymous_internet/Tor_Browser/security_slider.png
    doc/anonymous_internet/Tor_Browser/new_identity.png
  • doc/anonymous_internet/icedove/account_creation.inline
    doc/anonymous_internet/icedove/assistant.png
  • doc/anonymous_internet/claws_mail_to_icedove
    share/doc/tails/website/lib/go-down.png
  • doc/encryption_and_privacy/virtual_keyboard
    doc/first_steps/introduction_to_gnome_and_the_tails_desktop/florence.png
  • doc/encryption_and_privacy/encrypted_volumes
    lib/emblem-system.png
    doc/encryption_and_privacy/encrypted_volumes/empty_device.png
    doc/encryption_and_privacy/encrypted_volumes/encrypted_partition.png
    doc/encryption_and_privacy/encrypted_volumes/nautilus_encrypted.png
  • doc/encryption_and_privacy/gpgapplet
    doc/encryption_and_privacy/gpgapplet/gpgapplet_with_text.png
  • doc/tails/website/doc/encryption_and_privacy/gpgapplet/passphrase_encryption
  • doc/encryption_and_privacy/gpgapplet/public-key_cryptography
    doc/encryption_and_privacy/gpgapplet/browser_paste.png
  • doc/encryption_and_privacy/secure_deletion
    doc/encryption_and_privacy/secure_deletion/wipe_files.png
    lib/go-down.png
    doc/encryption_and_privacy/secure_deletion/wipe_available_diskspace.png
  • doc/encryption_and_privacy/checksums
    doc/encryption_and_privacy/checksums/gtkhash.png (layout changed a little bit, spacing etc. maybe not needed that badly)
  • doc/advanced_topics/virtualization
    doc/advanced_topics/virtualization/tails-in-jessie.png

#5 Updated by sajolida about 3 years ago

  • Parent task set to #11916

#6 Updated by sajolida about 3 years ago

spriver: I'm copying your list to the description of the ticket so we can modify it.

#7 Updated by sajolida about 3 years ago

  • Description updated (diff)

#8 Updated by sajolida about 3 years ago

  • Description updated (diff)

Ordered the list alphabetically and removed some of duplicates.

#9 Updated by sajolida about 3 years ago

  • Description updated (diff)

doc/first_steps/startup_options/boot-menu-with-options.png might need update due to the 64-bit user space (#8183).

#10 Updated by sajolida about 3 years ago

  • Blocked by Bug #11789: Have GNOME with a black theme on Tails Stretch added

#11 Updated by sajolida about 3 years ago

We shouldn't update any screenshot because deciding on the color of the theme (grey or black).

#12 Updated by sajolida about 3 years ago

  • Description updated (diff)

#13 Updated by sajolida about 3 years ago

  • Description updated (diff)

#14 Updated by sajolida about 3 years ago

  • Description updated (diff)

Double-checked the list, reordered, and remove some stuff we shouldn't bother doing. From now on, let's strike through the points in the list as we do them (so it's easier to track and review the work at the end).

#15 Updated by sajolida about 3 years ago

  • Description updated (diff)

A bit more cleaning, sorry...

#16 Updated by intrigeri over 2 years ago

  • Priority changed from Normal to Elevated

#17 Updated by spriver over 2 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to spriver:doc/11742-update-stretch-doc-screenshots

Almost done!
Screenshots that I did not update yet:
- doc/first_steps/upgrade/upgrader.png (needs an IUK in Tails 3.0)
- doc/advanced_topics/virtualization/tails-in-jessie.png (needs a bare metal stretch host with GNOME, I can do this ~next week)

#18 Updated by spriver over 2 years ago

  • Description updated (diff)

#19 Updated by sajolida over 2 years ago

  • Related to Feature #12366: Upgrade screenshot of Tails in virtual machine added

#20 Updated by sajolida over 2 years ago

  • Related to Bug #12365: Upgrade automatic and manual upgrade screenshots added

#21 Updated by sajolida over 2 years ago

  • QA Check set to Ready for QA

I did a bunch more work in a92bfb33ad..328af3c0e9. Please have a look.

We're almost there!

#22 Updated by spriver over 2 years ago

  • Assignee changed from spriver to sajolida

I already did the review in March and added some bits, can please take a look?

#23 Updated by sajolida over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

All this is already in feature/stretch, so I'm closing this ticket then. Yeah!

Also available in: Atom PDF