Project

General

Profile

Feature #11739

Feature #12160: Upgrade all systems to Stretch

Upgrade our isotesters to Stretch

Added by intrigeri about 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
08/28/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

I expect we'll do that as soon as Debian Stretch is released, or during its freeze.


Related issues

Related to Tails - Bug #10068: Upgrade to Jenkins 2.x, using upstream packages Resolved 01/08/2018
Related to Tails - Bug #13138: Cucumber segfaults on Jenkins isotesters Resolved 06/26/2017
Related to Tails - Bug #17080: Upgrade Cucumber on Jenkins isotesters Resolved

History

#1 Updated by intrigeri about 3 years ago

  • Blocks Bug #11605: Upgrade the QEMU machine type used in our test suite and stop supporting Jessie for running the test suite added

#2 Updated by intrigeri about 3 years ago

  • Assignee set to intrigeri

#3 Updated by anonym almost 3 years ago

  • Feature Branch set to feature/11739-stretch-isotesters

Pushed a branch that so far only deals with the follow-up on #12129 once we drop Jessie support for the host running the automated test suite.

#4 Updated by anonym almost 3 years ago

  • Feature Branch changed from feature/11739-stretch-isotesters to wip/feature/11739-stretch-isotesters

Let's not have Jenkins waste resources on testing this branch, since we'll push stuff into it that won't work on Debian Jessie.

#5 Updated by intrigeri almost 3 years ago

  • Description updated (diff)

#6 Updated by intrigeri almost 3 years ago

  • Parent task set to #12160

#7 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

I've upgraded isotester1.sib to Stretch, adjusted our Puppet code accordingly, and it works fine.

#8 Updated by intrigeri over 2 years ago

anonym and I agreed that we can stop supporting Jessie for running our test suite on feature/stretch, once 2.12 is out.

#9 Updated by intrigeri over 2 years ago

  • Subject changed from Upgrade our isotesters to Stretch and stop supporting Jessie for running the test suite to Upgrade our isotesters to Stretch
  • Feature Branch deleted (wip/feature/11739-stretch-isotesters)

Moving the "stop supporting Jessie for running the test suite" part to #11605, which is the one that really needs it.

#10 Updated by intrigeri over 2 years ago

  • Related to Bug #10068: Upgrade to Jenkins 2.x, using upstream packages added

#11 Updated by intrigeri over 2 years ago

  • % Done changed from 10 to 50

Upgraded all active isotesters, but the cucumber plugin for Jenkins fails to parse the resulting JSON:

17:13:03 [Cucumber Tests] Parsing results.
17:13:04 [Cucumber Tests] parsing cucumber.json
17:13:04 ERROR: Publisher org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberTestResultArchiver aborted due to exception
17:13:04 java.lang.NullPointerException 17:13:04     at org.jenkinsci.plugins.cucumber.jsontestsupport.GherkinCallback.before(GherkinCallback.java:220)
17:13:04     at gherkin.JSONParser.before(JSONParser.java:82)
17:13:04     at gherkin.JSONParser.parse(JSONParser.java:48)
17:13:04     at org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberJSONParser.parse(CucumberJSONParser.java:94)
17:13:04     at org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberJSONParser.parse(CucumberJSONParser.java:44)
17:13:04     at org.jenkinsci.plugins.cucumber.jsontestsupport.DefaultTestResultParserImpl$ParseResultCallable.invoke(DefaultTestResultParserImpl.java:161)
17:13:04     at org.jenkinsci.plugins.cucumber.jsontestsupport.DefaultTestResultParserImpl$ParseResultCallable.invoke(DefaultTestResultParserImpl.java:107)
17:13:04     at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2474)
17:13:04     at hudson.remoting.UserRequest.perform(UserRequest.java:118)
17:13:04     at hudson.remoting.UserRequest.perform(UserRequest.java:48)
17:13:04     at hudson.remoting.Request$2.run(Request.java:328)
17:13:04     at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
17:13:04     at java.util.concurrent.FutureTask.run(FutureTask.java:266)
17:13:04     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
17:13:04     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
17:13:04     at hudson.remoting.Engine$1$1.run(Engine.java:63)
17:13:04     at java.lang.Thread.run(Thread.java:745)
17:13:04 Sending e-mails to: intrigeri@boum.org
17:13:04 [WS-CLEANUP] Deleting project workspace...[WS-CLEANUP] done
17:13:05 Finished: FAILURE

This looks like https://github.com/jenkinsci/cucumber-testresult-plugin/pull/9 that hasn't been merged yet. But even once it's fixed there, it's not clear if we can upgrade as the latest version requires a newer Jenkins than what we have (until #10068 is addressed). So I'll try to downgrade cucumber to the Jessie version until the bug is fixed upstream and #10068 is a thing.

#12 Updated by intrigeri over 2 years ago

intrigeri wrote:

So I'll try to downgrade cucumber to the Jessie version until the bug is fixed upstream and #10068 is a thing.

Done.

#13 Updated by intrigeri over 2 years ago

  • % Done changed from 50 to 60

Simply downgrading didn't work so I had to forward-port 6 packages from Jessie and import cucumber 1.3.18 (that was never released to Debian). See commit 4a012e79d20ea5cf075fb14b338a721ac0b371e0 in puppet-tails for details. Let's see how it goes!

#14 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to bertagaz
  • % Done changed from 60 to 70
  • QA Check set to Ready for QA

It's repaired :)

Please review my changes (2d69e836c735526f1de434177ccafed2a3f57c39..95e23ff338190002141f64f2c961c9e1de5dfa86 in the manifests repo + obviously the corresponding submodules changes).

#15 Updated by intrigeri over 2 years ago

  • Blocks deleted (Bug #11605: Upgrade the QEMU machine type used in our test suite and stop supporting Jessie for running the test suite)

#16 Updated by bertagaz over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (bertagaz)
  • % Done changed from 70 to 100
  • QA Check changed from Ready for QA to Pass

Looks good! Seems it wasn't that easy in the end. I've updated #10068 to take note of the changes introduced here that may need to be reverted once Jenkins is upgraded.

#17 Updated by intrigeri over 2 years ago

  • Related to Bug #13138: Cucumber segfaults on Jenkins isotesters added

#18 Updated by intrigeri about 2 months ago

  • Related to Bug #17080: Upgrade Cucumber on Jenkins isotesters added

Also available in: Atom PDF