Project

General

Profile

Feature #11738

Upgrade our ISO builder Vagrant basebox to Stretch

Added by intrigeri over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
08/28/2016
Due date:
% Done:

100%

Feature Branch:
feature/11738-stretch-vagrant-basebox
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Technically this is not required for Tails 3.0: especially if Jessie LTS is a thing, we can stick to Jessie for a while. But let's keep this in mind and use Redmine relationships to indicate what this ticket is blocking, so that we can better prioritize it.


Related issues

Blocks Tails - Feature #11912: Purge Jessie time-based APT snapshots Resolved 11/13/2016
Blocked by Tails - Bug #13530: ISO builds are broken by weird enigmail situation Resolved 07/29/2017

Associated revisions

Revision 27e1a123 (diff)
Added by intrigeri over 2 years ago

Upgrade the Vagrant basebox for building ISO images to Stretch (refs: #11738).

Revision 71ad2fec (diff)
Added by intrigeri over 2 years ago

Vagrant build box: don't upgrade to stretch-backports kernel (refs: #11738).

The Stretch one is good enough.

Revision 37dd317f (diff)
Added by intrigeri over 2 years ago

Vagrant build box: don't (try to) install wdg-html-validator (refs: #11738).

It's not in Stretch (nor in testing/sid), we don't document this dependency
anywhere else, and our website builds just fine without it. So I think this
package installation comes from ancient times and is now obsolete.

Revision eda9ff27 (diff)
Added by intrigeri over 2 years ago

Rakefile: adjust free_vm_memory for Stretch (refs: #11738).

The output of `free' has changed in Stretch.

Revision fd27b878 (diff)
Added by intrigeri over 2 years ago

Ensure we install our own live-build (refs: #11738).

By default Stretch is pinned at 500, so live-build from Stretch was installed.

Revision 03923fe8
Added by bertagaz over 2 years ago

Merge remote-tracking branch 'origin/feature/11738-stretch-vagrant-basebox' into stable

Fix-committed: #11738

History

#1 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#2 Updated by intrigeri over 2 years ago

#3 Updated by intrigeri over 2 years ago

  • Assignee set to anonym
  • Target version set to Tails_3.5

anonym, can you take it during the 3.4 cycle (as part of Foundations Team work) so I can do #11912?

#4 Updated by intrigeri over 2 years ago

(Dropped my own comment that had incomplete info.)

#5 Updated by intrigeri over 2 years ago

  • Assignee changed from anonym to bertagaz
  • Target version changed from Tails_3.5 to Tails_3.1
  • QA Check set to Info Needed

Dear RM, would it feel crazy in principle to do this for 3.1? Rationale: as explained in #13526#note-9 this would allow us to do #11912 soon after the 3.1 release, and solve the recurring disk space problems we're experiencing on the apt-snapshots volume.

In practice live-build does everything in a chroot it creates (that's already Stretch anyway), so what would be impacted is only what we do in the basebox itself, i.e. building the wiki (FWIW we already install a version of discount that's almost the one in Stretch), updating PO files, and running debootstrap (we already install 1.0.89~bpo8+1 while Stretch has 1.0.89) so perhaps it's not such a big deal.

I'll try to quickly prepare a branch so we have more info wrt. how much work it requires and how broken the resulting ISO is.

#6 Updated by intrigeri over 2 years ago

  • Feature Branch set to feature/11738-stretch-vagrant-basebox

#7 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

I now have an ISO built from this branch, let's see what the test suite says. Will report diffoscope results later.

#8 Updated by intrigeri over 2 years ago

  • Blocked by Bug #13530: ISO builds are broken by weird enigmail situation added

#9 Updated by intrigeri over 2 years ago

  • % Done changed from 10 to 50
  • QA Check changed from Info Needed to Ready for QA

The subset of our automated tests that we run on Jenkins has passed here (on my own Jenkins).

I've diff'ed the two ISOs, one built from this branch and one built from the one for #13530 (nothing else builds right now anyway), and the only differences in the SquashFS are in the local copy of the website (expected as we're using different versions of ikiwiki due to #13531).

This matches my expectations, i.e. upgrading the OS of the basebox has very little impact on the resulting ISO image. So please review'n'merge.

#10 Updated by bertagaz over 2 years ago

  • % Done changed from 50 to 60

intrigeri wrote:

The subset of our automated tests that we run on Jenkins has passed here (on my own Jenkins).

I've diff'ed the two ISOs, one built from this branch and one built from the one for #13530 (nothing else builds right now anyway), and the only differences in the SquashFS are in the local copy of the website (expected as we're using different versions of ikiwiki due to #13531).

This matches my expectations, i.e. upgrading the OS of the basebox has very little impact on the resulting ISO image. So please review'n'merge.

Couldn't really believe it, but my local builds/diffs say the same (well, apart from some "bleeding" we already noticed). Good there's no surprise there.

I'm running the test suite on the ISO just in case, I think I'll merge this for 3.1 if there's no unexpected failure.

#11 Updated by bertagaz over 2 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (bertagaz)
  • % Done changed from 60 to 100
  • QA Check changed from Ready for QA to Pass

Merged into stable and devel, everything seems fine in Jenkins. Nice to see that upgrading our basebox is easy as that and does not have unexpected side effects!

#12 Updated by bertagaz over 2 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF