Project

General

Profile

Bug #11731

The text of the selected entry in the localization menus is grayed out on Stretch

Added by intrigeri about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
08/26/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Greeter

Description

Boot an ISO built from feature/stretch and look at the color of the text (e.g. "English") on the localization dropboxes.


Related issues

Related to Tails - Bug #11695: Tails Greeter's localization settings are broken on Stretch Resolved 08/23/2016

History

#1 Updated by intrigeri about 3 years ago

  • Target version set to Tails_3.0

Alan, can you please have a quick look and point me to what the root cause could be?

#2 Updated by intrigeri about 3 years ago

  • Related to Bug #11695: Tails Greeter's localization settings are broken on Stretch added

#3 Updated by intrigeri about 3 years ago

  • Assignee changed from alant to intrigeri

#4 Updated by intrigeri about 3 years ago

Alan tells me that it's because the focused window has black text and other ones have gray text. Our l10n menu is in its own window, that is apparently not focused, hence the result we see.

I'll wait until the next sprint (end of December) during which I hope we can merge the new Greeter, that does not share this bug.

#5 Updated by intrigeri about 3 years ago

https://sources.debian.net/src/gtk%2B3.0/3.22.3-2/gtk/theme/Adwaita/gtk-contained-dark.css/ is the default theme. We might be able to use a custom CSS to override the text color for unfocussed windows, but I doubt it's worth the effort. So as said earlier I'll wait for the December sprint.

#6 Updated by intrigeri almost 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

We merged the new Greeter so this is not applicable anymore.

Also available in: Atom PDF