Project

General

Profile

Bug #11728

Make sure we don't leak unwanted information through dhcp-client-identifier

Added by intrigeri about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
Spoof MAC
Target version:
Start date:
08/26/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

Description

It looks like NetworkManager configures dhclient to send some MAC address this way. We should make sure that if it's the case, we're not sending the device's permanent MAC address.

History

#1 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

I've checked tcpdump traces with wireshard, for Tails 2.5 and feature/stretch, and I could not spot dhcp-client-id being sent. This matches my understanding of the NM documentation, that suggests that nothing should be sent unless the dhcp-client-id setting is explicitly set.

Also available in: Atom PDF