Project

General

Profile

Feature #11717

Drop launchers from the Desktop

Added by intrigeri about 3 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
08/25/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

On feature/stretch they look wrong again (#11716) so I want to finally have this discussion before I spend any time fixing them.

In favour of removing these launchers:

  • The desktop are is meant to be hidden by application windows, so it's a poor place to access features that one may often need, such as Home or Trash.
  • This feature is a badly supported opt-in thing in GNOME these days, and I've seen upstream refuse to look at bugs that were only reproducible with Nautilus managing the desktop area (which is needed to have launchers on the desktop). Chances are that it'll simply go away sooner or later.
  • Fixing them for Stretch is not free (possibly super cheap though).
  • It's 2016 and most computer users are now used to adjust to crazy modern interfaces such as Android, OS X, Unity and GNOME Shell. So we can rely on their ability to cope with not having launchers on the desktop.

In favour of keeping (at least some) of these launchers:

  • The "Report a bug" and "Tails documentation" launchers provide obvious entry points to our documentation. Any other place will be at least a tiny less obvious.
  • A number of people are still used to GUI paradigms from the 90's, such as this one. Changing this would make them feel less at home in Tails.

I propose that for Tails 3.0, we:

  1. move the launchers we really want to keep ("Report a bug", "Tails documentation") to the Favorites section, so they appear 1. as soon as one opens the applications menu, along with Tor Browser and friends (and if one argues that it's too hard to find there, then Tor Browser is also too hard to find and then we have a bigger problem, that probably we should have heard about already); 2. in the Activities Overview (open by the Windows key or by moving the mouse to the top-left corner);
  2. drop the Home and Trash launchers entirely.

I'm open to doing this change earlier, if we prefer to introduce such UI changes one at a time, instead of all at once. I don't care much personally, and will rely on frontdesk's and communication/UX people's opinion regarding what's the best strategy here.


Related issues

Related to Tails - Feature #11743: Blueprint for "Documentation for newcomers" Rejected 08/29/2016
Related to Tails - Bug #13461: The Desktop icons are sometimes not displayed since the upgrade to Stretch Resolved 07/12/2017
Related to Tails - Bug #14793: Custom Desktop launchers are totally buggy Resolved 10/06/2017
Related to Tails - Bug #15321: "The Report an Error launcher will…" test suite step is fragile Resolved 02/17/2018
Related to Tails - Bug #15514: The "The Tails documentation launcher on the desktop works…" scenarios are fragile Resolved 04/09/2018
Related to Tails - Bug #16283: No more icons on desktop in buster Resolved 01/05/2019
Related to Tails - Bug #17180: cant wipe files on desktop New
Related to Tails - Bug #17207: not work desktop icons Duplicate
Related to Tails - Bug #17193: It is not work to run the script or shortcut New
Related to Tails - Bug #17243: Desktop icon's lable fail to resize for long names New
Blocked by Tails - Feature #11657: Reintroduce the "Take a Tour" button Rejected 08/17/2016

History

#1 Updated by intrigeri about 3 years ago

  • Blocks Bug #11716: Desktop icons look wrong on Stretch compared to Tails 2.x added

#2 Updated by intrigeri about 3 years ago

  • Assignee set to sajolida
  • QA Check set to Info Needed

sajolida: before I raise this at a monthly meeting, I'd like to make sure that I'm not forgetting an obvious reason to keep these launchers; and if you strongly disagree for some reason, I'd like to discuss it a bit with you before we have this discussion collectively. So, what's your take on my proposal?

#3 Updated by sajolida about 3 years ago

  • Assignee deleted (sajolida)
  • QA Check deleted (Info Needed)

I'm fine with discussing this in a monthly meeting. I don't find your proposal crazy at all.

#4 Updated by intrigeri about 3 years ago

  • Description updated (diff)
  • Assignee set to intrigeri

#5 Updated by sycamoreone about 3 years ago

  • Related to Feature #11743: Blueprint for "Documentation for newcomers" added

#6 Updated by sycamoreone about 3 years ago

In the September monthly meeting it was decided that the Desktop launchers are an important entry point to the documentation for users, that are not used to Linux and the Gnome desktop.

We should try to keep the Desktop launchers for now, if that is not too much work, and get rid of all the launchers if it's too much trouble. We can drop the launchers, when we do have a "take a tour" feature to introduce new users to the desktop.

If desired Trash and Home could already be dropped now or with 3.0. We will then see if and how many users complain.

(I don't see a status to set this ticket for "later". What is the best way to handle this?)

#7 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Reading the meeting minutes, I feel that my "if one argues that it's too hard to find there, then Tor Browser is also too hard to find and then we have a bigger problem, that probably we should have heard about already" argument was not really taken into account, but whatever. I can live with this decision. I won't bother removing just half of the launchers as I see no substantial benefit in doing it if we don't do the whole thing, thus closing.

#8 Updated by intrigeri about 3 years ago

  • Blocked by Feature #11657: Reintroduce the "Take a Tour" button added

#9 Updated by intrigeri about 3 years ago

  • Subject changed from Consider dropping launchers from the Desktop to Drop launchers from the Desktop
  • Status changed from Resolved to Confirmed
  • Target version deleted (Tails_3.0)
  • % Done changed from 100 to 0
  • Type of work changed from Discuss to Code

I'm turning this ticket into actually doing it (as decided) once we have #11657.

#10 Updated by intrigeri about 3 years ago

  • Blocks deleted (Bug #11716: Desktop icons look wrong on Stretch compared to Tails 2.x)

#11 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (intrigeri)

#11657 was rejected, so following our previous decision ("We can drop the launchers, when we do have a "take a tour" feature to introduce new users to the desktop") there's no way to ever change the current behaviour => rejecting. Let's come back to it if it becomes really painful to maintain, technically speaking.

#12 Updated by intrigeri about 2 years ago

  • Related to Bug #13461: The Desktop icons are sometimes not displayed since the upgrade to Stretch added

#13 Updated by intrigeri about 2 years ago

I'm coming back to this topic "thanks" to #13461; for now I'll drop some info I've gathered here and there (DebConf, GUADEC, Planet Ubuntu & GNOME), thinking a little bit of how they could work in Tails. But I'm not at the point when I'm ready to build a serious proposal, face the popular wrath (joke) once again.

FTR I've heard that there is work going on somewhere (in GNOME upstream I think) to have a "start GNOME in Overview mode" feature. This ensures that users who land on our desktop for the first time immediately see a few common launchers in the dash, and are introduced to the preferred interface to search for apps, files, etc. I think this would be good enough to address the "important entry point to the documentation for users" argument? However, this approach might conflict with any kind of welcoming screen we would want to display on the desktop (#10491 maybe?), and I don't know how it plays with notifications.

Another (probably cheaper) way out would be to enable one of the extensions that moves the dash from the overview to an always displayed dock (e.g. https://micheleg.github.io/dash-to-dock/) which is exactly what Ubuntu is doing in their upcoming GNOME-based version. This would permanently eat some screen estate, but since it shows all running apps this is compensated by allowing us to drop the taskbar and minimize button (#11270); besides, horizontal space is cheaper than vertical space on current wide-screen displays. If we do this, on the one hand we move further away from a pristine GNOME experience (by adding a dock), but OTOH we back get closer to it (by dropping the taskbar and the desktop icons).

#14 Updated by intrigeri about 2 years ago

  • Related to Bug #14793: Custom Desktop launchers are totally buggy added

#15 Updated by intrigeri over 1 year ago

  • Related to Bug #15321: "The Report an Error launcher will…" test suite step is fragile added

#16 Updated by intrigeri over 1 year ago

  • Related to Bug #15514: The "The Tails documentation launcher on the desktop works…" scenarios are fragile added

#18 Updated by segfault about 1 year ago

There is now a GNOME Shell extension for desktop icons (currently beta): https://csorianognome.wordpress.com/2018/08/22/desktop-icons-goes-beta/

#19 Updated by intrigeri 11 months ago

  • Related to Bug #16283: No more icons on desktop in buster added

#20 Updated by intrigeri 13 days ago

  • Related to Bug #17180: cant wipe files on desktop added

#21 Updated by intrigeri 13 days ago

  • Related to Bug #17207: not work desktop icons added

#22 Updated by intrigeri 12 days ago

  • Related to Bug #17193: It is not work to run the script or shortcut added

#23 Updated by intrigeri about 2 hours ago

  • Related to Bug #17243: Desktop icon's lable fail to resize for long names added

Also available in: Atom PDF