Project

General

Profile

Bug #11698

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

Test suite calls undefined save_pcap_file method in " the network device has its default MAC address configured"

Added by intrigeri over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
08/23/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

calling as root: . /usr/local/lib/tails-shell-library/hardware.sh && get_all_ethernet_nics
call returned: [0, "eth0\n", ""]
    Then 1 network interface is enabled                                                             # features/step_definitions/mac_spoofing.rb:75
calling as root: . /usr/local/lib/tails-shell-library/hardware.sh && get_all_ethernet_nics
call returned: [0, "eth0\n", ""]
calling as root: . /usr/local/lib/tails-shell-library/hardware.sh && get_all_ethernet_nics
call returned: [0, "eth0\n", ""]
calling as root: . /usr/local/lib/tails-shell-library/hardware.sh && get_current_mac_of_nic eth0
call returned: [0, "50:54:00:ce:30:6d\n", ""]
    And the network device has its default MAC address configured                                   # features/step_definitions/mac_spoofing.rb:11
      undefined local variable or method `save_pcap_file' for #<Object:0x000000091d2e10> (NameError)
      ./features/step_definitions/mac_spoofing.rb:28:in `/^the network device has (its default|a spoofed) MAC address configured$/'
      features/mac_spoofing.feature:19:in `And the network device has its default MAC address configured'
    And the real MAC address was leaked                                                             # features/step_definitions/mac_spoofing.rb:34
      Scenario failed at time 02:27:30

Perhaps we should instead call:

@sniffer.save_pcap_file

... as we do in other parts of the test suite?

Associated revisions

Revision 3f62b2ec (diff)
Added by anonym about 3 years ago

Don't call non-existing method Sniffer.save_pcap_file.

It was removed a long time ago.

Since the removed calls only happen on failure, we never see these on
Jessie-based branches (since these .feature:s work there), but only on
Stretch-based ones (where some of them are broken).

Will-fix: #11698

History

#1 Updated by intrigeri about 3 years ago

#2 Updated by intrigeri about 3 years ago

  • Parent task set to #10288

#3 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • Target version set to Tails_2.6
  • Feature Branch set to test/11698-save-pcap-file

This still breaks on feature/stretch, simply because save_pcap_file is not defined anywhere in our code.

#4 Updated by intrigeri about 3 years ago

  • Status changed from In Progress to Confirmed
  • Assignee changed from intrigeri to anonym
  • Priority changed from Normal to Elevated
  • Target version changed from Tails_2.6 to Tails_3.0
  • Feature Branch deleted (test/11698-save-pcap-file)

This prevents me from having reliable results and useful output from the test suite wrt. potential MAC spoofing regressions in feature/stretch => please prioritize this quite high among your other test suite porting tasks.

#5 Updated by anonym about 3 years ago

  • Status changed from Confirmed to In Progress

#6 Updated by anonym about 3 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (anonym)

#7 Updated by intrigeri about 3 years ago

  • Status changed from 11 to Resolved
  • % Done changed from 0 to 100

(If there's a reason not to close this ticket, please reopen and clarify.)

Also available in: Atom PDF