Project

General

Profile

Feature #11687

Known issues: How to recover an Electrum wallet

Added by emmapeel over 2 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/21/2016
Due date:
% Done:

20%

QA Check:
Feature Branch:
feature/11687-electrum_recovery
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Electrum

Description

We receive once in a while consults of users that cannot open their Electrum wallet anymore.

I am almost convinced the wallet gets somewhat corrupted, and until now we have proposed users to

- Delete or move the wallet folder
- Recreate the wallet from the seed (reconfigure Electrum with the old seed)

We never hear from users again, so it looks like the process is working.

We should add it to the Known issues page and link mention it on the Electrum page, or add it on the same Electrum documentation, linked from Known Issues.

I am not sure of the best place for this workaround.


Related issues

Related to Tails - Bug #11665: Clean up known issues page Confirmed 08/19/2016
Blocks Tails - Feature #14758: Core work 2017Q4 → 2018Q1: Technical writing Resolved 09/17/2017

History

#1 Updated by emmapeel over 2 years ago

  • Description updated (diff)

#2 Updated by emmapeel over 2 years ago

  • Description updated (diff)

#3 Updated by sajolida over 2 years ago

Unless we believe that this problem will disappear in the future, I think it's fine to document this in the Electrum page directly. Possibly with no mention on the known issues page (which is already quite a mess in and of itself).

#4 Updated by emmapeel over 2 years ago

  • Assignee changed from emmapeel to sajolida
  • QA Check set to Ready for QA
  • Feature Branch set to emmapeel:feature/11687-electrum_recovery

OK, a first branch to review.

Sajolida I thought you may like to see it but deassign if not very interested!

#5 Updated by sajolida over 2 years ago

Cool, thanks for working on this!

  • The original page is full of special <div>. I don't really like this
    but I wasn't sure how to do things differently until now. In your branch
    you're adding another one. Taking a step back, maybe we could merge your
    new section with "Your wallet can be recovered..." and create a <h2>
    section called "Recover your wallet from its seed" (or something like
    this). Then we could try to move "Electrum uses mBTC..." and "Do not
    blindly trust..." at the beginning of the page and have the section
    about recovering right after them.
  • If we end up moving this content outside of <div> then we should write
    markdown instead of full HTML (and rescue the translation from "Your
    wallet can be recovered..." which will become fuzzy.
  • The intro to your section ("If Electrum") looks like an algorithm (to
    avoid that feeling, dotted lists should be introduced with full
    sentences). As you know, I'm myself a big fan of dotted lists but here
    it sounds a bit too much. Could you try to rephrase this as one sentence
    and see if it flows better?
  • In English "may" could be permission or probability and "might" only
    probability. In our website I consistently use "might" for probability
    and "may" only for permission. It's correct grammatically speaking and
    no big deal but you know I ++
  • You're introducing the terminology "seed phrase" when we're talking
    about "seed" (only) elsewhere. How is that? What does Electrum do?
  • Earlier in the document we say "Your wallet can be recovered entirely
    from its seed" but in your section you're asking for "seed phrase,
    master key, a list of Bitcoin addresses or a list of private keys". What
    are the "master key", "list of Bitcoin addresses", and "list of private
    keys"? Is this terminology used in Electrum? Are you using "or" to mean
    either a "seed phrase", a "master key", a "list of Bitcoin addresses",
    OR a "list of private keys"?
  • Always use present tense when possible, and avoid future tense (almost
    always) and past tense (when you can instead describe the current state
    of things) because it's unclear to which point in time you are referring
    to. So get rid of "will" in your text and maybe replace "got corrupted"
    by "is corrupted".
  • Be neutral and avoid saying that things are simple.

#6 Updated by sajolida over 2 years ago

  • Assignee changed from sajolida to emmapeel
  • QA Check changed from Ready for QA to Dev Needed
  • Feature Branch changed from emmapeel:feature/11687-electrum_recovery to feature/11687-electrum_recovery

Ah, and fetch the new branch I push to the main repo so that it's merged with master.

#7 Updated by BitingBird over 1 year ago

  • Related to Bug #11665: Clean up known issues page added

#8 Updated by BitingBird over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 20

#9 Updated by intrigeri over 1 year ago

  • Affected tool set to Electrum

#10 Updated by intrigeri over 1 year ago

Dear emmapeel, I see no progress here for ~1 year. If you don't plan to resume working on this soon, please consider reassigning to one of our tech writers (e.g. cbrownstein or sajolida). Thanks! :)

#11 Updated by emmapeel over 1 year ago

  • Assignee changed from emmapeel to sajolida

Yeah... I'm hoarding on this one.

#12 Updated by emmapeel over 1 year ago

  • Blocks Feature #14758: Core work 2017Q4 → 2018Q1: Technical writing added

#13 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to emmapeel
  • Target version set to Tails_3.7
  • QA Check changed from Dev Needed to Ready for QA

Emma: Do you mind reviewing my new branch?

Otherwise, reassign it to Cody.

#14 Updated by emmapeel about 1 year ago

  • Assignee changed from emmapeel to sajolida

Looks good!

I added an anchor as well. Please review

git.tails.boum.org:emmapeel/tails
cf24f2bdd9..735fc98089 feature/11687-electrum_recovery

#15 Updated by sajolida about 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

Merged, thanks!

Also available in: Atom PDF