Project

General

Profile

Bug #11683

Feature #14534: Improve UX when Wi-Fi is not working

Improve installation instructions when Wi-Fi is not working (especially on macOS)

Added by Dr_Whax about 3 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Hardware support
Target version:
Start date:
12/29/2017
Due date:
% Done:

0%

Feature Branch:
doc/11683-broken-wifi
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Installation Assistant

Description

This ticket is about

  • adding documentation in the installation assistant,
  • warning about potential possibility of lack of WiFi support
  • pointing users to external USB WiFi adapters.

team: sajolida, cbrownstein


Related issues

Blocked by Tails - Feature #15131: Identify USB Wi-Fi adapters that are easily available and work with Tails Resolved 08/30/2018
Blocks Tails - Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing Resolved 09/11/2018

History

#1 Updated by intrigeri about 3 years ago

  • Target version set to 2017

#2 Updated by BitingBird about 2 years ago

  • Description updated (diff)

#3 Updated by intrigeri about 2 years ago

  • Subject changed from Improve Mac Tails user experience regarding WiFi to Improve Mac Tails user experience regarding Wi-Fi

#4 Updated by sajolida almost 2 years ago

  • Subject changed from Improve Mac Tails user experience regarding Wi-Fi to Improve installation instructions when Wi-Fi is not working (especially on macOS)

#5 Updated by u over 1 year ago

  • Target version changed from 2017 to 2018

#6 Updated by u over 1 year ago

  • Description updated (diff)

#7 Updated by sajolida over 1 year ago

  • Parent task set to #14534

#8 Updated by sajolida over 1 year ago

  • Blocks Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing added

#9 Updated by cbrownstein about 1 year ago

  • QA Check set to Ready for QA

#10 Updated by sajolida about 1 year ago

  • Blocked by Feature #15131: Identify USB Wi-Fi adapters that are easily available and work with Tails added

#11 Updated by sajolida about 1 year ago

  • QA Check deleted (Ready for QA)

I had this ticket assigned to me because I think we should block on #15131 before documenting that.

Right now I don't feel like TL-WN722N (version 1.x) as our only option is a good thing to document because most likely users won't be able to purchase it easly and might purchase instead newer versions that might not work.

I pushed a structural change that I think is important as well. See 871642e7f8.

Please don't work on this again before I do.

#12 Updated by sajolida about 1 year ago

  • Blocks deleted (Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing)

#13 Updated by sajolida about 1 year ago

  • Blocks Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing added

#14 Updated by sajolida 10 months ago

  • Priority changed from Normal to Elevated

Raising priority now that we know which adapters to document.

#15 Updated by sajolida 10 months ago

  • Description updated (diff)

Updating team as per summit 2018.

#16 Updated by sajolida 10 months ago

  • Assignee changed from sajolida to cbrownstein
  • QA Check set to Ready for QA
  • Feature Branch set to doc/11683-broken-wifi

Here is a branch. Finally!

#17 Updated by cbrownstein 10 months ago

  • Assignee changed from cbrownstein to sajolida

I've pushed some changes to my branch. Please review.

https://0xacab.org/cbrownstein/tails/commits/doc/11683-broken-wifi

#18 Updated by sajolida 9 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

I wrote this yesterday already but it seems I didn't press "Submit" or something...

Thanks for the very fast review!

See your commits 28b97313dc and bfc02ee9f8, it seems like you haven't read mine d9005d78bd. When you're doing your reviews, please make sure to always read the Git history, in addition to inspecting the diff. For example with git log -p origin/master..origin/doc/11683-broken-wifi or similar.

I also clarified my intent in the code directly from now with 3b99467cfc.

And merged :)

Also available in: Atom PDF