Project

General

Profile

Bug #11665

Clean up known issues page, 4.0 edition

Added by elouann about 3 years ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
doc/11665-clean-known-issues, https://salsa.debian.org/tails-team/tails/merge_requests/35
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

The known issues page should be updated to remove outdated data:
https://tails.boum.org/support/known_issues

The issues that are in tickets should also be added.


Related issues

Related to Tails - Feature #11687: Known issues: How to recover an Electrum wallet Resolved 08/21/2016
Related to Tails - Bug #11025: Known issues on browser fingerprinting don't mention uBlockOrigin Resolved
Related to Tails - Feature #6551: Link to the known issues for current version from the general ones Confirmed 12/29/2013
Related to Tails - Bug #14505: Merge help desk internal answers to public doc Resolved 07/26/2018
Related to Tails - Feature #14536: Restructure the Known issues page Confirmed 08/30/2017
Related to Tails - Feature #15130: Restructure our support page and content Confirmed 09/28/2013
Blocks Tails - Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing Confirmed 01/08/2016

Associated revisions

Revision 9e1d8d36
Added by intrigeri 2 months ago

Merge remote-tracking branch 'origin/doc/11665-clean-known-issues'

Closes: #11665

History

#1 Updated by u over 2 years ago

  • Subject changed from Cleanup known issue page to Clean up known issues page
  • QA Check set to Dev Needed

Yes, that would be part of front desk work indeed :)

#2 Updated by BitingBird about 2 years ago

  • Assignee changed from elouann to spriver
  • Target version set to 2018

#3 Updated by BitingBird about 2 years ago

  • Related to Feature #11687: Known issues: How to recover an Electrum wallet added

#4 Updated by BitingBird about 2 years ago

  • Related to Bug #11025: Known issues on browser fingerprinting don't mention uBlockOrigin added

#5 Updated by BitingBird about 2 years ago

  • Related to Feature #6551: Link to the known issues for current version from the general ones added

#6 Updated by BitingBird about 2 years ago

  • Description updated (diff)

#7 Updated by BitingBird about 2 years ago

  • Related to Bug #14505: Merge help desk internal answers to public doc added

#8 Updated by BitingBird about 2 years ago

#9 Updated by sajolida almost 2 years ago

  • Related to Feature #15130: Restructure our support page and content added

#10 Updated by u almost 2 years ago

@spriver: are you still interested in working on this ticket? If yes, fine. If not, please reassign to sajolida so that he can advise what to do.

Next steps for anybody taking care of this ticket:

  • ask help desk which data should be removed
  • remove it in a branch
  • assign your branch for review to sajolida.

#11 Updated by u about 1 year ago

  • Assignee changed from spriver to sajolida

Reassigning to sajolida for input.

#12 Updated by sajolida about 1 year ago

Note that help desk might not be the best place to ask about all these issues. Sometimes the Foundation teams might have more info. Or at least we shouldn't block too much on help desk and could look for the information elsewhere.

I want to associate a timestamp to each known issue. Either for when it was added, when it was last updated, or both. I'm not sure yet how to do this but I think it will greatly help the maintenance of this page in the future.

I'll leave this ticket assigned to me but feel free to steal it from me!

#13 Updated by sajolida 10 months ago

  • Target version changed from 2018 to 2019

#14 Updated by sajolida 3 months ago

  • Target version changed from 2019 to Tails_3.16

I started working on this.

#15 Updated by sajolida 3 months ago

  • Blocks Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing added

#16 Updated by sajolida 3 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from sajolida to goupille

I'm done with everything I could do on my own. I'm now waiting for feedback from help desk on 3 topics:

  • [internal] problematic PNY USB sticks (August 10, 15:10)
  • [internal] Can't display WebM (August 10, 16:30)
  • [internal] Tails fails to connect to certain Wi-Fi networks (August 17, 11:05)

#17 Updated by sajolida 3 months ago

  • Assignee changed from goupille to emmapeel

Reassigning to this week's help desker.

Please tell me if you don't have these emails and I'll resend them back to you.

#18 Updated by sajolida 3 months ago

Making sure that @emmapeel receives an email for that.

#19 Updated by sajolida 3 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from emmapeel to intrigeri

I confirmed with emmapeel that the 3 could be removed as well.

@intrigeri: Do you mind reviewing the whole branch? It has to do more with validating my analysis of each issue than about writing so I think it makes more sense for the Foundations Team to do it than Cody.

#20 Updated by intrigeri 3 months ago

intrigeri: Do you mind reviewing the whole branch?

Will do!

#21 Updated by intrigeri 3 months ago

  • Feature Branch set to doc/11665-clean-known-issues

#22 Updated by intrigeri 3 months ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from intrigeri to sajolida
  • Feature Branch changed from doc/11665-clean-known-issues to doc/11665-clean-known-issues, https://salsa.debian.org/tails-team/tails/merge_requests/35

I've spotted only two problems \o/

I was too lazy to do without inline commenting so I did the review on Salsa: https://salsa.debian.org/tails-team/tails/merge_requests/35

You may either get yourself an account on Salsa and reply there, or reply here: as you wish!

#23 Updated by sajolida 2 months ago

  • Subject changed from Clean up known issues page to Clean up known issues page, 4.0 edition

#24 Updated by sajolida 2 months ago

  • Target version changed from Tails_3.16 to Tails_3.17

#25 Updated by sajolida 2 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from sajolida to intrigeri

Regarding eca60b197d:

  • Acer ES-1-331 was added in 5682390959 as "Does not start on USB sticks created using Tails Installer". We don't really know if "edd=off" is really needed to start on this laptop (and we learn from #16926#note-6 that sometimes people tweak their boot options with no reason). This original description actually rather seems to mean that it might have been able to start on USB stick created using dd back in 2015.
  • The `edd=off` workaround is also still documented as something to try in /install/win/usb so, if it's needed, people can still find it there.

I'd rather not add hypothetical workarounds to our list of known issues partly because they are harder to get rid of over time.

Regarding "startup options":

  • Until now we've sometimes written 'startup options' in /support/known_issues to mean 'boot option' while we've already better at making a difference between 'startup option' and 'boot option' in both /doc/first_steps/startup_options and /install/inc/steps/restart_first_time.inline (inside the troubleshooting section about Tails not starting entirely).
  • I've checked the rest of our website, and the only inconsistencies left were in /support/known_issues/graphics. I fixed that with 809ffdf4fd.

#26 Updated by intrigeri 2 months ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from intrigeri to sajolida

OK, merged!

My only remaining concern is the one I raised about the style guide itself, more specifically:

<a id="startup-options"></a>

- **startup options**

  To refer to the kernel command line options that can be specified from
  the *Boot Loader Menu*.

  - *For example:*

    - Adding `radeon.dpm=0` to the [[startup
      options|/doc/first_steps/startup_options#boot_menu]].

It's the reason why I've kept using "startup options" when documenting known issues. It contradicts and somewhat duplicates what **boot** vs **start** says, no?

I'm worried that as long as it's like this, I will keep mistakenly using "startup options" when I should write "boot options".

#27 Updated by intrigeri 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#28 Updated by intrigeri 2 months ago

  • Target version changed from Tails_3.17 to Tails_4.0

#29 Updated by sajolida about 2 months ago

  • Assignee deleted (sajolida)

Ok! Indeed our style guide was itself inconsistent. Fixed now with 8549628e78.

Also available in: Atom PDF