Project

General

Profile

Bug #11663

Clarify the scope of hardware support

Added by goupille over 3 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
08/19/2016
Due date:
% Done:

0%

Feature Branch:
doc/11663-better-system-requirements
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

since Tails 2.0, Tails doen't support old hardware (i.e. released before 2010 with low RAM amount) as it has done in the past, and, in the same time, partialy due to the use of the 3.16 kernel, doesn't support very well newer hardware (Intel Skylake, NVidia GeForce 900 series...).

I think that we should be more prepared when implementing changes that would break hardware support.

Also I think we should choose between keeping up with the reputation Tails had about working well on old configurations or be sure to support (not that) new and fancy hardware.


Related issues

Related to Tails - Feature #8183: Ship a 64-bit (x86_64) instead of 32-bit userspace Resolved 10/11/2016
Blocks Tails - Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing Resolved 09/11/2018

Associated revisions

Revision 8c129ade (diff)
Added by intrigeri almost 3 years ago

Hardware requirements: don't pretend most computers from 2005-2008 will support Tails 3.0.

refs: #11663, #8183

Revision 7d6b2376 (diff)
Added by intrigeri almost 3 years ago

Hardware requirements: update processor link (x86 → x86-64).

refs: #11663, #8183

History

#1 Updated by emmapeel over 3 years ago

  • Subject changed from clarifying the scope of hardware support to Clarifying the scope of hardware support
  • Category set to Hardware support
  • Status changed from New to Confirmed

#2 Updated by intrigeri about 3 years ago

goupille wrote:

I think that we should be more prepared when implementing changes that would break hardware support.

Agreed.

Data points wrt. Tails 2.0:

  • support for old hardware can be broken for 2 main reasons:
    • no support for accelerated graphics needed by GNOME Shell: we did some testing (#7988) but I guess we did not check enough graphics hardware; next time we should issue an explicit call for testing on tails-testers@ and Twitter earlier (before the beta1), in the hope that it gives us more info earlier, and leaves you folks more time to get ready / shout / demand or write more documentation
    • lack of memory: we bumped the RAM requirement months before 2.0 was out (#9929), so I don't think that this is relevant here
  • support for shiny new hardware (e.g. Intel Skylake, some NVidia): it seems that GNOME Shell requires good drivers, while Metacity could deal with some low-performance compatibility mode; this is not something I had in mind, sorry; I would hope that here as well, more and earlier calls for testing would allow us to be better prepared
  • Tails 2.0 fixed quite a number of hardware support issues (one example: #7817)

=> call for testing earlier, louder, and get frontdesk involved in it earlier as well so that they don't discover the changes after we've shipped them to users. Anything else we can do to be more prepared?

Also I think we should choose between keeping up with the reputation Tails had about working well on old configurations or be sure to support (not that) new and fancy hardware.

I am not sure I understand why we should choose, except perhaps as a way to prioritize our engineering efforts: we will alway miss support for some new hardware, and we will always have to drop support for older hardware from time to time. Maybe rephrase this idea to help me understand it better?

#3 Updated by sycamoreone about 3 years ago

  • Related to Feature #8183: Ship a 64-bit (x86_64) instead of 32-bit userspace added

#4 Updated by sycamoreone about 3 years ago

  • Assignee set to goupille

This ticket was on the agenda for the September 2016 monthly meeting, but it wasn't clear, what question we should discuss and answer.

@goupille: Could you clarify what concrete result you are envisioning?

#5 Updated by goupille about 3 years ago

  • Assignee deleted (goupille)

sorry, it appears I missed the meeting (for whatever reason I thought it was the 13th...)
my last sentence is not very clear to me either :)

my question was, "what should/could we do to support users with either old or new hardware ?"

I think that people are using tails on rather old laptop for two reasons :

- because they do not have the money to buy a newer computer
- because they want to keep using/recycle laptops that regular OS doesn't support anymore

so telling these users "sorry you can't use Tails, just change your computer" is hard ethically.

and telling people with brand new nvidia stuff that need a patched kernel or whatever weird driver, that "Tails won't support your hardware for months because debian sid is not supporting it yet, and even if it was supporting it, Tails is based on the stable release, so you'll have to wait" eventually begin an endless discussion about that.

maybe it could be clearer on https://tails.boum.org/doc/about/requirements that, even if it is sad, there are old hardware that will not work anymore with Tails, and that there could be some issues with brand new hardware (like on every linux distributions)

#6 Updated by sajolida about 3 years ago

  • Type of work changed from Discuss to End-user documentation

So this is a writing ticket to be more clear on /doc/about/requirements that super new hardware might have problems. And maybe think about updating the part about "manufactured after 2005".

#7 Updated by intrigeri almost 3 years ago

  • Subject changed from Clarifying the scope of hardware support to Clarify the scope of hardware support

#8 Updated by u almost 2 years ago

  • Assignee set to goupille
  • QA Check set to Info Needed

I think many concerns this ticket is about have been addressed.

The text currently reads

Tails works on most reasonably recent computers, say manufactured after 2008. Here is a detailed list of requirements:

* Either an internal or external DVD reader or the possibility to boot from a USB stick.
* Tails requires a 64-bit x86-64 compatible processor: IBM PC compatible and others but not PowerPC nor ARM. Mac computers are IBM PC compatible since 2006. Tails does not run on most tablets and phones.
* 2 GB of RAM to work smoothly. Tails is known to work with less memory but you might experience strange behaviours or crashes.

We could add:

* There might be issues with brand new hardware missing Linux drivers.

And then we link to the know issues anyway.

@goupille: does this address your concerns? If yes, either you propose a branch or you assign this ticket back to a tech writer. If no, I let you make a better proposal.

If you think this is not necessary anymore, please close the ticket by marking it as resolved.

#9 Updated by goupille almost 2 years ago

  • Assignee changed from goupille to sajolida

@goupille: does this address your concerns? If yes, either you propose a branch or you assign this ticket back to a tech writer. If no, I let you make a better proposal.

I agree with your proposal, but I'm not able to "propose a branch" so reassigning this to sajolida

#10 Updated by sajolida 10 months ago

  • Related to Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing added

#11 Updated by sajolida 10 months ago

  • Related to deleted (Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing)

#12 Updated by sajolida 10 months ago

  • Blocks Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing added

#13 Updated by sajolida 9 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from sajolida to goupille
  • Target version set to Tails_3.13
  • Feature Branch set to doc/11663-better-system-requirements

Here is a branch.

I'd like both intrigeri and goupille to have look before merging it.

#14 Updated by intrigeri 9 months ago

I'd like both intrigeri and goupille to have look before merging it.

Sure!

Looks like a good Spring cleaning to me :) Only one comment: I find "recent computers less than 10 years old" a bit confusing: is "recent" a synonym for "less than 10 years old" (and then maybe drop "recent") or is it supposed to add some more info (in which case I don't get what info that is).

#15 Updated by intrigeri 9 months ago

@goupille: ping (just in case you did not notice this landed on your plate :)

#16 Updated by CyrilBrulebois 8 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#17 Updated by intrigeri 7 months ago

@goupille, in case having to use Git on the command line makes it harder than needed for you to take a look at sajolida's proposal, GitLab's branch comparison feature might help:

https://salsa.debian.org/tails-team/tails/compare/master...doc%2F11663-better-system-requirements

:)

#18 Updated by CyrilBrulebois 6 months ago

  • Target version changed from Tails_3.14 to Tails_3.15

#19 Updated by intrigeri 6 months ago

  • Status changed from In Progress to Needs Validation
  • QA Check deleted (Info Needed)

#20 Updated by goupille 5 months ago

  • Assignee changed from goupille to sajolida

thanks intrigeri !

I'm very sorry for the long delay, I agree with intrigeri about the "recent" VS "less than 10 years old", but except that, I think it is great !

#21 Updated by sajolida 5 months ago

  • Status changed from Needs Validation to Resolved
  • Assignee deleted (sajolida)

I love it when people improve my sentences :)

Done in 75ae597446 and merged.

Also available in: Atom PDF