Project

General

Profile

Bug #11662

XkbComp complains (warning) and spams the logs

Added by goupille about 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/18/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

since Tails 2.0, in every whisperback reports, there are hundreds of

amnesia gdm-Xorg-:0[2053]: The XKEYBOARD keymap compiler (xkbcomp) reports:
amnesia gdm-Xorg-:0[2053]: > Warning:          Compat map for group 2 redefined
amnesia gdm-Xorg-:0[2053]: >                   Using new definition
amnesia gdm-Xorg-:0[2053]: > Warning:          Compat map for group 3 redefined
amnesia gdm-Xorg-:0[2053]: >                   Using new definition
amnesia gdm-Xorg-:0[2053]: > Warning:          Compat map for group 4 redefined
amnesia gdm-Xorg-:0[2053]: >                   Using new definition
amnesia gdm-Xorg-:0[2053]: Errors from xkbcomp are not fatal to the X server

I don't know at all why it is complaining, but, as in #11661, even if it is not a critical error, it make the user-support job a lot harder than it could be.


Related issues

Related to Tails - Bug #11661: gnome-settings-daemon warns (a lot) about missing PackageKit Resolved 08/18/2016
Related to Tails - Bug #13174: Nautilus complains a lot about failed assertion, spamming the logs Rejected 06/27/2017

History

#1 Updated by goupille about 3 years ago

  • Assignee set to segfault

#2 Updated by intrigeri about 3 years ago

IMO we should teach tails-debugging-info to filter out a list of regexps, and then frontdesk can add to that list of regexps (or provide enough example lines so that someone else can infer what new regexp should be added).

#4 Updated by intrigeri about 3 years ago

  • Related to Bug #11661: gnome-settings-daemon warns (a lot) about missing PackageKit added

#5 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (segfault)
  • Target version set to Tails_3.0
  • % Done changed from 0 to 100

I cannot reproduce this on 3.0~beta1. Feel free to reopen if you can, along with instructions to reproduce it :)

#6 Updated by emmapeel over 2 years ago

  • Related to Bug #13174: Nautilus complains a lot about failed assertion, spamming the logs added

Also available in: Atom PDF