Project

General

Profile

Feature #11636

Replace apt-transport-tor with APT 1.3's Tor or SOCKS5h support

Added by intrigeri over 3 years ago. Updated over 3 years ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
08/12/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

apt (1.3~rc1) unstable; urgency=medium

  * Summary: [...] socks5h (and tor) support [...]
[...]
  * http: auto-configure for local Tor proxy if called as 'tor'

It seems that we could simply use tor:// instead of tor+http:// everywhere, and drop apt-transport-tor. Alternatively, and probably nicer: we could also just use http:// and use APT 1.3's socks5h support.


Related issues

Related to Tails - Feature #8198: Replace tor+http shim with apt-transport-tor Resolved 11/03/2014
Blocked by Tails - Bug #10289: Tails based on Debian Stretch Resolved 09/27/2015

History

#1 Updated by intrigeri over 3 years ago

  • Related to Feature #8198: Replace tor+http shim with apt-transport-tor added

#2 Updated by intrigeri over 3 years ago

  • Subject changed from Replace apt-transport-tor with APT 1.3's Tor support to Replace apt-transport-tor with APT 1.3's Tor or SOCKS5h support
  • Description updated (diff)

#3 Updated by intrigeri over 3 years ago

  • Priority changed from Low to Normal
  • Target version deleted (Tails_3.0)

#4 Updated by intrigeri over 3 years ago

  • Blocked by Bug #10289: Tails based on Debian Stretch added

Also available in: Atom PDF