Project

General

Profile

Bug #11606

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

"Tor Launcher uses all expected TBB shared libraries" is fragile

Added by intrigeri over 3 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Test suite
Target version:
Start date:
07/29/2016
Due date:
% Done:

100%

Feature Branch:
https://salsa.debian.org/tails-team/tails/merge_requests/33
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Tor Launcher

Description

And the Tor Launcher uses all expected TBB shared libraries
Command failed: find /usr/lib /lib -name "libnssutil3.so" 
error code: 1
stderr: find: `/lib/live/mount/overlay/var/tmp/systemd-private-9a29e2ac5e134767bdb750c1f0108468-systemd-hostnamed.service-23b1BY/tmp': No such file or directory
.
is not true. (ExecutionFailedInVM)
./features/support/helpers/vm_helper.rb:442:in `rescue in execute_successfully'
./features/support/helpers/vm_helper.rb:439:in `execute_successfully'
./features/step_definitions/browser.rb:145:in `block in xul_app_shared_lib_check'
./features/step_definitions/browser.rb:140:in `each'
./features/step_definitions/browser.rb:140:in `xul_app_shared_lib_check'
./features/step_definitions/browser.rb:166:in `/^the (.*) uses all expected TBB shared libraries$/'
features/tor_bridges.feature:12:in `And the Tor Launcher uses all expected TBB shared libraries'

Associated revisions

Revision da26fc1d (diff)
Added by intrigeri over 3 years ago

Test suite: mark tests that use Tor Launcher as fragile (refs: #11606).

Revision 5fb4077a (diff)
Added by intrigeri over 3 years ago

Revert "Test suite: mark tests that use Tor Launcher as fragile (refs: #11606)."

This reverts commit da26fc1d9399c8ae909f1b78a25fbbaa4fd35ca0.

Revision e96dbd19 (diff)
Added by intrigeri 4 months ago

Test suite: update reason why these tests are fragile (refs: #11606)

The step "the Tor Launcher uses all expected TBB shared libraries" step has
never failed on Jenkins in the last 2 months. But these scenarios
have failed a number of time due to "Tor is ready" failing, which I assume
is because of time sync' problems.

Revision a7ca22af
Added by Sandro Knauß 4 months ago

Merge remote-tracking branch 'test/update-fragile-tags' into devel (refs: #16281, #11890)

Closes: #13470, #11606, #11457, #11563, #11591
Closes: #10499, #11584, #11414, #11453, #11463

History

#1 Updated by intrigeri 4 months ago

  • Status changed from Confirmed to In Progress

#2 Updated by intrigeri 4 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee set to hefee
  • Target version set to Tails_4.0
  • Feature Branch set to https://salsa.debian.org/tails-team/tails/merge_requests/33

#3 Updated by Anonymous 4 months ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF