Project

General

Profile

Bug #11605

Upgrade the QEMU machine type used in our test suite and stop supporting Jessie for running the test suite

Added by intrigeri over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
Test suite
Target version:
Start date:
07/29/2016
Due date:
% Done:

100%

Feature Branch:
feature/11739-stretch-isotesters
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

We should switch to Q35 or newer, in order to be closer to real hardware that Tails is currently used with. This should be trivially doable once we use Stretch as the platform to run our test suite (see commit:b6bb39e for details).

Associated revisions

Revision f11583b7 (diff)
Added by intrigeri over 2 years ago

Test suite: run a Q35 (2.8) machine (refs: #11605).

Revision 85932ba3 (diff)
Added by intrigeri over 2 years ago

Test suite setup doc: adjust for Stretch (and drop Jessie support).

refs: #11605

Revision d9b23daf
Added by intrigeri over 2 years ago

Merge branch 'feature/11739-stretch-isotesters' into feature/stretch (Fix-committed: #11605).

History

#1 Updated by intrigeri over 3 years ago

  • Description updated (diff)
  • Category set to Test suite

#2 Updated by intrigeri about 3 years ago

#3 Updated by intrigeri over 2 years ago

anonym and I agreed that this can be done on feature/stretch once 2.12 is out.

#4 Updated by intrigeri over 2 years ago

  • Feature Branch set to wip/feature/11739-stretch-isotesters

#5 Updated by intrigeri over 2 years ago

  • Subject changed from Upgrade the QEMU machine type used in our test suite to Upgrade the QEMU machine type used in our test suite and stop supporting Jessie for running the test suite

#6 Updated by intrigeri over 2 years ago

  • Feature Branch changed from wip/feature/11739-stretch-isotesters to feature/11739-stretch-isotesters

#7 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

#8 Updated by intrigeri over 2 years ago

  • % Done changed from 10 to 20

Wow, the first test run of this branch on Jenkins was successful, which never happened since almost 2 months for feature/stretch. I'll wait for fresh results about feature/stretch before I draw any conclusion (it might be that updating the isotesters to Stretch was enough to make things better), and then I'll merge this branch into feature/stretch.

#9 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to 11
  • % Done changed from 20 to 100

#10 Updated by intrigeri over 2 years ago

  • Assignee deleted (intrigeri)

#11 Updated by intrigeri over 2 years ago

  • Blocked by deleted (Feature #11739: Upgrade our isotesters to Stretch)

#12 Updated by intrigeri over 2 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF