Project

General

Profile

Feature #11569

Have AppStream metadata for Tails Installer

Added by sajolida over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
Installation
Target version:
Start date:
07/16/2016
Due date:
% Done:

100%

Feature Branch:
tails-installer:feature/11569-appstream-metadata
Type of work:
Debian
Blueprint:
Starter:
Affected tool:
Installer

Description

According to https://www.freedesktop.org/software/appstream/docs/: "AppStream is a cross-distro effort for enhancing the way we interact with the software repositories provided by the distribution by standardizing sets of additional metadata".

It is a requirement to be listed in GNOME Software which is the only graphical tool available in Ubuntu 16.04. So until we have AppStream metadata people will have to go through to command line to install Tails Installer on Ubuntu 16.04 and later. See #11004#note-10.

Other resources:

0001-Added-an-AppStream-metadata-file.patch View (1.97 KB) muri, 07/16/2016 05:59 AM

0002-Add-the-AppStream-metadata-file-to-the-files-to-be-i.patch View (923 Bytes) muri, 07/16/2016 05:59 AM


Related issues

Blocks Tails - Feature #11378: Make Tails Installer installable through Ubuntu Software Rejected 05/09/2016

History

#1 Updated by sajolida over 3 years ago

  • Assignee set to u
  • QA Check set to Info Needed

u: Do you think you could work on this? I don't mind helping with filling up the XML file but I'm not sure I can figure out what's required, where to fit this in the source code, and test stuff without going nut. We could also ask help to muri who's interested in learning Debian packaging. AppStream will become a standard for graphical apps so something to know to create Debian packages in the future.

Note: not having this is quite serious for Ubuntu 16.04 users but I'll try to document a workaround until we get there.

#2 Updated by sajolida over 3 years ago

  • Description updated (diff)

#3 Updated by sajolida over 3 years ago

  • Blocks Feature #11378: Make Tails Installer installable through Ubuntu Software added

#4 Updated by intrigeri over 3 years ago

First step happens upstream: create the XML file (a recent Debian system has plenty of examples in /usr/share/appdata/, for those who are more comfortable with examples than with specs) and adjust setup.py. It may very well be that no change is needed in the Debian packaging.

#5 Updated by muri over 3 years ago

attached two patches, one adds the appstream metadata file (based on the one from eog, remove a lot of stuff and then compared with the one from onionshare). with that file tails-installer shows up in gnome-software.
the second patch adds the file to the files to be installed on linux (i don't know python very well or setuptools at all)

#6 Updated by intrigeri over 3 years ago

  • Target version set to Tails_2.6

u, wanna review this during the 2.6 cycle? Otherwise reassign to our RM for 2.6 (anonym).

#7 Updated by sajolida over 3 years ago

  • Assignee changed from u to sajolida

I'll have a look first as this is basically about describing Tails Installer to people who might not yet know what it is. Then I'll pass on to u for the more technical review and testing.

And since we're doing this basically to fix the Ubuntu installation, could it be considered as a bugfix branch? Of course, RM will have the last say :)

#8 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to u
  • Feature Branch set to feature/11569-appstream-metadata

Cool, that was easier than I thought! I pushed a bunch of commits in feature/11569-appstream-metadata.

#9 Updated by intrigeri over 3 years ago

Cool, that was easier than I thought! I pushed a bunch of commits in feature/11569-appstream-metadata.

Just to be clear: was the resulting file successfully tested with GNOME Software?

#10 Updated by sajolida over 3 years ago

No. I only reviewed the human content from Muri. I didn't check the specs, the formatting nor tested it.

#11 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress

#12 Updated by muri over 3 years ago

intrigeri wrote:

Cool, that was easier than I thought! I pushed a bunch of commits in feature/11569-appstream-metadata.

Just to be clear: was the resulting file successfully tested with GNOME Software?

well, i copied the appdata file to /usr/share/appdata/tails-installer.appdata.xml by hand and it showed up in gnome-software in the list of installed software. i now also built a .deb with the changes and after installing it, tails-installer shows up in gnome-software in the list of installed software. i've no idea how to test if it shows up in the list of software that can be installed- i don't know how gnome-software gets that information...

#13 Updated by anonym about 3 years ago

  • Target version changed from Tails_2.6 to Tails_2.7

#14 Updated by u about 3 years ago

gnome-software is currently available only in Debian testing and sid.

#15 Updated by u about 3 years ago

  • Target version changed from Tails_2.7 to Tails_2.9.1

I started to review this but did not test it fully yet. Won't be ready for the next release.

#16 Updated by anonym almost 3 years ago

  • Target version changed from Tails_2.9.1 to Tails 2.10

#17 Updated by anonym almost 3 years ago

  • Target version changed from Tails 2.10 to Tails_2.11

#18 Updated by anonym over 2 years ago

  • Target version changed from Tails_2.11 to Tails_2.12

#19 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_2.12 to Tails_3.0

Feel free to reassign to the RM if you prefer someone else to complete this review :)

#20 Updated by intrigeri over 2 years ago

  • Priority changed from Normal to Elevated

(This blocks #11378 that sajolida wants to tackle in 2017Q2, for good reasons IMO since our instructions have been broken on Ubuntu since a year => bumping priority.)

#21 Updated by u over 2 years ago

  • Assignee changed from u to anonym

Reassiging to anonym to complete this review. thanks!

#22 Updated by anonym over 2 years ago

  • Feature Branch changed from feature/11569-appstream-metadata to tails-installer:feature/11569-appstream-metadata

#23 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_3.0 to Tails_3.0~rc1
  • % Done changed from 30 to 80
  • QA Check changed from Ready for QA to Pass

I've tried to validate this file with:

appstream-util validate data/tails-installer.appdata.xml
appstream-util validate-relax data/tails-installer.appdata.xml
appstream-util validate-strict data/tails-installer.appdata.xml

… and got a bunch of errors. I've fixed the most important ones and now:

  • validate-relax is happy
  • validate only complains about <screenshot> width too small [https://screenshots.debian.net/screenshots/000/014/555/large.png]
  • validate-strict complains about:
    • <screenshot> aspect ratio not 16:9 [https://screenshots.debian.net/screenshots/000/014/555/large.png]
    • missing translations

IMO that's good enough so I've merged it into the master branch. But it would be nice if muri or u could create a ticket about the 2 remaining screenshot issues :)

anonym, please make sure you pull current master when you build a new package for 3.0~rc1.

#24 Updated by intrigeri over 2 years ago

  • Assignee changed from anonym to u
  • Target version changed from Tails_3.0~rc1 to Tails_3.0
  • Type of work changed from Code to Debian

tails-installer (4.4.14+dfsg-0tails1) fixes this. Next step is to get it into Debian and Ubuntu, as that's where this change will matter => reassigning to our packages maintainer. Please set an adequate target version.

#25 Updated by u over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

I have already uploaded these packages to Debian and Ubuntu a week ago.
The last remaining thing to do is to build and upload a backport for Jessie.
This is on my todo list, thus closing this ticket.

Also available in: Atom PDF