Project

General

Profile

Bug #11561

Add Linut Mint to installation assistant

Added by sajolida over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
07/12/2016
Due date:
% Done:

0%

Feature Branch:
doc/11561-linux-mint
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Installation Assistant

Description

Tails Installer is available in Linux Mint Sarah. Mint is a very popular distribution and the process is very close to the one from Debian. So it would be good to advertise the Debian installation as working for Mint as well and adapt it accordingly.

There are two ways of installation Tails Installer in Mint: Synaptic and Software Manager, which is a custom tool from Mint.

Note that the Software Sources dialog of Mint (in both Software Manager and Synaptic) is custom as well. Enjoy...

Here are some notes on both methods:

  • With Software Manager
    1. Start Software Manager.
    2. Choose EditSoftware source.
    3. PPAs tab.
    4. Add a new PPA....
      ppa:tails-team/tails-installer
    5. Update the cache.
    6. Close dialog.
    7. Wait for Software Manager to reappear.
    8. Search tails-installer.
  • With Synaptic
    1. Menu → System → Package Manager.
    2. Settings → Repositories.
    3. PPAs tab.
    4. Add a new PPA....
      ppa:tails-team/tails-installer
    5. Close dialog.
    6. In Synaptic: Reload.
    7. Wait while "Rebuild search index".
    8. Search tails-installer.
    9. Mark for installation.
    10. etc.

ppa description.png View (20.1 KB) sajolida, 07/12/2016 12:35 AM

software manager.png View (25.8 KB) sajolida, 07/12/2016 12:35 AM

software sources.png View (44 KB) sajolida, 07/12/2016 12:35 AM

software sources with ppa.png View (60.5 KB) sajolida, 07/12/2016 12:35 AM


Related issues

Related to Tails - Feature #11404: Rewrite Ubuntu instructions to install Tails Installer from Synaptic Rejected 05/09/2016
Related to Tails - Feature #11378: Make Tails Installer installable through Ubuntu Software Rejected 05/09/2016

Associated revisions

Revision 0e085c9d
Added by sajolida over 3 years ago

Merge remote-tracking branch 'spriver/doc/11561-linux-mint' (Closes: #11561)

History

#1 Updated by sajolida over 3 years ago

  • Related to Feature #11404: Rewrite Ubuntu instructions to install Tails Installer from Synaptic added

#2 Updated by sajolida over 3 years ago

  • Related to Feature #11378: Make Tails Installer installable through Ubuntu Software added

#4 Updated by sajolida over 3 years ago

  • Description updated (diff)

Since Synaptic is not the way forward in Ubuntu, see #11004#note-10 and that we can't reuse the instructions for Synaptic on Debian because the source management is different, then I think we should document using the custom Software Manager of Mint.

#5 Updated by sajolida over 3 years ago

Mint might be as popular as Debian, so it seems to make sense to mention it in all the titles as well:

Still, to make it a bit shorter, lets write "Mint" in titles and buttons and "Linux Mint" in body of pages.

#6 Updated by sajolida over 3 years ago

  • Target version set to Tails_2.5
  • QA Check set to Ready for QA

#7 Updated by sajolida over 3 years ago

I'll send a mail to BitingBird, emmapeel, spriver, and muri to see if one of them wants to review this.

#8 Updated by sajolida over 3 years ago

  • Feature Branch set to doc/11561-linux-mint

#9 Updated by spriver over 3 years ago

  • Assignee set to spriver

#10 Updated by spriver over 3 years ago

  • Assignee changed from spriver to sajolida
  • Feature Branch changed from doc/11561-linux-mint to spriver:doc/11561-linux-mint

I did some minor changes. Reviewing them should be little work.

#11 Updated by sajolida over 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)
  • Feature Branch changed from spriver:doc/11561-linux-mint to doc/11561-linux-mint

Thanks for the fixes. I'm merging now!

Also available in: Atom PDF