Project

General

Profile

Bug #11545

Make "Online Accounts" work in Tails or hide them

Added by sajolida about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
06/24/2016
Due date:
% Done:

100%

Feature Branch:
bugfix/11545-hide-gnome-online-accounts
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Right now in Tails you can open the configuration for GNOME Online Account, like ownCloud but they are not configured to go through Tor so they fail. For example I tried connecting to the ownCloud instance of my email provider and got a "Dropped outbound packet" to its IP in the logs.

I tried to configure a system SOCKS proxy for GNOME but this didn't work either.

From a user's point of view this option ("Settings → Online Accounts") should either work or not exist, as otherwise it create a false hope and might lead the user to believe that they are the ones doing something wrong.

I would personally love to be able to use ownCloud in Tails :)


Related issues

Related to Tails - Bug #9810: Bluetooth options in System settings has no icon Confirmed 07/28/2015

Associated revisions

Revision 2a8179bf (diff)
Added by muri about 3 years ago

added gnome-online-accounts to the files to be deleted

refs: #11545

Revision 4657f96f (diff)
Added by intrigeri about 3 years ago

Nitpick: sort by lexical order.

refs: #11545

History

#1 Updated by sajolida about 3 years ago

  • Related to Bug #9810: Bluetooth options in System settings has no icon added

#2 Updated by intrigeri about 3 years ago

Patching /usr/share/applications/gnome-online-accounts-panel.desktop (e.g. drop "GNOME" from OnlyShowIn=) might be enough to hide this icon. This should be done using sed or perl in a config/chroot_local-hooks/.

Alternatively, an equivs (fake) package for gnome-online-accounts can be installed, but it might break random bits of GNOME in a way that's hard to notice (initially) and debug (later), so I'd rather not take this heavy handed approach.

#3 Updated by muri about 3 years ago

  • Assignee set to muri
  • Type of work changed from Research to Code

i'll take that one

#4 Updated by muri about 3 years ago

  • File 0001-make-gnome-online-accounts-unaccessible-for-the-tail.patch added
  • Status changed from Confirmed to In Progress
  • Assignee deleted (muri)
  • % Done changed from 0 to 30
  • QA Check set to Ready for QA

hi,
removing the GNOME from OnlyShowIn didn't work (i guess the gnome-control-center uses different system of selecting desktop files), but i've changed the mode of the file, so the tails user can not access it, which worked.
i've added this to config/chroot_local-hooks/54-menu bc this is a menu modification.

#5 Updated by intrigeri about 3 years ago

  • Assignee set to muri
  • QA Check changed from Ready for QA to Dev Needed

removing the GNOME from OnlyShowIn didn't work (i guess the gnome-control-center uses different system of selecting desktop files), but i've changed the mode of the file, so the tails user can not access it, which worked.

Good! Maybe let's just delete the file, then? This sounds safer (less chances that g-c-c some day starts crashing because of blocked access), and more consistent with how we handle similar other things.

Bonus points if you use dpkg-divert instead of rm, so that this tweak survives a package upgrade, but I know that we're already rm'ing stuff all over the place, so really that's your call.

i've added this to config/chroot_local-hooks/54-menu bc this is a menu modification.

Makes sense to me.

#6 Updated by muri about 3 years ago

  • File deleted (0001-make-gnome-online-accounts-unaccessible-for-the-tail.patch)

#7 Updated by muri about 3 years ago

hi, i've updated the patch and simply added the path to the already existing list of files that are deleted.

i've looked into dpkg-divert, but as far as i can say, its not possible to simply delete files. what would be possible is to rename the file

dpkg-divert --local --divert /usr/share/applications/gnome-online-accounts-panel.desktop.tails-deleted --rename /usr/share/applications/gnome-online-accounts-panel.desktop

or to use dpkg-statoverride and change the permissions but that would also involve the possibility of g-c-c crashing.

i didn't know if it should be the debian-way solution or the safe-disk-space solution, so i chose the way it was already implemented for other files ;)

#8 Updated by intrigeri about 3 years ago

  • Assignee set to intrigeri
  • Target version set to Tails_2.5

hi, i've updated the patch and simply added the path to the already existing list of files that are deleted.

Great! Will review shortly.

i didn't know if it should be the debian-way solution or the safe-disk-space solution, so i chose the way it was already implemented for other files ;)

Makes sense, totally reasonable.

#9 Updated by intrigeri about 3 years ago

  • % Done changed from 30 to 50
  • Feature Branch set to bugfix/11545-hide-gnome-online-accounts

Imported into a branch, fixed conflicts, added a nitpicking commit on top. Static code review passes.

#10 Updated by intrigeri about 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Merged!

#11 Updated by intrigeri about 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF