Project

General

Profile

Feature #11539

Don't ship the testing and unstable APT sources

Added by anonym almost 3 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
-
Start date:
06/20/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

I.e. only have them enabled while building Tails -- after that they're arguably of little use since users should install stable packages. This would significantly speed up `apt update` -- right now we have to fetch almost 40 MiB, but after removing testing and unstable only 13.5 MiB is fetched, so a ~200% speed-up can be expected.


Related issues

Related to Tails - Feature #12237: Reduce apt update time during first start of Tails Server Resolved 02/14/2017

History

#1 Updated by muri almost 3 years ago

  • Type of work changed from Discuss to Research

We talked about that ticket at the monthly meeting:

Segfault explained that the reason for this ticket was that Tails Server needs
to download the packge list the first time a service is installed, which takes
a long time at the moment (30 seconds instead of 2 to 10 minutes).
There could be corner cases where this could break stuff. intrigeri: "say we
pull pkg P1 from sid, and then user wants to install package P2 themselves, and
it depends on P3 but the version of P3 in stable conflicts with the version of
P1 in stable, so the user would need to install P3 from sid, but we just broke
that for them."
We decided that this ticket needs more research into possible corner cases that
could be broken.

#2 Updated by intrigeri almost 3 years ago

anonym, I see that you've added this to our 2016 roadmap. Does this imply you want to commit to make it happen? If so, please assign this ticket to you; otherwise, maybe raise the topic on tails-dev hoping that someone volunteers to do the research?

#3 Updated by Dr_Whax almost 3 years ago

  • Priority changed from Normal to Elevated
  • Target version deleted (2016)

#4 Updated by segfault over 2 years ago

  • Related to Feature #12237: Reduce apt update time during first start of Tails Server added

#5 Updated by anonym over 2 years ago

muri wrote:

There could be corner cases where this could break stuff. intrigeri: "say we
pull pkg P1 from sid, and then user wants to install package P2 themselves, and
it depends on P3 but the version of P3 in stable conflicts with the version of
P1 in stable, so the user would need to install P3 from sid, but we just broke
that for them."

Good point! I don't see how this could be solved. I'm in favor of closing this ticket; at least I won't work on it any further.

#6 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to Rejected

Also available in: Atom PDF