Project

General

Profile

Bug #11518

Linux 4.x QXL 64-bit kernel modesetting breaks 32-bit X.Org

Added by intrigeri over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Hardware support
Target version:
Start date:
06/08/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

With Linux 4.x we get KMS for QXL enabled by default. But then, when mixing a 64-bit kernel with 32-bit userspace, X.Org fails to start and says something like: "failed to set DRM interface version 1.4: Inappropriate ioctl for device".

What works:

  • booting with the 32-bit kernel (I'm starting to really want #8183)
  • qxl.modeset=0

I've tried a local xserver-xorg-video-qxl 0.1.4-3~bpo8+1 backport, but it did not help.

This affects feature/10298-linux-4.x-aufs (#10298) and feature/stretch (KMS is required since X.Org runs as non-root; and maybe #11441 too).


Related issues

Related to Tails - Bug #11441: Stretch's X.Org cannot start with Linux 3.16's qxl Resolved 05/18/2016
Related to Tails - Feature #10298: Upgrade to Linux 4.x Resolved 08/11/2015
Blocked by Tails - Feature #8183: Ship a 64-bit (x86_64) instead of 32-bit userspace Resolved 10/11/2016

Associated revisions

Revision d58f25e4 (diff)
Added by intrigeri over 3 years ago

Disable kernel modesetting for QXL: it's not compatible with Jessie's QXL X.Org driver.

refs: #11518

Revision beff8345 (diff)
Added by intrigeri over 3 years ago

Revert "Disable kernel modesetting for QXL: it's not compatible with Jessie's QXL X.Org driver."

On Stretch X runs as non-root, and so we really need KMS.

This reverts commit d58f25e4f64ed158becb3fcb367e580afb723fa9.

refs: #11518

Revision 348e2276 (diff)
Added by intrigeri about 3 years ago

Disable 64-bit CPU autodetection to force usage of a 32-bit kernel.

The goal here is to have a Tails that boots for our Stretch sprint #1,
while postponing a bit the move to a 64-bit userspace.

refs: #11518

Revision 64954708 (diff)
Added by anonym about 3 years ago

Revert "Test suite: use a VGA graphics adapter, instead of the QXL one."

This reverts commit 91f2ae152951208f865254293cb26a389797fb35.

Thanks to our workaround to #11518 we can (and must!) use QXL again.

Refs: #11518, #11441

History

#1 Updated by intrigeri over 3 years ago

  • Assignee deleted (intrigeri)

I'll workaround this by disabling qxl.modeset, not sure what are the drawbacks nor if it's an acceptable long-term solution.

#2 Updated by intrigeri over 3 years ago

  • Related to Feature #8183: Ship a 64-bit (x86_64) instead of 32-bit userspace added

#3 Updated by intrigeri over 3 years ago

  • Related to Bug #11441: Stretch's X.Org cannot start with Linux 3.16's qxl added

#4 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#5 Updated by intrigeri over 3 years ago

intrigeri wrote:

I'll workaround this by disabling qxl.modeset, not sure what are the drawbacks nor if it's an acceptable long-term solution.

I think it's not a good enough solution for 3.0, since on Stretch X runs as non-root, and so we really need KMS to work.

#6 Updated by intrigeri over 3 years ago

  • Target version changed from 2016 to Tails_3.0
  • Parent task deleted (#10298)

The current solution is good enough for #10298, but not for 3.0 => unparenting and adjusting target version accordingly.

#7 Updated by intrigeri over 3 years ago

#8 Updated by intrigeri over 3 years ago

  • Priority changed from Normal to High

This problem currently prevents X from starting on feature/stretch with the 64-bit kernel (workaround: manually select the 32-bit kernel), so bumping priority.

#9 Updated by intrigeri about 3 years ago

Workaround'ed with 348e22764d258ba3710141e20e1a7ba778bc63d4, that should be reverted once we do #8183.

#10 Updated by anonym about 3 years ago

intrigeri wrote:

Workaround'ed with 348e22764d258ba3710141e20e1a7ba778bc63d4, that should be reverted once we do #8183.

Thanks to this I've pushed the revert 649547083e293e52f07b9fe3200d062d53a0b517 so QXL is used in the automated test suite again.

#11 Updated by bertagaz about 3 years ago

  • Assignee set to intrigeri
  • QA Check set to Info Needed

Unless I've mistaken the problem, sounds to me that this ticket could be closed as we're going full 64 bit userland in Tails 3.0 (as per #8183).

#12 Updated by intrigeri about 3 years ago

  • Related to deleted (Feature #8183: Ship a 64-bit (x86_64) instead of 32-bit userspace)

#13 Updated by intrigeri about 3 years ago

  • Blocked by Feature #8183: Ship a 64-bit (x86_64) instead of 32-bit userspace added

#14 Updated by intrigeri about 3 years ago

Right. I'm marking this as blocked by #8183. I don't want to close this ticket yet, since this problem does exist on current feature/stretch, and our workaround is hackish.

#15 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100
  • QA Check deleted (Info Needed)

Also available in: Atom PDF