Project

General

Profile

Bug #11514

QXL driver is used unconditionally

Added by intrigeri about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
Hardware support
Target version:
Start date:
06/06/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

I see builds from the testing branch fail to start X, while previous versions worked just fine. It seems that due to the changes we introduced with #11500, the QXL driver is used in all cases, regardless of the actual hardware. I think we need to revert these changes for 2.4.


Related issues

Related to Tails - Bug #11500: Poor graphics performance in KVM guest with QXL driver Resolved 05/30/2016

Associated revisions

Revision e156ad26 (diff)
Added by anonym about 3 years ago

Revert "Disable surfaces support in QXL X.Org video driver."

This reverts commit 9dc411eb14da8a48c94867ff5a8de9be1dc9853e.

This configuration makes the QXL driver be used in all cases,
regardless of the actual hardware available.

Will-fix: #11514
Fix-committed: #1151

History

#1 Updated by intrigeri about 3 years ago

  • Related to Bug #11500: Poor graphics performance in KVM guest with QXL driver added

#2 Updated by anonym about 3 years ago

  • Status changed from Confirmed to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100
  • QA Check set to Pass

intrigeri wrote:

I see builds from the testing branch fail to start X, while previous versions worked just fine. It seems that due to the changes we introduced with #11500, the QXL driver is used in all cases, regardless of the actual hardware. I think we need to revert these changes for 2.4.

Ack, fixed now in revert e156ad2619d9ca53f1bb10c94bec4e928a423f06 that's now in both testing and devel. I'll reopen #11500 and propose a fix...

#3 Updated by anonym about 3 years ago

  • Status changed from Fix committed to In Progress

#4 Updated by intrigeri about 3 years ago

  • Status changed from In Progress to Fix committed

#5 Updated by anonym about 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF