Project

General

Profile

Bug #11512

Don't translate news/test_*rc.

Added by sajolida about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
-
Start date:
06/05/2016
Due date:
% Done:

100%

Feature Branch:
web/11512-dont-translate-test-rc
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Description

  • The translation window is quite short and translators are already busy with updating the rest of the website.
  • People will have a hard time sending useful test reports if they don't understand English.
  • These pages have been historically very little translated (note that the Farsi translations were all done in one shot way after the fact):
    • 2.4~rc1: French 100%
    • 2.2~rc1: none
    • 2.0~rc1: none
    • 1.7~rc1: French 96%
    • 1.5~rc1: none
    • 1.4~rc1: Farsi 32%
    • 1.3~rc1: Farsi 29%, French 79%
    • 1.2~rc1: Farsi 34%
    • 1.1~rc1: Farsi 35%
    • 1.0~rc1: Farsi 95%

Related issues

Related to Tails - Bug #11424: Make /about/contact translatable Resolved 05/16/2016

Associated revisions

Revision 9102ef94
Added by intrigeri about 3 years ago

Merge remote-tracking branch 'origin/web/11512-dont-translate-test-rc'

Closes: #11512

Revision 95c1e190
Added by intrigeri about 3 years ago

Merge remote-tracking branch 'origin/web/11512-dont-translate-test-rc'

Closes: #11512

History

#1 Updated by intrigeri about 3 years ago

I agree with this proposal.

#2 Updated by sajolida about 3 years ago

  • Assignee set to sajolida
  • Type of work changed from Discuss to Website

I'll do that.

#3 Updated by sajolida about 3 years ago

  • Assignee changed from sajolida to intrigeri
  • Target version set to Tails_2.5
  • QA Check set to Ready for QA
  • Feature Branch set to web/11512-dont-translate-test-rc

Can someone review this and then I'll coordinate with for the merge.

intrigeri: do you mind doing this? Otherwise unassign it from you and we'll find someone else.

#4 Updated by sajolida about 3 years ago

  • Related to Bug #11424: Make /about/contact translatable added

#5 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to In Progress

#6 Updated by intrigeri about 3 years ago

  • Assignee changed from intrigeri to sajolida
  • % Done changed from 0 to 50
  • QA Check changed from Ready for QA to Dev Needed

I've merged this and realized too late that this introduces a regression: the calls for testing are not listed anymore in the non-English version of the News homepage. It seems that the relevant inline directive(s) were not updated to match this change.

#7 Updated by intrigeri about 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#8 Updated by sajolida about 3 years ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

Oops, I always forget that... Do you mind reviewing 69cb022 which is meant to fix this?

#9 Updated by sajolida about 3 years ago

  • Status changed from Resolved to In Progress

#10 Updated by intrigeri about 3 years ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Dev Needed

Oops, I always forget that... Do you mind reviewing 69cb022 which is meant to fix this?

Merged, thanks! It did fix that bug. Now, I guess that wiki/src/index.html is affected by the same problem, right? (I didn't check if there are other instances of it, but please do so.)

(I would appreciate if you created a ticket to think about how all these things could be made less reliant less on humans, like you or I, trying to not forget all these details each time we modify one of those [[!inline]] directives or the list of translatable pages. I know we already have a comment that I asked for, that handles the "when I modify the inline I need to modify other inlines + ikiwiki*.setup", but apparently that's not a good enough safeguard. Perhaps we need a checklist to go through whenever we modify po_translatable_pages, or something.)

#11 Updated by sajolida about 3 years ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

Fix in c34c259.

And the checklist is a great idea (you know I love them). So I did that in b90be5a.

Sorry for the many round-trips :(

#12 Updated by intrigeri about 3 years ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Info Needed

Fix in c34c259.

Looks good (untested).

And the checklist is a great idea (you know I love them). So I did that in b90be5a.

Was it on purpose that you removed "On each release `n` of Tails 3.0, 4.0, etc"? That info disappeared and I see no explanation for it. Now, I doubt these files are the best place to remind us to do that, so likely a ticket about for 3.0 (with a note to create one for 4.0 etc.) would work better?

#13 Updated by sajolida about 3 years ago

Was it on purpose that you removed "On each release `n` of Tails 3.0,
4.0, etc"?

Yes, I removed it from the .html files on purpose but didn't remove it
from the .setup files. The git grep command in the checklist will
cover identifying which .html files need to be updated.

That info disappeared and I see no explanation for it.

It was probably too implicit but I meant for it to be covered by the
commit message in 288cf33: "This is now covered by
/contribute/how/website/po_translatable_pages".

Now, I doubt these files are the best place to remind us to do that,
so likely a ticket about for 3.0 (with a note to create one for 4.0
etc.) would work better?

Done in #11573.

#14 Updated by sajolida about 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • Target version deleted (Tails_2.5)

Marking this as resolved then.

#15 Updated by intrigeri about 3 years ago

sajolida wrote:

Marking this as resolved then.

Well, not exactly: providing the info I've requested did not automatically trigger a merge :)

Now merged. I've spotted this because this branch was still built on Jenkins, which should not be the case if it had been merged.

Also available in: Atom PDF