Project

General

Profile

Feature #11501

Feature #9005: Tails Installer without a splash screen

Confirmation dialog of Tails Installer should use verbs for button instead of Yes/No

Added by sajolida over 2 years ago. Updated 21 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
05/30/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
kurono/liveusb-creator:feature/11501-install-verbs-instead-yes-no, feature/11501-install-verbs-instead-yes-no
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:
Installer

Description

Quite often when I use Tails Installer myself to upgrade my USB sticks I have a moment of doubt on the confirmation dialog "Please confirm your device selection". Even if the message is clear, this step might erase all of my data so I'm very scared of having chosen the wrong entry in the splash screen.

I think that using verbs ("Cancel" and "Install" or "Upgrade") in this confirmation dialog would help me. It's usually a good practice nowadays anyway.


Related issues

Related to Tails - Bug #16053: Re-enable USE_LAST_RELEASE_AS_OLD_ISO on Jenkins after Tails 3.10 is released Resolved 10/16/2018
Blocks Tails - Feature #15392: Core work 2018Q2 → 2018Q3: User experience Confirmed 03/09/2018

Associated revisions

Revision a9455f48 (diff)
Added by kurono about 1 month ago

changes the test suite to validate the new confirmation button
labels with "Install|Upgrade" and "Cancel" instead of "Yes" or
"No". refs issue #11501

Revision 5a0598b8 (diff)
Added by intrigeri about 1 month ago

Test suite: DRY code introduced to deal with changing confirmation dialogs (refs: #11501).

Revision cc5095e0 (diff)
Added by intrigeri about 1 month ago

Import tails-installer branch kurono/feature/11501-install-verbs-instead-yes-no as a patch (refs: #11501)

Revision db5ba016 (diff)
Added by intrigeri 28 days ago

Replace patch with the feature-11501-install-verbs-instead-yes-no APT overlay (refs: #11501).

Revision 27cf851a
Added by intrigeri 28 days ago

Merge branch 'feature/11501-install-verbs-instead-yes-no' into stable (Fix-committed: #11501)

History

#1 Updated by SpencerOne over 2 years ago

Action words for proposing/confirming actions is the way to go XD

#2 Updated by u almost 2 years ago

  • Assignee changed from sajolida to u

#3 Updated by sajolida almost 2 years ago

This might require having #8860 first. Otherwise how would we know whether the label "Install" or "Upgrade"?

#4 Updated by kurono over 1 year ago

  • Assignee changed from u to kurono

#5 Updated by sajolida over 1 year ago

kurono: I feel like I can't do that myself because it requires some coding logic to alternate between "Install" and "Upgrade" but maybe you can do a rough draft of the coding logic and then I can work on putting the right words in the right place.

#6 Updated by kurono 4 months ago

  • Category set to Installation
  • Status changed from Confirmed to In Progress
  • Assignee changed from kurono to sajolida
  • Target version set to Tails_3.9
  • % Done changed from 0 to 10
  • QA Check set to Ready for QA
  • Feature Branch set to feature/11501-install-verbs-instead-yes-no

sajolida wrote:

kurono: I feel like I can't do that myself because it requires some coding logic to alternate between "Install" and "Upgrade" but maybe you can do a rough draft of the coding logic and then I can work on putting the right words in the right place.

Sajolida: I have made a first draft of this. The only thing is that I don't know if it was already translatable. I have followed the format to make it translatable (I think).

#7 Updated by intrigeri 3 months ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

This won't make it into 3.9.

#8 Updated by sajolida about 2 months ago

  • Assignee changed from sajolida to intrigeri

Sorry for the huge delay in reviewing this...

I like what I can understand from 0b2d20af.

Reassigning to the Foundations Team lead to find someone to review that.

I'll also let intrigeri change the target version if that's too big to go in 3.10.

#9 Updated by sajolida about 2 months ago

  • Blocks Feature #15392: Core work 2018Q2 → 2018Q3: User experience added

#10 Updated by intrigeri about 2 months ago

  • Feature Branch changed from feature/11501-install-verbs-instead-yes-no to kurono/liveusb-creator:feature/11501-install-verbs-instead-yes-no

#11 Updated by intrigeri about 2 months ago

  • Assignee changed from intrigeri to kurono
  • QA Check changed from Ready for QA to Info Needed

Hey kurono! Great work, code review passes. I believe this requires a test suite update and I think it's going to be trivial (git grep -w Yes -- features/step_definitions/). IIRC your setup allows you to build a custom ISO (drop your patch in config/chroot_local-patches/) and to run automated tests, right? Do you want to complete this work by preparing and testing the corresponding automated test suite update? If yes and if done in time, I'm happy to take this into 3.10. Otherwise, we'll see when we have time to do the test suite work.

#12 Updated by kurono about 1 month ago

intrigeri wrote:

Hey kurono! Great work, code review passes. I believe this requires a test suite update and I think it's going to be trivial (git grep -w Yes -- features/step_definitions/). IIRC your setup allows you to build a custom ISO (drop your patch in config/chroot_local-patches/) and to run automated tests, right? Do you want to complete this work by preparing and testing the corresponding automated test suite update? If yes and if done in time, I'm happy to take this into 3.10. Otherwise, we'll see when we have time to do the test suite work.

Hi intrigeri, thanks :)
I will try to make it on time, lets see if it happens before 3.10.

#13 Updated by kurono about 1 month ago

  • Assignee changed from kurono to intrigeri
  • % Done changed from 10 to 30
  • QA Check changed from Info Needed to Ready for QA

Ok, I have changed the test suite, to validate these new labels. I tested all the usb scenarios and they passed. I pushed a new branch: tails:kurono/feature/11501-install-verbs-instead-yes-no

#14 Updated by intrigeri about 1 month ago

  • % Done changed from 30 to 50

Great, thanks! I've made the code a bit more DRY and Rubyish with commit:138305c7a99ca71988299559a8069cb4d35d7820, imported your tails-installer work as a local patch in tails.git, and pushed the result to Jenkins.

#15 Updated by intrigeri about 1 month ago

  • Feature Branch changed from kurono/liveusb-creator:feature/11501-install-verbs-instead-yes-no to kurono/liveusb-creator:feature/11501-install-verbs-instead-yes-no, feature/11501-install-verbs-instead-yes-no

#16 Updated by intrigeri about 1 month ago

Also, rebased on top of the stable branch so there's a chance we ship this to users this year.

#17 Updated by intrigeri 30 days ago

  • Related to Bug #16053: Re-enable USE_LAST_RELEASE_AS_OLD_ISO on Jenkins after Tails 3.10 is released added

#18 Updated by intrigeri 29 days ago

  • % Done changed from 50 to 70

Test suite passes on Jenkins => I'm going to merge this into the Installer's Git repo, prepare a new upstream release, package it, and do the APT overlay dance so I can merge this into tails.git.

#19 Updated by intrigeri 28 days ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 70 to 100
  • QA Check changed from Ready for QA to Pass

Merged :)

#20 Updated by intrigeri 28 days ago

  • Status changed from Fix committed to In Progress

#21 Updated by intrigeri 28 days ago

  • Status changed from In Progress to Fix committed

#22 Updated by intrigeri 23 days ago

  • Status changed from Fix committed to In Progress

Applied in changeset commit:9cf37c41a3a508293d9630d62da6161522a333f6.

#23 Updated by intrigeri 21 days ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF