Project

General

Profile

Bug #11499

test_Tails_ISO_testing job is not enabled during the freeze

Added by intrigeri over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
05/28/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

We're in the freeze for 2.4, so our jenkins-jobs repo rightfully has build+test jobs for the testing branch. So far, so good. Except the test job doesn't show up in Jenkins (while the build job does), which prevents our QA to be done precisely on the branch that would need it most currently. What's wrong?

Setting >>normal prio + 2.4 target version, since the problem won't be reproducible anymore as soon as 2.4 is released, so if we want to fix it for the next major release, we can only do it now.


Related issues

Duplicated by Tails - Bug #11504: Missing test_Tails_ISO_testing job on Jenkins Duplicate 06/02/2016

History

#1 Updated by intrigeri over 2 years ago

  • Duplicated by Bug #11504: Missing test_Tails_ISO_testing job on Jenkins added

#2 Updated by intrigeri over 2 years ago

  • Priority changed from Elevated to High

Ping? Time flies, so raising priority.

#3 Updated by bertagaz over 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from bertagaz to intrigeri
  • % Done changed from 0 to 30
  • QA Check set to Info Needed

intrigeri wrote:

We're in the freeze for 2.4, so our jenkins-jobs repo rightfully has build+test jobs for the testing branch. So far, so good. Except the test job doesn't show up in Jenkins (while the build job does), which prevents our QA to be done precisely on the branch that would need it most currently. What's wrong?

I finally got the test_Tails_ISO_testing job back in the configuration after some by hand researches yesterday. I had to run j-j-b update with the --flush-cache option for it to be added. First time I see that, and don't know what happened with the JJB cache. We can either add this option permanently to our gitolite hooks, or wait to see if it happens again.

#4 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to bertagaz
  • QA Check changed from Info Needed to Dev Needed

I finally got the test_Tails_ISO_testing job back in the configuration after some by hand researches yesterday. I had to run j-j-b update with the --flush-cache option for it to be added.

Cool!

First time I see that, and don't know what happened with the JJB cache. We can either add this option permanently to our gitolite hooks, or wait to see if it happens again.

Well, given you found a solution, I'm all for applying it (if it doesn't have too adverse consequences) instead of waiting to see if it happens again.

#5 Updated by bertagaz over 2 years ago

  • Assignee changed from bertagaz to intrigeri
  • Priority changed from High to Normal
  • % Done changed from 30 to 80
  • QA Check changed from Dev Needed to Ready for QA

intrigeri wrote:

Well, given you found a solution, I'm all for applying it (if it doesn't have too adverse consequences) instead of waiting to see if it happens again.

I don't think there will be harmful consequences. I've added the option to our JJB deployment git hook script in puppet-tails:c927489. Pushed a commit to our JJB repo (in passing using the new cucumber-testresult plugin support we added to JJB), seems it worked fine, everything was deployed

#6 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_2.4 to Tails_2.5

#7 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 80 to 100
  • QA Check changed from Ready for QA to Pass

Pushed a commit too, and not suffered from any performance issue, so seems like we're good here.

Also available in: Atom PDF