Project

General

Profile

Bug #11468

Fix daily cleanup of Puppet reports

Added by intrigeri over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
05/23/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

It seems that it doesn't: we still get disk space issues on puppet-git.lizard. I wonder if the cronjob actually runs, or if we merely survive because we run the script by hand from time to time. FTR, after running it, I see 1.1 GB of reports left. So in the worst case we should in theory be storing ~2.2GB of reports just before the cleanup is done. This doesn't really match what Icinga is telling us, so something must be wrong.

History

#1 Updated by intrigeri over 3 years ago

  • Subject changed from Check if daily cleanup of Puppet reports actually works to Fix daily cleanup of Puppet reports
  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

And indeed it simply doesn't run: run-parts --list /etc/cron.daily doesn't list the cleanup cronjob, presumably due to its file extension. So we could very well tweak the cleanup delay as much as we wanted, it would not have fixed the problem whatsoever.

#2 Updated by intrigeri over 3 years ago

  • % Done changed from 10 to 50

Presumably fixed, filed a ticket upstream (https://gitlab.com/shared-puppet-modules-group/puppet/issues/9) and sent a merge request there. I'll see in a couple days how it goes.

#3 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100

I've seen the number of reports grow, and shrink again, so I think we're good :)

Also available in: Atom PDF