Project

General

Profile

Bug #11467

isotester 5-8 don't reboot before running test suite jobs

Added by intrigeri about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
05/23/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

... and this breaks tests, e.g. because chutney can't start all its Tor processes. It seems that each attempt to reboot fails due to:

May 19 11:52:12 isotester7 sshd[3891]: Connection closed by 192.168.122.11 [preauth]

(192.168.122.11 is jenkins.lizard)

History

#1 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50

Probably fixed by unlocking the jenkins user on those slaves, and adding this step to the ISO tester setup doc. Now, one wonders if the reboot job has ever worked on those slaves..

I'll check tomorrow to confirm it really works.

#2 Updated by intrigeri about 3 years ago

That wasn't enough: as jenkins@jenkins, when I try to connect e.g. to isotester6, I see a prompt asking me to confirm the ED25519 host key. I've found another issue, and fixed it too. Let's see if it works any better.

#3 Updated by intrigeri about 3 years ago

  • Assignee set to intrigeri
  • % Done changed from 50 to 60

Woohoo, isotester7 was just successfully rebooted :) I'll wait for the others (5, 6, 8) to also be automatically rebooted before I call this done.

#4 Updated by intrigeri about 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 60 to 100

3 out of 4 rebooted successfully, I'll assume that the 4th one will work as well once it is given a job.

#5 Updated by intrigeri about 3 years ago

  • Subject changed from isotester 5-8 don't reboot anymore before running test suite jobs to isotester 5-8 don't reboot before running test suite jobs

Also available in: Atom PDF