Project

General

Profile

Feature #11448

Feature #5926: Freezable APT repository

Write helper tools for APT repository freeze exceptions

Added by intrigeri over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
05/18/2016
Due date:
% Done:

100%

Feature Branch:
feature/11448-freeze-exception-helper
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:

Related issues

Blocked by Tails - Feature #11446: Document freeze exceptions workflow for the freezable APT repository Resolved 05/18/2016

Associated revisions

Revision 4c91937f (diff)
Added by intrigeri over 3 years ago

Automate a part of the process to grant a freeze exception to a Debian package.

refs: #11448

Revision b1862702 (diff)
Added by intrigeri about 3 years ago

import-package: enable deb-src in the pbuilder chroot before relying on them.

refs: #11448

Revision b8e76cfe
Added by intrigeri about 3 years ago

Merge branch 'feature/11448-freeze-exception-helper' into stable

Closes: #11448

History

#1 Updated by intrigeri over 3 years ago

  • Copied from Feature #11446: Document freeze exceptions workflow for the freezable APT repository added

#2 Updated by intrigeri over 3 years ago

  • Copied from deleted (Feature #11446: Document freeze exceptions workflow for the freezable APT repository)

#3 Updated by intrigeri over 3 years ago

  • Parent task set to #5926

#4 Updated by intrigeri over 3 years ago

  • Blocked by Feature #11446: Document freeze exceptions workflow for the freezable APT repository added

#5 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 50
  • Feature Branch set to feature/11448-freeze-exception-helper

I've automated the most painful and error-prone part of the process. The rest of the process is easy to follow, and rarely used anyway, so it didn't seem necessary to invest time into automating it.

To test the script, you may use TARGET_DIST=playground, that is meant for such experiments :)

#6 Updated by intrigeri over 3 years ago

  • QA Check set to Ready for QA

P.S.: no big deal if this is reviewed a bit later, e.g. during the 2.6 or 2.7 release cycle. I expect the real test will be whenever one of us needs to actually use this tool during a freeze, anyway.

#7 Updated by intrigeri about 3 years ago

FWIW I had to test this doc+tool for real due to #11568 and it worked flawlessly.

#8 Updated by intrigeri about 3 years ago

  • Target version changed from Tails_2.5 to Tails_2.6

#9 Updated by intrigeri about 3 years ago

  • Blocks Bug #11612: Cannot import needed packages into the new tagged APT snapshot at point-release time added

#10 Updated by anonym about 3 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 50 to 90
  • QA Check changed from Ready for QA to Dev Needed

Code looks good, and my test worked (cowsay is happily grazing in the playground). :)

My only stumbling block was this: by default pbuilder creates chroot:s where the deb-src is commented out => the script fails. Please document that that line needs to be uncommented in the pbuilder chroot used for these instructions. Bonus points if you provide commands for how to do it with pbuilder --login --save-after-login etc.

Feel free to merge this branch yourself after fixing the above.

#11 Updated by intrigeri about 3 years ago

  • Blocks deleted (Bug #11612: Cannot import needed packages into the new tagged APT snapshot at point-release time)

#12 Updated by intrigeri about 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 90 to 100
  • QA Check changed from Dev Needed to Pass

anonym's concern was fixed in a nicer way wit b1862702ef6dd04d6ebfbffbad18dc92f0e2e44d.

#13 Updated by intrigeri about 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF