Project

General

Profile

Bug #11440

Adjust /etc/gnome/defaults.list for Stretch

Added by intrigeri over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
05/17/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

gnome-session (3.20.1-2) unstable; urgency=medium

  * Drop /usr/share/gnome/applications/defaults.list symlink and install
    /etc/gnome/defaults.list to /usr/share/applications/gnome-mimeapps.list
    instead, as the xdg spec is allowing desktop specific default applications.
    If /etc/gnome/defaults.list was modified by the system administrator, the
    file is moved to /etc/xdg/gnome-mimeapps.list during the upgrade.
    This seems to fix default apps when running gnome-shell as a wayland
    compositor, as the 55gnome-session_gnomerc is not sourced in that case.

 -- Laurent Bigonville <bigon@debian.org>  Tue, 17 May 2016 02:02:11 +0200

Associated revisions

Revision daeb26cd (diff)
Added by intrigeri over 3 years ago

Adjust to the move of /etc/gnome/defaults.list in Stretch.

I'm not sure we can override existing entries via /etc/xdg/gnome-mimeapps.list,
without forking the entire original file. Let's see. At least it should fix the
ISO build.

refs: #11440

Revision 574cd079 (diff)
Added by intrigeri about 3 years ago

Adjust default web browser customization: GNOME in Debian now defaults to Firefox ESR (refs: #11440).

Revision de20f31b (diff)
Added by intrigeri about 3 years ago

AppArmor gnome abstraction: allow reading /etc/xdg/*-mimeapps.list.

refs: #11440

I've submitted this upstream already:
https://code.launchpad.net/~intrigeri/apparmor/moved-gnome-mimeapps/+merge/303916

History

#1 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 0 to 10

... and indeed, the ISO build is now broken due to this move. I've tried something in daeb26c, but we'll need to test if this works, i.e. whether 1. it's taken into account (Tor Browser is the default GNOME web browser e.g. when clicking URLs); and 2. it does not kill the other file associations set up in /usr/share/applications/gnome-mimeapps.list.

#2 Updated by intrigeri about 3 years ago

Evince cannot open URLs because AppArmor prevents it from reading /etc/xdg/gnome-mimeapps.list.

#3 Updated by intrigeri about 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 10 to 100

Also available in: Atom PDF