Project

General

Profile

Bug #11414

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

The "Chatting with some friend over XMPP in a multi-user chat" scenario is fragile

Added by anonym over 3 years ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Test suite
Target version:
Start date:
05/14/2016
Due date:
% Done:

100%

Feature Branch:
https://salsa.debian.org/tails-team/tails/merge_requests/33
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Instant Messaging

Description

Same for "Connecting to the tails multi-user chat with my XMPP account".

See attached files for the symptom and context.

01_18_46_Connecting_to_the_tails_multi-user_chat_with_my_XMPP_account.png View (63 KB) anonym, 05/14/2016 07:17 AM

debug.log View (7.3 KB) anonym, 05/14/2016 07:17 AM


Related issues

Related to Tails - Bug #12043: Test failure in "Fetching OpenPGP keys using Seahorse via the OpenPGP Applet should work and be done over Tor" due to weird interaction with GNOME Shell tiling features Confirmed 12/19/2016

Associated revisions

Revision a878b28e (diff)
Added by intrigeri 3 months ago

Test suite: remove obsolete fragile tag (refs: #11414)

These scenarios never failed on Jenkins in the last 2 months,
except occasionally for reasons that were fixed via #15321.

Revision a7ca22af
Added by Sandro Knauß 3 months ago

Merge remote-tracking branch 'test/update-fragile-tags' into devel (refs: #16281, #11890)

Closes: #13470, #11606, #11457, #11563, #11591
Closes: #10499, #11584, #11414, #11453, #11463

History

#1 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#2 Updated by intrigeri over 3 years ago

I've seen something very similar (instead of the intended GUI interaction, a window is dragged to one side of the screen, which triggers GNOME half-screen tiling feature) in another scenario so the underlying problem is apparently more general. Not sure what scenarios it affects, so I can't tag much as fragile.

#3 Updated by anonym over 3 years ago

  • Target version changed from Tails_2.4 to Tails_2.5

#4 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.5 to Tails_2.7

#5 Updated by intrigeri over 3 years ago

  • Assignee deleted (anonym)
  • Target version deleted (Tails_2.7)

#6 Updated by intrigeri almost 3 years ago

  • Related to Bug #12043: Test failure in "Fetching OpenPGP keys using Seahorse via the OpenPGP Applet should work and be done over Tor" due to weird interaction with GNOME Shell tiling features added

#7 Updated by intrigeri almost 3 years ago

#12043 is another instance of the same problem. I'm not merging these tickets since it might be that ad-hoc solutions can be found to fix each of them differently; I didn't check if a shared solution is feasible.

#8 Updated by anonym almost 3 years ago

  • Priority changed from Elevated to Normal

#9 Updated by intrigeri over 2 years ago

I've seen this scenario fail (on feature/stretch) because "Pidgin automatically enables my XMPP account" passes before the account is connected, i.e. PidginAvailableStatus.png is erroneously found on the screen while Pidgin is still connected. Maybe we have a too high fuzz factor or something?

#10 Updated by intrigeri 3 months ago

  • Affected tool set to Instant Messaging

#11 Updated by intrigeri 3 months ago

  • Status changed from Confirmed to In Progress

#12 Updated by intrigeri 3 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee set to hefee
  • Target version set to Tails_4.0
  • Feature Branch set to https://salsa.debian.org/tails-team/tails/merge_requests/33

#13 Updated by Anonymous 3 months ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF