Project

General

Profile

Bug #11401

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

robust_notification_wait sometimes opens the Applications menu which breaks tests

Added by intrigeri over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
05/05/2016
Due date:
% Done:

100%

Feature Branch:
test/11401-notification-wait-is-fragile
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Unsafe Browser


Related issues

Related to Tails - Bug #13469: Starting applications "via GNOME Activities Overview" step is fragile Resolved 07/14/2017
Blocks Tails - Bug #10497: wait_until_tor_is_working helper is fragile Resolved 11/06/2015

Associated revisions

Revision bb54cad5 (diff)
Added by intrigeri over 3 years ago

Test suite: close the notification bar by pressing ESC, instead of opening the Applications menu.

The Applications menu often covers other elements that we're looking for on
the screen.

refs: #11401

Revision 6bbcce04 (diff)
Added by intrigeri over 3 years ago

Test suite: unmark scenarios previously broken by the notifications handling as fragile.

refs: #11401

Revision 06634d46
Added by anonym over 3 years ago

Merge remote-tracking branches 'origin/test/10376-fix_startup-page_roadmap-test-is-fragile' and 'origin/test/11401-notification-wait-is-fragile' into testing

Fix-committed: #10376, #10497, #11398, #11401, #11464

History

#1 Updated by intrigeri over 3 years ago

  • Parent task set to #10288

#2 Updated by intrigeri over 3 years ago

Perhaps desktop notification handling would be a good candidate for dogtail'ification? The way it looks visually changes a lot in Stretch, our handling of it has historically been quite brittle, and now even our "robust" helper breaks stuff.

#3 Updated by intrigeri over 3 years ago

One more case, attaching video. I'll mark this test as fragile, and IMO we should go on doing this until we can check if this breaks too many tests and needs to be prioritized higher.

#4 Updated by intrigeri over 3 years ago

  • Priority changed from Normal to Elevated

FTR, all recent test failures I've seen while running tests on 4 branches intensively were caused either by this problem, or by #11398 => bumping priority.

And now I wonder: did we ever see this before we merged the dogtail branch? I can't remember this, and this ticket is pretty new, and I see this problem very often these days. So I wonder if robust_notification_wait is really guilty, or if we're experiencing some dogtail-induced bug.

#5 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to test/11401-notification-wait-is-fragile

In def robust_notification_wait I see:

  # Click anywhere to close the notification applet
  @screen.hide_cursor
  @screen.click("GnomeApplicationsMenu.png")
  @screen.hide_cursor

... which probably explains very clearly what we're seeing. JFTR this code was introduced in bd2d2bdf. I'm pushing a different implementation, will merge it into test/10497-tor-bootstrap-is-fragile so that we can see how it goes in Jenkins.

#6 Updated by intrigeri over 3 years ago

  • Blocks Bug #10497: wait_until_tor_is_working helper is fragile added

#7 Updated by intrigeri over 3 years ago

  • Assignee set to intrigeri
  • Target version set to Tails_2.4
  • % Done changed from 0 to 10

Will try to do that during this cycle, since it blocks #10497 (and in turn, those that #10497 itself blocks).

#10 Updated by intrigeri over 3 years ago

  • Subject changed from robust_notification_wait sometimes fails to close a notification which breaks tests to robust_notification_wait sometimes opens the Applications menu which breaks tests
  • Description updated (diff)

(Repurposing this ticket to track the specific problem I'm trying to fix here, instead of two unrelated things at a time. The issue it was previously about, that's specifically about browser close notifications, is now tracked by #11457.)

#11 Updated by intrigeri over 3 years ago

  • File deleted (03_55_28_Closing_the_Unsafe_Browser_shows_a_stop_notification_and_properly_tears_down_the_chroot..mkv)

#12 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

I've not seen this bug happen anymore on Jenkins with this fix in, while it happened pretty regularly before. FTR this branch has been merged into the one for #10497, and in turn into the ones for #10442, #10376 and #10381, so it has seen a fair amount of testing. Then I think we're good and should merge this :)

#13 Updated by anonym over 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#14 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

#15 Updated by intrigeri over 2 years ago

  • Related to Bug #13469: Starting applications "via GNOME Activities Overview" step is fragile added

Also available in: Atom PDF