Project

General

Profile

Bug #11396

Make sure vagrant-libvirt and its dependencies are packaged according to our needs

Added by anonym over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
05/04/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Debian
Blueprint:
Starter:
Affected tool:

Description

This means having this Debian bug fixed:

  1. vagrant-libvirt: include tools/create_box.sh

Bonus, non-blocking, as it's working fine on Jessie + our APT repo currently:

  1. ruby-libvirt: backport rubygems integration fix to Jessie
  2. vagrant-libvirt: backport to jessie

See, #6354#note-24 for details.

History

#1 Updated by anonym over 3 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check set to Info Needed

anonym is trying to learn how to be a nice citizen of bugs.debian.org but needs some guidance.

anonym wrote:

  1. vagrant-libvirt: include tools/create_box.sh

This one has not been answered yet. I guess I should ping? With a proposed patch (since the maintainer doesn't care too much, it seems)?

  1. ruby-libvirt: backport rubygems integration fix to Jessie

I assume "p-u" = "proposed-updates". What is the protocol here? I Cc the release team and ask their opinion?

  1. vagrant-libvirt: backport to jessie

Unfortunate answer, but oh well, we were ready to maintain a backport ourselves at one point. Again, in hopes of not having to do that, should I just Cc and ask what they think?

#2 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Info Needed to Dev Needed

anonym is trying to learn how to be a nice citizen of bugs.debian.org but needs some guidance.

Let's say this is good training for your future NM process ;)

anonym wrote:

  1. vagrant-libvirt: include tools/create_box.sh

This one has not been answered yet. I guess I should ping? With a proposed patch (since the maintainer doesn't care too much, it seems)?

Yes, a patch would be good (and presumably quite easy).

  1. ruby-libvirt: backport rubygems integration fix to Jessie

I assume "p-u" = "proposed-updates". What is the protocol here? I Cc the release team and ask their opinion?

Yes, as Guido suggested. The release team would likely prefer being asked in the form of a bug report, for easier tracking: https://www.debian.org/doc/manuals/developers-reference/pkgs.html#upload-stable. Please X-Debbugs-Cc me :)

  1. vagrant-libvirt: backport to jessie

Unfortunate answer, but oh well, we were ready to maintain a backport ourselves at one point. Again, in hopes of not having to do that, should I just Cc and ask what they think?

I don't think that will have much to say if Antonio doesn't want to do it: he's the major contributor to that list. So, if we really want this (we do, right?) we need to maintain this set of backports ourselves, and as Antonio offered, if we have any issue along the way we can ask help to the Ruby team. I suggest you do that in the relevant Vcs-Git repositories, which probably requires you to get access to collab-maint and pkg-ruby-extras repositories (via Alioth group membership requests, I believe).

#3 Updated by anonym over 3 years ago

  • Target version changed from Tails_2.4 to Tails_2.6

Thanks for the pointers! I truly doubt I'll have time for any of this in the next few months (=> postponing) but one issue is a blocker and will need a short-term solution, namely:

2. ruby-libvirt: backport rubygems integration fix to Jessie

=> #11509.

#4 Updated by anonym over 3 years ago

  • Subject changed from Make sure vagrant-libvirt is packaged according to our needs to Make sure vagrant-libvirt and its dependencies are packaged according to our needs

#5 Updated by intrigeri about 3 years ago

  • Description updated (diff)
  • Assignee changed from anonym to intrigeri
  • Target version changed from Tails_2.6 to Tails_2.7
  • Type of work changed from Wait to Debian

Next steps:

  • provide a patch for https://bugs.debian.org/823317
  • clarify on the two other Debian bugs that it's no big deal if they are not fixed, and that we're not going to work on it any further

#6 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100
  • QA Check deleted (Dev Needed)

intrigeri wrote:

Next steps:

Done.

  • clarify on the two other Debian bugs that it's no big deal if they are not fixed, and that we're not going to work on it any further

Done.

#7 Updated by intrigeri about 3 years ago

intrigeri wrote:

intrigeri wrote:

Next steps:

Done.

… and the patch was included in the last upload :)

Also available in: Atom PDF