Project

General

Profile

Bug #11382

New ibus-pinyin cannot be used for quanpin

Added by emmapeel about 3 years ago. Updated 2 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
-
Start date:
04/27/2016
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

Reported by user, no idea about this stuff myself.

User reports that the new ibus-pinyin in Tails 2.3 is buggy, cannot be used with quanpin, and is better to have ibus-libpinyin or ibus-sunpinyin.

It would be nice to have input from some chinese speaker about this...


Related issues

Related to Tails - Bug #14535: Bopomofo input method doesn't work Duplicate 08/30/2017
Related to Tails - Bug #11995: Fix the support of Chinese (Bopomofo) Duplicate 11/24/2016
Related to Tails - Bug #11292: Bopomofo input for Chinese is not working Resolved 03/31/2016

History

#1 Updated by intrigeri about 3 years ago

  • Assignee set to emmapeel

User reports that the new ibus-pinyin in Tails 2.3 is buggy,

It would be great if there was information more specific and actionable than "is buggy", if it really matters.

cannot be used with quanpin,

According to https://en.wikipedia.org/wiki/Talk:Chinese_input_methods_for_computers, Quanpin ("full pinyin") is one of the main flavours of the Pinyin input method. I am not sure but it seems to be a synonym or alternate spelling for Quanyin. Also, https://chinese.stackexchange.com/questions/5675/which-imes-input-method-editors-are-actually-most-used-in-each-of-prc-roc-an seems useful.

and is better to have ibus-libpinyin or ibus-sunpinyin.

OK, thanks for the suggestion. Next step would be to check if we have to choose only one among ibus-pinyin, ibus-libpinyin and ibus-sunpinyin, or if we can ship 2 or 3 of them.

emmapeel, can we get in touch with the bug reporter, and get them to test experimental ISO images? If yes, then I'm ready to prepare a few ones. If not, then there's no point in me working on this much more, since I won't be able to evaluate and validate my results.

In case we have to choose:

  • ibus-pinyin:
    • a couple upstream releases in the last few years
    • in Debian since a long time
    • popcon: 510 (inst.), 177 (vote)
  • ibus-libpinyin:
    • a few upstream releases in 2015
    • in Debian since Jessie
    • popcon: 101 (inst.), 53 (vote)
  • ibus-sunpinyin
    • 2.0.3 in Debian since 2011
    • no upstream release since then
    • popcon: 128 (inst.), 39 (vote)

#2 Updated by emmapeel about 3 years ago

Yes, we can ask them to test ISO images.

#3 Updated by intrigeri about 3 years ago

  • Assignee changed from emmapeel to intrigeri
  • QA Check changed from Info Needed to Dev Needed

Thanks!

#4 Updated by BitingBird almost 3 years ago

  • Status changed from New to Confirmed

You assigned to yourself so I guess it's confirmed :)

#5 Updated by intrigeri almost 2 years ago

  • Assignee changed from intrigeri to emmapeel
  • QA Check changed from Dev Needed to Info Needed

emmapeel wrote:

Yes, we can ask them to test ISO images.

I'm very sorry it took me a year (!) to come back to this topic. If you can easily find their email address, please give it to me. Otherwise, well, too bad, my bad, and I'll see what I can do about it without any testers.

Thanks in advance!

#6 Updated by u 2 months ago

  • Related to Bug #14535: Bopomofo input method doesn't work added

#7 Updated by u 2 months ago

  • Related to Bug #11995: Fix the support of Chinese (Bopomofo) added

#8 Updated by intrigeri 2 months ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (emmapeel)
  • QA Check deleted (Info Needed)

Please reopen if you can give me the contact of at least one candidate tester :)

#9 Updated by intrigeri 2 months ago

  • Related to Bug #11292: Bopomofo input for Chinese is not working added

#10 Updated by intrigeri 2 months ago

@emmapeel, if you still have the contact of the person who reported this, please point them to #11292#note-34. Thanks in advance!

Also available in: Atom PDF