Project

General

Profile

Feature #11306

Feature #7874: Find a more stable solution for Tails default chat support channel

Move #tails to XMPP

Added by intrigeri over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
10/28/2015
Due date:
% Done:

100%

Feature Branch:
feature/11306-move-tails-support-to-xmpp
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Subtasks

Bug #10443: Pidgin OFTC tests are fragileResolved


Related issues

Related to Tails - Bug #11413: Test suite: newly added XMPP account is not persisted, and "Pidgin has the expected persistent accounts configured" doesn't notice Resolved 05/14/2016

Associated revisions

Revision 1358403f (diff)
Added by intrigeri over 3 years ago

Don't pre-configure the #tails chan on the default OFTC account.

refs: #11306

Revision f9a015c7 (diff)
Added by intrigeri over 3 years ago

Documentation: replace #tails @ OFTC with xmpp:.

refs: #11306

Revision a6e7253d (diff)
Added by intrigeri over 3 years ago

Test suite: replace OFTC and #tails -based tests with xmpp: ones.

refs: #11306

Revision d7f9ad19 (diff)
Added by intrigeri over 3 years ago

Test suite: don't rely on the tails XMPP channel to have a stable topic.

The topic is reset whenever it happens that nobody is on the chan.

refs: #11306

Revision 07b6d3b1
Added by anonym over 3 years ago

Merge remote-tracking branch 'origin/feature/11306-move-tails-support-to-xmpp' into devel

Fix-committed: #11306

History

#1 Updated by emmapeel over 3 years ago

  • Blocks Feature #7874: Find a more stable solution for Tails default chat support channel added

#2 Updated by emmapeel over 3 years ago

  • Blocks deleted (Feature #7874: Find a more stable solution for Tails default chat support channel)

#3 Updated by emmapeel over 3 years ago

  • Parent task set to #7874

#4 Updated by sajolida over 3 years ago

Tor uses anonymous logins on XMPP for live and one-time user support
sessions. We could ask them for tricks or if we can use it for testing
maybe.

#5 Updated by intrigeri over 3 years ago

Tor uses anonymous logins on XMPP for live and one-time user support sessions. We could ask them for tricks or if we can use it for testing maybe.

I suggest you let the people who work on #11307 and #11317 know, as it's outside of the scope of what I committed to do on this ticket.

#6 Updated by sycamoreone over 3 years ago

@sajolida Is there any documentation about what kind of anonymous accounts they use? Or a person one could ask questions?

#7 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#8 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to feature/11306-move-tails-support-to-xmpp

#9 Updated by intrigeri over 3 years ago

Drafted the needed code and doc changes. Started updating the automated test suite.

#10 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to sajolida
  • QA Check set to Ready for QA

sajolida: please review the doc changes on this branch.

Then, please pass it to anonym who will review the code changes.

Thanks!

(The situation on #tails is really concerning, I'm told, so I would like to speed up this migration a bit.)

#11 Updated by anonym over 3 years ago

sajolida, note that I already merged this branch (by mistake, due to #10443).

#12 Updated by muri over 3 years ago

fyi, these are the most important workflows for managing an xmpp channel:

to make a jid silent, but jid can still read whats happening:

/role visitor jid

the role is lost on rejoion

to kick a nick

/kick jid

after a kick, the jid can rejoin

to ban a nick

/ban jid reason

this makes a jid an outcast; all outcasts can be listed by using:
/affiliate outcast

ro remove affiliation:
/affiliate none jid

#13 Updated by anonym over 3 years ago

  • Status changed from In Progress to Fix committed

#14 Updated by intrigeri over 3 years ago

  • Related to Bug #11413: Test suite: newly added XMPP account is not persisted, and "Pidgin has the expected persistent accounts configured" doesn't notice added

#15 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to anonym

Adjusted the documentation a bit in d7f9ad1..aeff321.

#16 Updated by intrigeri over 3 years ago

  • Assignee changed from anonym to intrigeri

#17 Updated by intrigeri over 3 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Reviewed, looks good. Thanks!

#18 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF