Project

General

Profile

Feature #11294

Replace remote shell with python-negotiator

Added by anonym almost 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
-
Start date:
03/31/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

From https://github.com/xolox/python-negotiator:

The Python packages negotiator-host, negotiator-guest and negotiator-common together implement a scriptable KVM/QEMU guest agent infrastructure in Python. This infrastructure supports realtime bidirectional communication between Linux hosts and guests which allows the hosts and guests to invoke user defined commands on 'the other side'.

I think we can use this to implement a muuuuch faster and more robust remote shell.


Related issues

Related to Tails - Feature #11888: Improve the remote shell's performance by switching to a virtio channel In Progress 10/25/2016

History

#1 Updated by intrigeri over 3 years ago

  • Target version deleted (2016)

#2 Updated by intrigeri over 3 years ago

  • Related to Feature #11888: Improve the remote shell's performance by switching to a virtio channel added

#3 Updated by anonym over 3 years ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (anonym)

Our remote shell now implements the properties of python-negotiator that I thought interesting, so let's reject this. Even if it was packaged in Debian there would be quite some work in order to use it. For instance, since it's written in Python, and our test suite is written in Ruby, we probably would have to re-implement a ruby-negotiator for the host-side, or a wrapper so we can call the python code, or similar.

Also available in: Atom PDF