Project

General

Profile

Feature #11284

Bug #7161: Support more than 24 HTTP mirrors

Update the DNS round-robin mirror pool to only include a few fast and reliable HTTP mirrors

Added by intrigeri over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
03/25/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

This includes updating our internal doc (in mirrors.git) accordingly:

  • stop unconditionally adding new mirrors to the DNS round-robin pool;
  • how to manage the DNS round-robin pool (what mirrors should go in or not, when to remove mirrors from it), and keep it in sync' with what we have in mirrors.json (e.g. when we disable a mirror in mirrors.json, presumably we also want to remove it from the DNS round-robin pool.

Related issues

Blocked by Tails - Feature #10295: Build a list of fast and reliable HTTP mirrors Resolved 09/28/2015
Blocked by Tails - Feature #11109: Have DAVE build the ISO URL using our mirrors pool configuration Resolved 01/09/2015 04/15/2016
Blocked by Tails - Feature #11123: Have the Upgrader use the new mirror pool design Resolved 02/13/2016
Blocked by Tails - Feature #8642: Enable the mirror pool dispatcher on all website pages that need it Resolved 01/09/2015 04/15/2016

History

#1 Updated by intrigeri over 3 years ago

  • Blocked by Feature #10295: Build a list of fast and reliable HTTP mirrors added

#2 Updated by intrigeri over 3 years ago

  • Blocked by Feature #11109: Have DAVE build the ISO URL using our mirrors pool configuration added

#3 Updated by intrigeri over 3 years ago

  • Blocks Feature #8642: Enable the mirror pool dispatcher on all website pages that need it added

#4 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#5 Updated by intrigeri over 3 years ago

  • Blocked by Feature #11123: Have the Upgrader use the new mirror pool design added

#6 Updated by intrigeri over 3 years ago

(See #11123#note-17 for an explanation of why it would be much nicer if #11123 was merged before we go ahead here. "Blocked by" might be a bit strong, but that's the best way I've found to encode the relationship.)

#7 Updated by intrigeri over 3 years ago

  • Blocks deleted (Feature #8642: Enable the mirror pool dispatcher on all website pages that need it)

#8 Updated by intrigeri over 3 years ago

  • Blocked by Feature #8642: Enable the mirror pool dispatcher on all website pages that need it added

#9 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.4 to Tails_2.5

I don't see #11109 be fully done (including a new DAVE on AMO) during the 2.4 cycle, so postponing this ticket it blocks.

#10 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.5 to Tails_2.6

intrigeri wrote:

I don't see #11109 be fully done (including a new DAVE on AMO) during the 2.4 cycle, so postponing this ticket it blocks.

Same.

#11 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.6 to Tails_2.7

#12 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 20

Doc updated in mirrors.git, support code written and pushed to mirror-pool.git. Now I'll refresh the list of fast+reliable mirrors (things may have changed since I completed #10295 six months ago), and will finally remove all mirrors from the DNS pool except a few selected ones.

#13 Updated by intrigeri about 3 years ago

  • Assignee changed from intrigeri to u
  • % Done changed from 20 to 50
  • QA Check set to Ready for QA

#14 Updated by u about 3 years ago

  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Tested the script and reread the doc, great! I think we're done here.

#15 Updated by u about 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (u)

Also available in: Atom PDF