Project

General

Profile

Bug #11263

Xorg crashes with Intel Braswell

Added by gentriles over 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/18/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

I boot up Tails 2.2 and after the greeter, instead of showing the desktop, it gives a white fullscreen page saying "Oh no. Something went wrong." with a sad smileface on the left of the text. Booting in failsafe option gives the same error.

Hardware:

lspci -nn | grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:22b1] (rev 21)
CPU: Intel Celeron N3050 1.6 GHz
GPU: Intel HD Graphics

Sorry, I dont know how to get log files or other relevant information to this issue. But I can post them if you give me the commands I need to use. I marked this "bug" Urgent, because I cant use Tails at all.

tails-debugging-info.txt View - Tails Debug-Info (1.41 MB) vitali576, 03/20/2016 10:04 PM


Related issues

Duplicates Tails - Feature #11303: Ship mesa from jessie-backports Resolved 04/02/2016

History

#1 Updated by gentriles over 3 years ago

Appendix: I tried to run the same Tails 2.2 image on VirtualBox on the same machine that gave me the "Oh no. Something went wrong." error message ... and it also gave me the same error in the Virtualbox (Host: Ubuntu). I activated '3D-Acceleration' for the VirtualBox machine Tails 2.2 and then it worked.

Could this be helpful to solve the problem for booting Tails 2.2 on a normal (non virtualbox) machine?

#2 Updated by vitali576 over 3 years ago

I have exactly the same problem with Acer Aspire ES1-331-C5KL, CPU Intel Celeron N3150.
I have already spent about 8 hours on researching the cause of this problem, as for now I highly assume there is a bug in Gnome Display Manager that appears in combination with integrated Intel HD Graphics.
I have already tried the following kernel boot parameters, without any success:

vga=771
vga=788
intel_idle.max_cstate=2
intel_idle.max_cstate=1
intel_idle.max_cstate=0
tsc=reliable
clocksource=tsc
video=VGA-1:1280x800
i915.enable_fbc=0
video=SVIDEO-1:d
i915.enable_execlists=0
vga=normal
nofb
video=vesafb:off
radeon.modeset=0
xorg-driver=fbdev
nomodeset
i915.modeset=0
i915.modeset=1
i915.preliminary_hw_support=1
i915.enable_rc6=0
i915.enable_rc6=1

Could someone with similar hardware please try to reproduce this, so we can find a solution asap.
Please keep in mind that I am only little experienced with Debian/Tails - maybe someone would like to explain how I can create a log file from the console and save it to the USB Drive and then upload this here for further investigation?

#4 Updated by mercedes508 over 3 years ago

  • Priority changed from Urgent to Normal

Hi !

we are suspecting that the issue you reported has to do with the GPU of your computer.
In order to understand what is the exact issue, we need more informations. Since Gnome is not started,
you can't send a whisperback report the usual way, the following steps will allow you to collect
these informations in a file on another USB stick, then you will be able to send us that file in an email to our bug report mailling-list:

https://tails.boum.org/support/

You will need your problematic Tails device, and another stick (preferably empty).

1. start Tails

2. in the greeter, set up an administrator password (https://tails.boum.org/doc/first_steps/startup_options/administration_password)

3. once Tails has crashed (freeze or return to the greeter), press simulteanously Ctrl + Alt + F1 to get to the text console

4. if it worked, you are asked for a login, that's 'amnesia'. the password is the administrator password you set up previously

5. type the following command, that will allow you a root access to the system (so be carefull) :

sudo su --

6. this command will create an empty directory in amnesia's home :

mkdir /home/amnesia/mountpoint

7. plug in your second USB stick.

8. this command will show you some system log :

dmesg

9. in the last lines of the logs, there should be a line like this one :

[12345.678910] sd 10:0:0:0: [sdc] Attached SCSI removable disk

[sdc] is what we're searching for. this name depends of the number of hard drives plugged in your computer. if you only have your usual Hard Drive (sda) and your Tails device (sdb), then your second stick should be 'sdc'

10. this command will mount the device in the filesystem :

mount /dev/sdc1 /home/amnesia/mountpoint

11. and this one will copy the debugging information in a file on that stick :

tails-debugging-info > /home/amnesia/mountpoint/tails-debugging-info.txt

12. now you can unmount the stick :

umount /dev/sdc1

13. unplug it, then unplug the Tails device, boot another system and send us that file or its content in an email (our public PGP key is here : https://tails.boum.org/doc/about/openpgp_keys/#support)

get back to us if you have some trouble to follow those steps.

#5 Updated by gentriles over 3 years ago

mercedes508 wrote:

3. once Tails has crashed (freeze or return to the greeter), press simulteanously Ctrl + Alt + F1 to get to the text console

When I press Ctrl + Alt + F1 it brings me to the "Welcome to Tails" screen with "More options? Yes No" window. I can't start the text console...

#6 Updated by vitali576 about 3 years ago

gentriles wrote:

When I press Ctrl + Alt + F1 it brings me to the "Welcome to Tails" screen with "More options? Yes No" window. I can't start the text console...

I had exactly the same issue, however I just found out how to get to the text console:

1. use kernel boot parameter vga=770 and hit return key
2. on the next screen, again hit return key, it will show you a list of compatible video modes
3. I have tested the following modes working for me (I haven't tested all of them yet): 311, 312 and 315
4. Enter the specific mode number (e.g. 311) and hit return
5. the system will boot, after login screen it crashes as usual BUT now you can switch to console by pressing CTRL+ALT+F1
6. now you can proceed with mercedes508 tutorial
7. you may also use kernel boot paramters "rootpw=1234" (to specify a password for root at startup) and delete "noautologin", so you do not have to select "login" button to get to the error code
8. As mentioned above, I have not yet tried all of the vga=XXX modes, maybe some of these will work even without gnome crashing, so can you please try all of them and report back?

#7 Updated by gentriles about 3 years ago

mercedes508 wrote:

In order to understand what is the exact issue, we need more informations.

I sent the email with the log file you requested.

vitali576 wrote:

I had exactly the same issue, however I just found out how to get to the text console

Thanks for the workaround to reach the console! I too havent tried all video modes yet. I'll post a message if one of them is actually working.

#8 Updated by vitali576 about 3 years ago

I have attached the log file here for anyone who may be interested in helping us. I will also send the log to the support via email.

#9 Updated by mercedes508 about 3 years ago

  • Subject changed from "Oh no. Something went wrong." - Cant use Tails 2.2 to Xorg crashes with Intel HD graphics
  • Status changed from New to Confirmed
  • Type of work changed from Graphics to Research

#10 Updated by mercedes508 about 3 years ago

  • Subject changed from Xorg crashes with Intel HD graphics to Xorg crashes with Intel Celeron

#11 Updated by devnsec about 3 years ago

I can confirm that I have the same issue with Tails 2.2.1 on a computer that uses a N3700 processor.

Hardware information:

$ grep 'model name' /proc/cpuinfo | head -n1
model name    : Intel(R) Pentium(R) CPU  N3700  @ 1.60GHz

$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:22b1] (rev 21)

I have tried Debian 8 on the computer, the GNOME desktop could not startup and crashed with the same error message like Tails, but I was managed to solve the issue on Debian by installing mesa from jessie-backports. To be specific, I upgraded the following packages to the backports version and solved the issue: libegl1-mesa libegl1-mesa-drivers libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libwayland-egl1-mesa

The commit in mesa that fixed this issue is: https://cgit.freedesktop.org/mesa/mesa/commit/?id=cad60420d5ea36a4b6fa2e6c91317f71423aa63e

#12 Updated by devnsec about 3 years ago

I would also suggest change the subject from Xorg crashes with Intel Celeron to Xorg crashes with Intel Braswell

And Intel Bay Trail is potentially affected by the same bug, need to confirm.

#13 Updated by gentriles about 3 years ago

devnsec wrote:

To be specific, I upgraded the following packages to the backports version and solved the issue: libegl1-mesa libegl1-mesa-drivers libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libwayland-egl1-mesa

How do I install these packages in Tails? I read that one should not use "sudo apt-get install ..." on Tails?! If you can tell me how to install them, I can report if it fixes the problem.

#14 Updated by devnsec about 3 years ago

gentriles wrote:

devnsec wrote:

To be specific, I upgraded the following packages to the backports version and solved the issue: libegl1-mesa libegl1-mesa-drivers libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libwayland-egl1-mesa

How do I install these packages in Tails? I read that one should not use "sudo apt-get install ..." on Tails?! If you can tell me how to install them, I can report if it fixes the problem.

Use "sudo apt-get" updates those packages is not going to work. The reason is simple, you don't have the password for "sudo" if you cannot login.

The only solution that I can see is modify the squashfs image file.

#15 Updated by goupille about 3 years ago

  • Subject changed from Xorg crashes with Intel Celeron to Xorg crashes with Intel Braswell
  • Assignee set to intrigeri

#16 Updated by goupille about 3 years ago

  • Assignee deleted (intrigeri)

#17 Updated by goupille about 3 years ago

#18 Updated by vitali576 about 3 years ago

devnsec wrote:

gentriles wrote:

devnsec wrote:

To be specific, I upgraded the following packages to the backports version and solved the issue: libegl1-mesa libegl1-mesa-drivers libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libwayland-egl1-mesa

How do I install these packages in Tails? I read that one should not use "sudo apt-get install ..." on Tails?! If you can tell me how to install them, I can report if it fixes the problem.

Use "sudo apt-get" updates those packages is not going to work. The reason is simple, you don't have the password for "sudo" if you cannot login.

The only solution that I can see is modify the squashfs image file.

Is it possible to install the mentioned jessie-backport packages inside tails with persistence enabled on another machine and then use the fixed tails on the buggy hardware?
Could You please describe how to add the jessie-backport APT repository from the terminal in tails to install the packages? As I said I want to try if this works, assuming the backport packages remain persistent once installed?
I have already tried to add the repo
echo "deb http://ftp.us.debian.org/debian/ jessie main" | \
sudo tee /etc/apt/sources.list.d/jessie.list

but I without luck:

E: Package 'libegl1-mesa-drivers' has no installation candidate
root@amnesia:/home/amnesia# sudo apt-get install libegl1-mesa
Reading package lists... Done
Building dependency tree
Reading state information... Done
libegl1-mesa is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@amnesia:/home/amnesia# sudo apt-get install libegl1-mesa-driversReading package lists... Done
Building dependency tree
Reading state information... Done
Package libegl1-mesa-drivers is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libwayland-egl1-mesa

E: Package 'libegl1-mesa-drivers' has no installation candidate
root@amnesia:/home/amnesia#

Maybe you could help me with this? I appreciate your help!

#19 Updated by devnsec about 3 years ago

vitali576 wrote:

devnsec wrote:

gentriles wrote:

devnsec wrote:

To be specific, I upgraded the following packages to the backports version and solved the issue: libegl1-mesa libegl1-mesa-drivers libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libwayland-egl1-mesa

How do I install these packages in Tails? I read that one should not use "sudo apt-get install ..." on Tails?! If you can tell me how to install them, I can report if it fixes the problem.

Use "sudo apt-get" updates those packages is not going to work. The reason is simple, you don't have the password for "sudo" if you cannot login.

The only solution that I can see is modify the squashfs image file.

Is it possible to install the mentioned jessie-backport packages inside tails with persistence enabled on another machine and then use the fixed tails on the buggy hardware?
Could You please describe how to add the jessie-backport APT repository from the terminal in tails to install the packages? As I said I want to try if this works, assuming the backport packages remain persistent once installed?
I have already tried to add the repo
echo "deb http://ftp.us.debian.org/debian/ jessie main" | \
sudo tee /etc/apt/sources.list.d/jessie.list

but I without luck:

E: Package 'libegl1-mesa-drivers' has no installation candidate
root@amnesia:/home/amnesia# sudo apt-get install libegl1-mesa
Reading package lists... Done
Building dependency tree
Reading state information... Done
libegl1-mesa is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@amnesia:/home/amnesia# sudo apt-get install libegl1-mesa-driversReading package lists... Done
Building dependency tree
Reading state information... Done
Package libegl1-mesa-drivers is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libwayland-egl1-mesa

E: Package 'libegl1-mesa-drivers' has no installation candidate
root@amnesia:/home/amnesia#

Maybe you could help me with this? I appreciate your help!

First of all, I don't think install them in persistence will work, because the mesa library probably loads before the persistence unlocked.

If you still want to test it, follow instructions here: http://backports.debian.org/Instructions/

TL;DR:

sudo -i
echo 'deb http://ftp.debian.org/debian jessie-backports main' >> /etc/apt/sources.list
apt-get update
apt-get -t jessie-backports install libegl1-mesa libegl1-mesa-drivers libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libwayland-egl1-mesa

#20 Updated by devnsec about 3 years ago

Hi vitali576,

I've read the source code of the persistent apt-get packages, and I think it won't help you to fix this issue.

tails/config/chroot_local-includes/usr/local/sbin/tails-additional-software line 98:

    apt_get_returncode = _launch_apt_get(["--no-remove",
        "--option", "DPkg::Options::=--force-confold",
        "install"] + packages)

It has the "--no-remove" parameter, and the "man apt-get" says:

--no-remove
    If any packages are to be removed apt-get immediately aborts without prompting. 

Since we are trying to replace the packages with a newer version, this will most likely removes the existing packages, and results in "apt-get immediately aborts without prompting".

#21 Updated by devnsec about 3 years ago

Since the persistent looks like a dead end, and modifying the squashfs image seems overkill, I did more research on how to patch Tails installation, and come up with this: https://tails.boum.org/contribute/design/incremental_upgrades/archive/

stacking squashfs images sounds like an easier and less destructive way of testing this.

#22 Updated by devnsec about 3 years ago

I have succeed with a squashfs image file. Here is the steps I did:

WARNING: FOR TESTING PURPOSE ONLY, I CANNOT GUARANTEE ANYTHING, USE IT ON YOUR OWN RISK

  1. Download all of the deb files below (some of them are dependencies)
    http://ftp.debian.org/debian/pool/main/libd/libdrm/libdrm-amdgpu1_2.4.67-1~bpo8+1_i386.deb
    http://ftp.debian.org/debian/pool/main/libd/libdrm/libdrm2_2.4.67-1~bpo8+1_i386.deb
    http://ftp.debian.org/debian/pool/main/m/mesa/libwayland-egl1-mesa_11.1.2-1~bpo8+1_i386.deb
    http://ftp.debian.org/debian/pool/main/m/mesa/libglapi-mesa_11.1.2-1~bpo8+1_i386.deb
    http://ftp.debian.org/debian/pool/main/m/mesa/libgl1-mesa-glx_11.1.2-1~bpo8+1_i386.deb
    http://ftp.debian.org/debian/pool/main/m/mesa/libgl1-mesa-dri_11.1.2-1~bpo8+1_i386.deb
    http://ftp.debian.org/debian/pool/main/m/mesa/libegl1-mesa_11.1.2-1~bpo8+1_i386.deb
    
  2. Make temporary directories
    mkdir -p tails/{media,filesystem,2.2.1,changes,root}
    cd tails
    
  3. Mount your USB stick, assume /dev/sdx1 is your Tails USB stick
    mount /dev/sdx1 media
    
  4. Mount squashfs images
    mount -o ro,loop media/live/filesystem.squashfs filesystem
    mount -o ro,loop media/live/2.2.1.squashfs 2.2.1
    
  5. Mount the live root with aufs (please make sure your kernel has AUFS supports)
    mount -t aufs -o br:changes=rw,br:2.2.1=ro,br:filesystem=ro none root
    
  6. Copy all packages into live root
    cp /path/to/deb/files/*.deb root/
    
  7. Chroot into the live root
    chroot root /bin/bash
    source /etc/profile
    
  8. Install deb files
    cd /
    dpkg -i *.deb
    
  9. Exit chroot environment
    exit
    rm -rf root/*.deb
    umount root
    
  10. Cleanup unnecessary files
    cd changes
    rm -rf tmp .wh..wh.aufs .wh..wh.orph .wh..wh.plnk root var/log var/lib/dpkg/{updates,triggers,status-old,lock}
    cd ..
    
  11. Make the delta squashfs image, and put it on the USB stick
    mksquashfs changes media/live/mesa-backports.squashfs
    
  12. Edit the media/live/Tails.module file, append a line that contains the new image file name, like this:
    filesystem.squashfs
    2.2.1.squashfs
    mesa-backports.squashfs
    
  13. Umount everything
    umount filesystem 2.2.1
    umount media
    

Done! Now test your Tails on the problematic hardware, and report your test result here.

#23 Updated by devnsec about 3 years ago

Actually, try the Tails feature #11303 build, and report your results to this ticket or #11303

Download link: http://nightly.tails.boum.org/build_Tails_ISO_feature-11303-mesa-backport/lastSuccessful/archive/latest.iso

It worked for me, I was able to run Tails on Intel N3700 CPU use this ISO.

#24 Updated by vitali576 about 3 years ago

devnsec wrote:

It worked for me, I was able to run Tails on Intel N3700 CPU use this ISO.

I can confirm this build works on Intel Celeron N3150 with Acer Aspire ES1-331-C5KL!
Will this fix be included in the next official release?

#25 Updated by devnsec about 3 years ago

vitali576 wrote:

devnsec wrote:

It worked for me, I was able to run Tails on Intel N3700 CPU use this ISO.

I can confirm this build works on Intel Celeron N3150 with Acer Aspire ES1-331-C5KL!
Will this fix be included in the next official release?

I believe that this fix will be included if we push it hard enough.

Ticket #11303 says "Target version: Tails_2.4", but I believe it still has the chance to ship with the 2.3 release if this ISO is well tested.

#26 Updated by gentriles about 3 years ago

devnsec wrote:

Actually, try the Tails feature #11303 build, and report your results to this ticket or #11303

Download link: http://nightly.tails.boum.org/build_Tails_ISO_feature-11303-mesa-backport/lastSuccessful/archive/latest.iso

I can confirm this is working on the "Intel Celeron N3050 1.6 GHz"! Thank you very much.

Gnome is working, though expectingly very slow...There is a ton of minimalistic / extremely lightweight desktop-environments out there. "TinyWM" one of the smallest. Here is a great list: https://l3net.wordpress.com/2013/03/17/a-memory-comparison-of-light-linux-desktops/ If it's possible to include one of them as a "fail-safe" GUI or GUI for low end machines. This would definately help people who cant afford a decend performant laptop ... or doesnt push the requirement to buy one of the latest laptop (which also ships with some other fancy technology not everybody likes...). Think about it...

#27 Updated by devnsec about 3 years ago

gentriles wrote:

devnsec wrote:

Actually, try the Tails feature #11303 build, and report your results to this ticket or #11303

Download link: http://nightly.tails.boum.org/build_Tails_ISO_feature-11303-mesa-backport/lastSuccessful/archive/latest.iso

I can confirm this is working on the "Intel Celeron N3050 1.6 GHz"! Thank you very much.

Gnome is working, though expectingly very slow...There is a ton of minimalistic / extremely lightweight desktop-environments out there. "TinyWM" one of the smallest. Here is a great list: https://l3net.wordpress.com/2013/03/17/a-memory-comparison-of-light-linux-desktops/ If it's possible to include one of them as a "fail-safe" GUI or GUI for low end machines. This would definately help people who cant afford a decend performant laptop ... or doesnt push the requirement to buy one of the latest laptop (which also ships with some other fancy technology not everybody likes...). Think about it...

Thanks for the feedback.

For the DE/WM question, see here: https://tails.boum.org/support/faq/index.en.html#index4h2

Personally, I don't like GNOME either. I have a quad core N3700 which is definitely better than the dual core N3050, even though, use keyboard to typing in a GUI text editor is very laggy. But since Tails only has GNOME, we don't have any choices, and I won't push the developers to support another DE, because the cost of that is bigger ISO files and a lots more maintenance works. The only thing that I can do is disable animations, it's not a big improvement, but better than nothing.

If you really had enough with GNOME, you could modify the squashfs image file as a mentioned before, add your favourite DE, but you probably need to find a way to deal with the Greeter. (I have never tried to do this)

#28 Updated by intrigeri about 3 years ago

  • Assignee set to elouann
  • QA Check set to Info Needed

elouann (assuming you're on frontdesk duty currently), can you please quickly check if #11303 would solve all the problems this ticket is about? Don't spend too much time on it though.

Rationale: I'm confused and am not sure what the exact scope of this ticket is, especially since "Intel Braswell" does not exist as far as I know, and quite a few different GPUs are mentioned here.

Also, it would be nice if someone (frontdesk?) checked if/how the tickets mentionned on #11263#note-3 relate to this one, and to #11303.

#29 Updated by intrigeri about 3 years ago

intrigeri wrote:

Rationale: I'm confused and am not sure what the exact scope of this ticket is, especially since "Intel Braswell" does not exist as far as I know,

My bad, it does exist. Still, it would be great to check if all GPUs mentioned on this ticket are indeed Braswell ones.

#30 Updated by elouann about 3 years ago

it would be great to check if all GPUs mentioned on this ticket are indeed Braswell ones.

Yes they are, according to http://ark.intel.com/fr/products/codename/66094/Braswell#@All (checked: Intel Celeron N3150, Intel Celeron N3050, Intel Pentium N3700)

can you please quickly check if #11303 would solve all the problems this ticket is about?

Yes: the experimental ISO fixes the issue of everybody here (devnsec, vitali576, gentriles). Thank you devnsec!

Also, it would be nice if someone (frontdesk?) checked if/how the tickets mentionned on #11263#note-3 relate to this one, and to #11303.

I'll dig into that a bit later

#31 Updated by elouann about 3 years ago

I processed the tickets listed in #3 and others:
It seems like the same error message ("Oh no. Something has gone wrong") can have different causes.
For example, some tickets refer to this error as appearing randomly, some appears each time after the greeter, etc.

Users facing this problem should IMHO:

- test this experimental ISO: http://nightly.tails.boum.org/build_Tails_ISO_feature-11303-mesa-backport/lastSuccessful/archive/latest.iso and report if it does the trick

- Check those workarounds and report
https://labs.riseup.net/code/issues/11095#note-3
https://labs.riseup.net/code/issues/11095#note-7

- If the issue is not fixed, gather some more info, see
https://labs.riseup.net/code/issues/7323#note-31
https://labs.riseup.net/code/issues/11263#note-4
https://labs.riseup.net/code/issues/11263#note-6

Random notes:

#11145 and #11014: Error message appearing after the Greeter
#8778 Error was appearing after the Greeter in the test suite, fixed one year ago
#7323: Error appearing randomly, investigation is going on
#7890 Error was appearing before the Greeter, closed one year ago by installing libgl1-mesa-dri

#32 Updated by intrigeri about 3 years ago

  • Related to deleted (Feature #11303: Ship mesa from jessie-backports)

#33 Updated by intrigeri about 3 years ago

#34 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to Duplicate
  • Assignee deleted (elouann)

Since everybody seems to agree that the branch for #11303 fixes this problem, I'm marking it as a duplicate :)

Also available in: Atom PDF