Project

General

Profile

Feature #11256

Feature #5684: Screen locker

Feature #5878: Add a lock screen action to the system menu

Replace "Debian Live user" with a more descriptive full user name

Added by sajolida almost 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/17/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

When locking the screen, the full name of the amnesia user appears: "Debian Live user". We could have something nicer. Maybe "amnesia", maybe "Tails".

But does this have to reuse the same name as the one we would choose for #5655, for anonymity reasons? or can we use something specific for Tails?


Related issues

Related to Tails - Feature #5655: Share username and hostname amongst all anonymity distributions Confirmed 03/17/2016

Associated revisions

Revision b67a1c3a (diff)
Added by anonym about 2 years ago

Enter a name into the Thunderbird account configuration.

After we set the "Full user name" to the empty string, nothing is
pre-filled into this obligatory field.

Refs: #11256

History

#1 Updated by sajolida almost 4 years ago

  • Assignee set to intrigeri
  • QA Check set to Info Needed

Assigning to intrigeri who's assignee for #5655 to have a first opinion on whether we should wait for #5655 to use the same display name or if we can find something specific to Tails.

#2 Updated by intrigeri almost 4 years ago

  • Assignee changed from intrigeri to sajolida

(There's been a misunderstanding: I was assigned to #5655 only to do #5655#note-11, in order to kill a pending thread frmo my mailmox; I've completed it but forgot to deassign myself. I don't want to add a new task related to that topic on my plate now, since my plan was to drop one.)

#3 Updated by intrigeri almost 4 years ago

  • Related to Feature #5655: Share username and hostname amongst all anonymity distributions added

#4 Updated by sajolida almost 4 years ago

  • Assignee deleted (sajolida)
  • QA Check deleted (Info Needed)

#5 Updated by intrigeri over 3 years ago

  • Type of work changed from Discuss to Research

(I see security questions that need to be researched, and nothing that's ready to be discussed.)

#6 Updated by sajolida over 3 years ago

  • Assignee set to segfault
  • Parent task set to #5878
  • Type of work changed from Research to Code

I think that this should be part of #5878 because #5878 will make the screen locker visible to most users (so far it's available but hidden).

segfault: what do you think?

Regarding which full name to choose, I would put "amnesia" which is the current login and is already refered to in several places in the documentation. This way no more research or discussion are needed and we can jump straight to code.

#7 Updated by segfault over 3 years ago

  • Assignee changed from segfault to anonym
  • QA Check set to Ready for QA

I just pushed a commit to the feature branch of #5684 which removes this "Debian Live user" comment from the amnesia account.
See https://gitlab.com/segfault_/tails.git feature/5684-screen-locker

#8 Updated by sajolida over 3 years ago

  • Target version set to Tails_2.6

Marking this for 2.6 until the status of this is clarified, see #5878#note-16.

#9 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.6 to Tails_2.9.1

#10 Updated by anonym about 3 years ago

  • Target version changed from Tails_2.9.1 to Tails 2.10

Bumping this feature to the new next major release (given 2.8 was cancelled).

#11 Updated by anonym about 3 years ago

I've pushed two commit to our repo's version of the branch:

d52d946 Enter a name into the Icedove account configuration.
19fb574 Make GNOME's default Lock Screen keyboard shortcut use our locker.

Please review'n'merge, segfault! :)

Edit: I meant to post this to #5684, so please post any follow-ups there.

#12 Updated by anonym about 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

Also available in: Atom PDF