Project

General

Profile

Bug #11253

See if we can upstream our VPN bits to immerda's puppet-tinc module

Added by bertagaz over 3 years ago. Updated 9 months ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
-
Start date:
03/17/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

While deploying our monitoring setup, we developed some manifests to handle a Tinc VPN. Immerda has a puppet module for that, but it would need to be adapted to fit our needs. So we should first check if immerda's module is still maintained, and then check how we could modify so that we can get rid of this lines of code.

Update: https://git.puppet.immerda.ch/module-tinc/ has seen commits in 2018.

History

#1 Updated by intrigeri over 3 years ago

  • Subject changed from See if we can upstream our vpn bits to immerda's puppet-tinc module to See if we can upstream our VPN bits to immerda's puppet-tinc module

#3 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.4 to Tails_2.5

#4 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.5 to Tails_2.6

Probably won't have time to work on that before.

#5 Updated by anonym about 3 years ago

  • Target version changed from Tails_2.6 to Tails_2.7

#6 Updated by bertagaz about 3 years ago

  • Target version changed from Tails_2.7 to Tails_2.9.1

#7 Updated by anonym almost 3 years ago

  • Target version changed from Tails_2.9.1 to Tails 2.10

#8 Updated by intrigeri almost 3 years ago

  • Target version changed from Tails 2.10 to Tails_2.11

#9 Updated by bertagaz almost 3 years ago

  • Target version changed from Tails_2.11 to Tails_2.12

#10 Updated by bertagaz almost 3 years ago

  • Target version changed from Tails_2.12 to Tails_3.0

#11 Updated by bertagaz over 2 years ago

  • Target version changed from Tails_3.0 to Tails_3.1

#12 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_3.1 to Tails_3.2

Please focus on our CI ISO builds robustness for now. I guess this + RM'ing will be enough to keep you plenty busy :)

#13 Updated by bertagaz over 2 years ago

  • Target version changed from Tails_3.2 to Tails_3.3

#14 Updated by bertagaz about 2 years ago

  • Target version changed from Tails_3.3 to Tails_3.5

Realistically reschedule for 3.4.

#15 Updated by bertagaz about 2 years ago

  • Target version changed from Tails_3.5 to Tails_3.6

#16 Updated by u almost 2 years ago

I'm unblocking this for the deliverable.

#19 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#20 Updated by intrigeri over 1 year ago

  • Description updated (diff)

#22 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#23 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#24 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

#25 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#26 Updated by CyrilBrulebois 12 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#27 Updated by anonym 11 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#28 Updated by u 9 months ago

  • Assignee deleted (bertagaz)
  • Target version deleted (Tails_3.13)

It looks like this is one more thing we have to maintain ourselves as opposed to sharing the work with like-minded people, so it would be nice to get this upstreamed and not have to cope with changes in the surrounding environment (Debian upgrade, concat module upgrade).

Also available in: Atom PDF