Project

General

Profile

Bug #11248

List applications that need more appropriate menu categories

Added by spriver over 3 years ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
03/16/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:

Description

Some applications could have assigned more suitable categories in the menu of GNOME.
E.g.:

MAT is in "System Tools"
poedit is in "Development"

The categories in the corresponding .desktop file in /usr/share/applications should be fixed upstream.


Related issues

Related to MAT - Bug #11260: Reconsider .desktop menu categories New 03/18/2016
Related to Tails - Feature #7449: Have Seahorse easier to find in the Applications menu Confirmed 07/19/2014
Related to Tails - Feature #7433: Turn Tails OpenPGP Applet into a standalone application Duplicate 06/22/2014
Related to Tails - Bug #10564: Single-item submenus in Applications menu Confirmed 11/17/2015
Related to Tails - Feature #7435: Add Tails OpenPGP Applet to the Applications menu Confirmed 06/22/2014
Related to Tails - Feature #5521: Remove system tools menu duplicates Confirmed

History

#1 Updated by spriver over 3 years ago

IMO "Configure persistent volume", "Delete persistent volume" and "Tails Installer" should get removed from "System Tools" as we do have a "Tails" section where they are located, too. Having applications available in just one section makes it easier to write doc and explain it to users.

#2 Updated by spriver over 3 years ago

Another thing spotted:
"LibreOffice Math" ist located in both "Office" and as the only application in "Science".

It's also to possible to remove menu categories entirely (by deleting the corresponding section in /etc/xdg/menus/gnome-applications.menu, e.g. LibreOffice Math will get deleted then automatically from "Science" if the section gets removed). But this would also mean a code delta.

#3 Updated by mercedes508 over 3 years ago

  • Status changed from New to Confirmed

#4 Updated by spriver over 3 years ago

  • Related to Bug #11260: Reconsider .desktop menu categories added

#5 Updated by u about 2 years ago

  • Related to Feature #7449: Have Seahorse easier to find in the Applications menu added

#6 Updated by u about 2 years ago

  • Related to Feature #7433: Turn Tails OpenPGP Applet into a standalone application added

#7 Updated by u about 1 year ago

  • Subject changed from Finding more appropriate menu categories to List applications that need more appropriate menu categories

I'm changing the title to at least collect which apps are concerned by this, before even trying to implement this anywhere.

#8 Updated by u about 1 year ago

  • Related to Bug #10564: Single-item submenus in Applications menu added

#9 Updated by u about 1 year ago

  • Related to Feature #7435: Add Tails OpenPGP Applet to the Applications menu added

#10 Updated by u about 1 year ago

  • Related to Feature #5521: Remove system tools menu duplicates added

#11 Updated by sajolida about 2 months ago

  • Status changed from Confirmed to Resolved
  • MAT doesn't have a menu entry anymore in Tails 4.0.
  • Poedit is in "Programming" and I think it's the best category for it. Note that we might remove it in the future, cf. #15291.
  • I'll propose to remove LibreOffice Math in #16910.

The rest is fine, except "Tails" entries that are duplicate but I think that because of a bug. The difference between "Accessories" and "Utilities" will always remain a mystery to me. They are full of GNOME core apps so I don't think it's worth trying to change things upstream.

#12 Updated by intrigeri about 1 month ago

sajolida wrote:

The rest is fine, except "Tails" entries that are duplicate but I think that because of a bug.

Yep, that's #5521.

Also available in: Atom PDF