Project

General

Profile

Feature #11237

Consider removing GNOME Tweak Tool

Added by sajolida about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/14/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/11237-remove-tweak-tool
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

While discussing #10997 we proposed to remove GNOME Tweak Tool.

It was added in a1e80d7 with no very good reason.

I checked the list of options that can be modified through it and the most useful ones I found (apart from aesthetics, theme, etc.) are:

  • Activating or deactivating extensions. But if people install extra extensions they can install Tweak Tool as well.
  • Workspace creation which is static and limited to 4 right now. So far nobody complained about having only 4 workspaces so maybe that's no big deal.
  • Activating week numbers in the calendar. This might be the most serious issue :)

So unless we find better uses of GNOME Tweak Tool maybe we can remove it, no?

Setting to 2.4, the next major version. I can do the patch :)


Related issues

Related to Tails - Bug #10797: GNOME Shell crashes when deleting workspaces Resolved 12/28/2015
Blocks Tails - Bug #10997: Document GNOME Tweak Tool Rejected 01/26/2016

Associated revisions

Revision 1a276d65 (diff)
Added by sajolida about 3 years ago

Revert "Install gnome-tweak-tool." (Will-fix: #11237)

This reverts commit a1e80d72a508ee49b63afa166261e99a6c3387a5.

Including GNOME Tweak Tool was probably meant for development only but
then it got shipped in 2.0. In #11237 we agreed on removing it to
avoid having to support corner cases trigger by people doing to much
tweaking.

Revision 9e28d239
Added by anonym about 3 years ago

Merge remote-tracking branch 'origin/feature/11237-remove-tweak-tool' into devel

Fix-committed: #11237

History

#1 Updated by sajolida about 3 years ago

  • Blocks Bug #10997: Document GNOME Tweak Tool added

#2 Updated by intrigeri about 3 years ago

It was added in a1e80d7 with no very good reason.

Sorry about that. Re-reading the commit message, it looks like something I meant to revert before 2.0 was out :/

  • Workspace creation which is static and limited to 4 right now. So far nobody complained about having only 4 workspaces so maybe that's no big deal.

... and I think we've been reported crashes when changing this setting in some ways.

  • Activating week numbers in the calendar. This might be the most serious issue :)

:)

So unless we find better uses of GNOME Tweak Tool maybe we can remove it, no?

I'm rather in favour of dropping it. I could live with keeping it as long as we then don't spend too much energy working around, fixing or documenting various issues that happen only when fiddling with settings in that interface (e.g. I personally would juse close any ticket that's about "bad things happen when I do X in GNOME Tweak Tool" as rejected).

#3 Updated by spriver about 3 years ago

  • Related to Bug #10797: GNOME Shell crashes when deleting workspaces added

#4 Updated by spriver about 3 years ago

IMHO we should delete it. There are several issues with that (also linked #10797 - the crashing after deleting a workspace) and users might think that this tool is standard and could complain/file tickets about things not working. If it isn't shipped by default users have to install and then it's sort of advanced software and not in our scope of responsibility. Just my 2 cents.

#5 Updated by sajolida about 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to sajolida
  • QA Check set to Ready for QA
  • Feature Branch set to feature/11237-remove-tweak-tool
  • Type of work changed from Discuss to Code

Ok, so here's a branch! I'll wait until the build works before assigning it to RM.

#6 Updated by sajolida about 3 years ago

  • Assignee changed from sajolida to anonym

Build successful!

#7 Updated by anonym about 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

#8 Updated by anonym almost 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF