Project

General

Profile

Feature #11229

Fix zenity hacks for focusing negative answer

Added by anonym over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
03/14/2016
Due date:
% Done:

100%

Feature Branch:
feature/11229-remove-zenity-focus-hacks
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Jessie's zenity has the --default-cancel option, so we can remove the hacks we currently use to simulate it (and screw up GNOME normal order of positive vs negative answers). Affected scripts are at least:

  • config/chroot_local-includes/usr/local/bin/electrum
  • config/chroot_local-includes/usr/local/bin/icedove
  • config/chroot_local-includes/usr/local/bin/tor-browser
  • config/chroot_local-includes/usr/local/sbin/i2p-browser
  • config/chroot_local-includes/usr/local/sbin/unsafe-browser

Associated revisions

Revision a09727cb (diff)
Added by anonym over 3 years ago

Drop zenity hacks to "focus" the negative answer.

Jessie's zenity introduced the --default-cancel option, finally!

Will-fix: #11229

Revision bbf75c85 (diff)
Added by anonym over 3 years ago

Fix automated test after zenity focus fix.

With our previous zenity hack, pressing Escape would result in a
positive answer, but not any more.

Refs: #11229

Revision 6648c77d (diff)
Added by intrigeri over 3 years ago

Take into account that button ordering differs depending on the locale's text direction.

refs: #11229

History

#1 Updated by anonym over 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 30
  • QA Check set to Dev Needed
  • Feature Branch set to feature/11229-remove-zenity-focus-hacks

Untested.

#2 Updated by anonym over 3 years ago

  • Assignee deleted (anonym)
  • % Done changed from 30 to 50
  • QA Check changed from Dev Needed to Ready for QA

anonym wrote:

Untested.

I've tested all five scripts now, and it works as it should. Yay! I also realized that one automated test had to be fixed since it used Escape to give a positive answer to a zenity question. :)

#3 Updated by intrigeri over 3 years ago

  • Assignee set to intrigeri

Code review passes. Not sure I'll have time to do more during this cycle.

#4 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Merged!

#5 Updated by intrigeri over 3 years ago

  • Status changed from Fix committed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 100 to 70
  • QA Check changed from Pass to Dev Needed

Oops, it seems to break "The_Unsafe_Browser_can_be_used_in_all_languages_supported_in_Tails" in at least one (Arabic) locale, presumably because screen.type(Sikuli::Key.RIGHT + Sikuli::Key.ENTER) doesn't play well with RTL. I'll try to fix it.

#6 Updated by intrigeri over 3 years ago

  • Priority changed from Normal to Elevated

Bumping priority since I've merged something buggy.

#7 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 70 to 80
  • QA Check changed from Dev Needed to Ready for QA

6648c77 (pushed directly to devel to fix the regression) fixes this for me. It's ugly, but I could not easily find a programmatic way to know what a given locale's text direction is. Please have a look :)

#8 Updated by anonym over 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 80 to 100
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

6648c77 (pushed directly to devel to fix the regression) fixes this for me. It's ugly, but I could not easily find a programmatic way to know what a given locale's text direction is. Please have a look :)

Looks acceptable to me. :) And it works!

#9 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF