Project

General

Profile

Bug #11191

Discuss if we should document how to autostart applications/scripts after login

Added by muri over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
-
Target version:
-
Start date:
03/04/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Description

hi, i could do that- but i want some input first, if we should document something like that, which can break the login procedure of a lot of users.
assiging to sajolida for a first estimate...

History

#1 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to muri
  • Priority changed from Normal to Low
  • QA Check set to Info Needed

I have something like this in my setup (in a dotfile) but I'm not sure we should document it on the website.

The target user for such documentation would be people who already know how to write scripts. So they might as well be able to figure out by themselves which dotfile to use to do so.

Also, having a documentation about this makes it somehow official that it's cool to tweak your Tails to death and possibly shoot yourself in the foot.

But, yeah, people who want to do this can do it anyway already by executing their custom backdoor every time they start Tails.

We also already have /doc/advanced_topics/additional_software which is similar though maybe not as dangerous.

Explaining how to only autostart applications might be different.

I'm not sure what we should do but I definitely don't think it's important to have it documented.

What do you think?

#2 Updated by muri over 3 years ago

  • Subject changed from Document how to autostart applications/scripts after login to Discuss if we should document how to autostart applications/scripts after login
  • Status changed from Confirmed to Resolved

sajolida wrote:

I have something like this in my setup (in a dotfile) but I'm not sure we should document it on the website.

same here

The target user for such documentation would be people who already know how to write scripts. So they might as well be able to figure out by themselves which dotfile to use to do so.

ack

Also, having a documentation about this makes it somehow official that it's cool to tweak your Tails to death and possibly shoot yourself in the foot.

ack

Explaining how to only autostart applications might be different.

yeah, actually, if i remember correctly, people were not asking so much about autostarting applications but about scripts. i think i only combined these two possiblilties because i use the 'gnome autostart application'-way to start my script

I'm not sure what we should do but I definitely don't think it's important to have it documented.

ok

What do you think?

i agree that people who write scripts should also be able to find out how to autostart them. and autostarting applications has not been asked
marking as resolved

Also available in: Atom PDF