Project

General

Profile

Bug #11187

Migration to Icedove: Users don't realise how to stop the warning

Added by emmapeel over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
03/02/2016
Due date:
% Done:

100%

Feature Branch:
doc/11187-claws-mail-persistence
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Email Client

Description

Users don't understand that they need to disable persistence of Claws Mail after migration, and they keep clicking on the warning 'You need to migrate to Icedove'.

The warning (or the migration howto) should mention this step, as some users are still clicking every time they start Icedove.

Associated revisions

Revision 3611ae80 (diff)
Added by sajolida over 3 years ago

Explain how to disable the Claws Mail persistence feature (Will-fix: #11187)

Revision 67e0bea5
Added by anonym over 3 years ago

Merge remote-tracking branch 'origin/doc/11187-claws-mail-persistence' into stable

Fix-committed: #11187

History

#1 Updated by intrigeri over 3 years ago

  • Category deleted (Continuous Integration)

#2 Updated by intrigeri over 3 years ago

  • Assignee set to sajolida
  • Target version set to Tails_2.3

sajolida and u, can you please give it a look? I'm not sure if it's a follow-up on the Claws→Icedove documentation path, that needs to be documented.

#3 Updated by u over 3 years ago

Hi,

I'm not sure how exactly this warning works. If I remember correctly, that it is shown only when Claws persistence is enabled.

I'm also not sure how this relates to #10742. Is is even possible to disable Claws persistence in that case?

I agree that it could be mentioned in the migration documentation, but I would need to set up quite a test case in order to test this at all. Maybe sajolida already has such a setup?

#4 Updated by sajolida over 3 years ago

  • Status changed from Confirmed to In Progress

#5 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to emmapeel
  • QA Check set to Ready for QA
  • Feature Branch set to doc/11187-claws-mail-persistence

Here is a branch for you Emma :)

#6 Updated by emmapeel over 3 years ago

I like the changes, and it would have been good if they were there when we got rid of Claws mail, but I think people will not spot the new information on the howto easily after this time.

Maybe it is better to change the actual error message that appears?

Some users complained after a new release came, I think because they thought the new release will make the message dissapear.

#7 Updated by sajolida over 3 years ago

  • Assignee changed from emmapeel to sajolida
  • Priority changed from Normal to Elevated
  • QA Check changed from Ready for QA to Dev Needed

Good idea! I'll work on this top then. Hopefully in time for 2.3.

#8 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to anonym
  • QA Check changed from Dev Needed to Ready for QA

Actually, the warning is not displayed if people go until the end of the
instructions and delete all their Claws Mail data: we check for
~/.claws-mail/accountrc before displaying the warning. So this problem
only occurs for people who didn't do the whole migration.

Still, I improved the warning to handle this better, see b3fbf4d.

Marking as "Ready for QA" for anonym as this imply some coding and you
and me can't merge this on our own.

#9 Updated by anonym over 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

Looks good!

#10 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF