Project

General

Profile

Bug #11145

GNOME freezes with Intel HD GPU (3rd Gen)

Added by goupille over 3 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
-
Start date:
02/20/2016
Due date:
% Done:

0%

Feature Branch:
bugfix/7505-optimus
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

after the greeter, gnome starts then freezes on a blue screen.

the laptop has two graphical cards:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 740M] (rev a1)

the kernel loads i915 and nouveau modules, but Xorg doesn't seem to use the NVIDIA card :

amnesia gdm-Xorg-:0[2506]: (II) LoadModule: "intel" 

and then there are errors :

amnesia gdm-Xorg-:0[2506]: (EE) open /dev/dri/card0: No such file or directory
amnesia gdm-Xorg-:0[2506]: (EE) open /dev/dri/card0: No such file or directory
amnesia gdm-Xorg-:0[2506]: (EE) Screen 0 deleted because of no matching config section.
amnesia gdm-Xorg-:0[2506]: (EE) FBDEV(0): FBIOBLANK: Invalid argument
amnesia gdm-Xorg-:0[2506]: (EE) AIGLX: reverting to software rendering
amnesia gdm-Xorg-:0[2506]: (EE) FBDEV(0): FBIOBLANK: Invalid argument
amnesia gdm-Xorg-:0[2506]: (EE) FBDEV(0): FBIOBLANK: Invalid argument

Related issues

Related to Tails - Bug #7505: Video is broken with switchable graphics Rejected 07/06/2014

History

#1 Updated by goupille over 3 years ago

same issue (same error message) reported with those intel graphics :

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

and

00:02.0 VGA compatible controller: Intel Corporation Device 22b1 (rev 21)

#2 Updated by intrigeri over 3 years ago

  • Related to Bug #7505: Video is broken with switchable graphics added

#3 Updated by intrigeri over 3 years ago

  • Category set to Hardware support
  • Assignee changed from intrigeri to goupille

This problem looks very much like https://tails.boum.org/support/known_issues/#switchable_graphics. So I would suggest you just that known issue section, to cover the hardware this ticket is about.

Or, if I'm expected to do more here, I'll need more debugging info, e.g. what happens when booting with i915.modeset=0 and/or with nouveau.modeset=0 (all 3 combinations that have not been reported about yet), and whether xorg-driver=fbdev helps.

and then there are errors :

FYI, these errors are rather expected when booting in failsafe mode, which is apparently the case here (at least it was, in the logs I was forwarded).

#4 Updated by elouann over 3 years ago

  • Status changed from New to Confirmed
  • QA Check set to Info Needed

#5 Updated by intrigeri about 3 years ago

Ping?

#6 Updated by intrigeri about 3 years ago

  • Subject changed from gnome freeze with Intel HD GPU (3rd Gen) to GNOME freezes with Intel HD GPU (3rd Gen)

Also, please ask bug reporters to try the experimental ISO at http://nightly.tails.boum.org/build_Tails_ISO_feature-11303-mesa-backport/lastSuccessful/archive/latest.iso and report back. Presumably this will be merged in time for Tails 2.4, but some more testing would help.

#7 Updated by intrigeri about 3 years ago

  • Feature Branch set to bugfix/7505-optimus

intrigeri wrote:

Also, please ask bug reporters to try the experimental ISO at http://nightly.tails.boum.org/build_Tails_ISO_feature-11303-mesa-backport/lastSuccessful/archive/latest.iso and report back.

Update: that's now in 2.4~rc1, so that's the one you folks should ask bug reported to try.

And: ping? I've initially asked more info 3 months ago.

#8 Updated by intrigeri about 3 years ago

Once we've confirmed that this is a problem with switchable graphics (and no particularly with 3rd gen Intel HD, at least not when it's alone), let's mark this as a duplicate of. #7505.

#9 Updated by goupille almost 3 years ago

  • Status changed from Confirmed to Duplicate
  • Assignee deleted (goupille)

we do not have any feedback from the users, so I'm all for marking is as duplicate of #7505

Also available in: Atom PDF