Project

General

Profile

Bug #11134

add .rake_tasks~ to .gitignore

Added by hybridwipe over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
02/17/2016
Due date:
% Done:

100%

Feature Branch:
https://git-tails.immerda.ch/hybridwipe/tails/?h=bugfix/11134-add-rake_tasks-to-gitignore
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:

Description

To reproduce, in tails' git:

$ rake TAB TAB
$ rake
build vm:destroy vm:halt vm:provision vm:up

this will leave a .rake_tasks~ file. Trying to build then fails:
austin@debian-laptop:~/src/tails$ rake build

You have uncommitted changes in the Git repository. Due to limitations
of the build system, you need to commit them before building Tails:
?? .rake_tasks~

If you don't care about those changes and want to build Tails nonetheless,
please add `ignorechanges` to the TAILS_BUILD_OPTIONS environment
variable.

Uncommitted changes. Aborting.

Associated revisions

Revision fb976fd9
Added by anonym over 3 years ago

Merge remote-tracking branch 'hybridwipe/bugfix/11134-add-rake_tasks-to-gitignore' into devel

Fix-committed: #11134

History

#1 Updated by hybridwipe over 3 years ago

  • Assignee deleted (hybridwipe)
  • QA Check set to Ready for QA
  • Feature Branch set to https://git-tails.immerda.ch/hybridwipe/tails/?h=bugfix/11134-add-rake_tasks-to-gitignore

#2 Updated by intrigeri over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to anonym
  • Target version set to Tails_2.2

#3 Updated by anonym over 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

Yes, this makes a lot of sense! Thanks for you contribution! Merged (into devel)!

#4 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF