Project

General

Profile

Bug #11090

Deal with September 2016 false positive scenarios

Added by bertagaz almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
09/05/2016
Due date:
10/05/2016
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

As defined in #10993, check is there are still some of them and tag them as fragile if any (see #10288)


Related issues

Related to Tails - Bug #11869: CI: use locally hosted Git repositories on Lizard Confirmed 01/01/2015

History

#1 Updated by bertagaz almost 4 years ago

  • Target version set to Tails_2.7

#2 Updated by intrigeri almost 4 years ago

  • Subject changed from Deal with September false positive scenarios to Deal with September 2016 false positive scenarios

#3 Updated by intrigeri over 3 years ago

While you do this work, it would be nice if I could get some feedback on #11816: does the "Test suite often freezes after clicking Login in the Greeter" problem still happen often after September 20?

#4 Updated by bertagaz over 3 years ago

Beware artifacts will start to disappear at some point.

#5 Updated by anonym over 3 years ago

intrigeri wrote:

While you do this work, it would be nice if I could get some feedback on #11816: does the "Test suite often freezes after clicking Login in the Greeter" problem still happen often after September 20?

I didn't in the stable and devel branches, but your comment #11816#note-2 says you've seen it on another branch. Too bad. :/

#6 Updated by anonym over 3 years ago

Here's the results:

Temporary stuff that will go away:

  • 's key will expire
  • Missing 2.7 UDF => all update checks fail.

Infra issues that I don't know if they are tracked (bertagaz?):

  • fatal: unable to access 'https://git-tails.immerda.ch/chutney/': Failed to connect to git-tails.immerda.ch port 443: Connection timed out

Issues we already track:

  • 7 times - #11786: System often crashes during/after memory wipe since Linux 4.6
  • 4 times - #11816: Test suite often freezes after clicking "Login" in the Greeter
  • 4 times - #10502: Remote shell seems to be down
  • 3 times - #10576: Occasionnally missing bits of widgets in the top-right GNOME Shell tray on Jessie
  • 1 time - #11846: The remote shell can mix up responses after an execution has been aborted

New issues:

#7 Updated by anonym over 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to bertagaz
  • % Done changed from 0 to 50
  • QA Check changed from Dev Needed to Info Needed

anonym wrote:

Infra issues that I don't know if they are tracked (bertagaz?):

  • fatal: unable to access 'https://git-tails.immerda.ch/chutney/': Failed to connect to git-tails.immerda.ch port 443: Connection timed out

bertagaz, what about this? I've seen it quite a few times (at least five this month).

#8 Updated by anonym over 3 years ago

So, w.r.t. @fragile tagging I don't think any new ones should be added. The already tracked issues I saw are too generic, and the new one, #11865, is something I've never seen and rather would like to know more about its frequency.

#9 Updated by bertagaz over 3 years ago

  • Assignee changed from bertagaz to anonym

anonym wrote:

  • fatal: unable to access 'https://git-tails.immerda.ch/chutney/': Failed to connect to git-tails.immerda.ch port 443: Connection timed out

bertagaz, what about this? I've seen it quite a few times (at least five this month).

There has been routing issue to immerda, and we've reported it to the colo who said they fixed it. So we're tracking that by email. Did it still appear lately?

So, w.r.t. @fragile tagging I don't think any new ones should be added.

\o/

#10 Updated by anonym over 3 years ago

  • Blocked by Bug #11866: Cannot download some artifacts from Jenkins added

#11 Updated by anonym over 3 years ago

  • Blocked by deleted (Bug #11866: Cannot download some artifacts from Jenkins)

#12 Updated by anonym over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Info Needed to Pass

Actually #11866 is not a blocker so I removed it, and we're done here.

#13 Updated by intrigeri over 3 years ago

  • Assignee set to bertagaz

There has been routing issue to immerda, and we've reported it to the colo who said they fixed it. So we're tracking that by email. Did it still appear lately?

Yes, from time to time, but never for extended periods of time (so I've closed #11633 which is about another problem that "connection timeout"). I've been meaning to suggest for a while that our builds stop relying on git.t.b.o, and instead use local clones of the repositories. Maybe it's time to consider this seriously? Please create a ticket about it if you think it's a valuable idea.

#14 Updated by bertagaz over 3 years ago

  • Assignee deleted (bertagaz)

intrigeri wrote:

There has been routing issue to immerda, and we've reported it to the colo who said they fixed it. So we're tracking that by email. Did it still appear lately?

Yes, from time to time, but never for extended periods of time (so I've closed #11633 which is about another problem that "connection timeout"). I've been meaning to suggest for a while that our builds stop relying on git.t.b.o, and instead use local clones of the repositories. Maybe it's time to consider this seriously? Please create a ticket about it if you think it's a valuable idea.

I've been thinking about doing that for a while now too. I've created #11869 to track that.

#15 Updated by bertagaz over 3 years ago

  • Related to Bug #11869: CI: use locally hosted Git repositories on Lizard added

Also available in: Atom PDF