Project

General

Profile

Bug #11085

Deal with April 2016 false positive scenarios

Added by bertagaz over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
04/05/2016
Due date:
05/05/2016
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

As defined in #10993, check is there are still some of them and tag them as fragile if any (see #10288)

History

#1 Updated by bertagaz over 3 years ago

  • Target version set to Tails_2.4

#3 Updated by intrigeri over 3 years ago

  • Subject changed from Deal with April false positive scenarios to Deal with April 2016 false positive scenarios

#4 Updated by bertagaz about 3 years ago

  • Assignee changed from intrigeri to bertagaz

Taking over this one. I've made a good part of it while doing #11084, and I'll try to finish this one before the CI meeting (which will probably just means implementing what we came up with on #11083 and #11084).

#5 Updated by intrigeri about 3 years ago

Taking over this one.

Thank you!

#6 Updated by bertagaz about 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50

So in April, we had 5 test suite run failures (for the stable and devel branch). Not much

cucumber features/i2p.feature:12 # Scenario: I2P is enabled when the "i2p" boot parameter is added
    Step failed while creating checkpoint: the Tails desktop is ready
    Given I have started Tails from DVD with I2P enabled and logged in # features/step_definitions/snapshots.rb:208
      FindFailed: can not find GnomeSystrayFlorence.png on the screen.

This is the only time in all of our test_Tails_ISO_* logs this bug happen. If you have a look at the screenshot, you'll notice that indeed the Florence icon is a bit weird. Not sure we have to flag this as @fragile.

cucumber features/root_access_control.feature:25 # Scenario: If no administrative password is set in Tails Greeter the live user \
  should not be able to get administrative privileges through PolicyKit with the standard passwords.
cucumber features/encryption.feature:32 # Scenario: Symmetric encryption and decryption using OpenPGP Applet
cucumber features/evince.feature:24 # Scenario: I cannot view a PDF file stored in non-persistent /home/amnesia/.gnupg

One has already been tagged as @fragile. I'll take care of the others tomorrow.

  • stable #245, #253 and devel #287 which failed because of the main suspect already tagged as @fragile.
cucumber features/encryption.feature:32 # Scenario: Symmetric encryption and decryption using OpenPGP Applet

#7 Updated by bertagaz about 3 years ago

bertagaz wrote:

This is the only time in all of our test_Tails_ISO_* logs this bug happen. If you have a look at the screenshot, you'll notice that indeed the Florence icon is a bit weird. Not sure we have to flag this as @fragile.

My bad, this also happened once in test_Tails_ISO_feature-11123-new-mirror-pool #6. Same bug.

#8 Updated by intrigeri about 3 years ago

[...]

This is the only time in all of our test_Tails_ISO_* logs this bug happen. If you have a look at the screenshot, you'll notice that indeed the Florence icon is a bit weird. Not sure we have to flag this as @fragile.

I bet it's related to #10576. If this happens so rarely, indeed let's not mark it as fragile, but let's keep an eye on it to see if it happens again.

  • stable #243 with the 3 usual suspects:
    [...]
    One has already been tagged as @fragile. I'll take care of the others tomorrow.

OK. Let's keep this ticket open until this has happened.

So in summary, once we'll have marked as fragile all those, we should get almost no false positives anymore!

#9 Updated by bertagaz about 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 100
  • QA Check deleted (Dev Needed)

intrigeri wrote:

I bet it's related to #10576. If this happens so rarely, indeed let's not mark it as fragile, but let's keep an eye on it to see if it happens again.

Probably yes, let's do that.

OK. Let's keep this ticket open until this has happened.

Done with #11338, seems they share the same root cause. Closing this ticket then.

So in summary, once we'll have marked as fragile all those, we should get almost no false positives anymore!

yep, we'll see with the May fragile pass, but hopefully we should be good.

Also available in: Atom PDF