Project

General

Profile

Bug #11075

Remove "Power Off" and "Reboot" from Applications → System Tools

Added by sajolida over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/27/2016
Due date:
% Done:

100%

Feature Branch:
feature/11075-remove-power-menu-entries
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Why do we have them there? Isn't the system menu sufficient? Removing these from this menu would clean it a bit...


Subtasks

Bug #11286: Clicking Applications → System Tools → poweroff doesn't workResolved


Related issues

Related to Tails - Bug #11061: Make it easier to access WhisperBack from the Applications menu Resolved 02/05/2016

Associated revisions

Revision 33a1c177 (diff)
Added by sajolida about 3 years ago

Remove 'Reboot' and 'Power Off' entries from Applications → System Tools (Will-fix: #11075)

These entries were added in 8b7dac2 for the Windows camouflage. But we
don't have the Windows camouflage anymore and they are cruft with the
default theme.

Revision 469b1ec0
Added by anonym about 3 years ago

Merge remote-tracking branch 'origin/feature/11075-remove-power-menu-entries' into devel

Fix-committed: #11075

History

#1 Updated by sajolida over 3 years ago

  • Assignee set to anonym
  • Target version set to Tails_2.2

Assigning to next RM for first opinion.

#2 Updated by sajolida over 3 years ago

  • Related to Bug #11061: Make it easier to access WhisperBack from the Applications menu added

#3 Updated by intrigeri over 3 years ago

Assigning to next RM for first opinion.

FTR we added these menu items there because otherwise there was no way to shut down Tails cleanly in Windows camouflage mode. So if we remove them, then the Windows camouflage mode will need to re-add them dynamically (on session login I guess) when it's reintroduced.

#4 Updated by anonym over 3 years ago

  • Assignee deleted (anonym)
  • Target version changed from Tails_2.2 to Tails_2.3

To me this looks like a detail, and honestly I do not care, so I will not try to facilitate this discussion. Any one that cares, please assign this ticket to you, reach a decision. On approval I can implement it.

#5 Updated by sajolida about 3 years ago

  • Status changed from New to Confirmed
  • Target version changed from Tails_2.3 to Tails_2.4
  • Type of work changed from Discuss to Code

I'll try to get rid of them for 2.4 then!

#6 Updated by intrigeri about 3 years ago

  • Assignee set to sajolida

(Assuming that's what you meant :)

#7 Updated by sajolida about 3 years ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:5eb46ba28bb3028c3725c7efb6b8027b4cf60166.

#8 Updated by sajolida about 3 years ago

  • Assignee changed from sajolida to anonym
  • QA Check set to Ready for QA
  • Feature Branch set to feature/11075-remove-power-menu-entries

#9 Updated by anonym about 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#10 Updated by anonym about 3 years ago

  • % Done changed from 0 to 100

#11 Updated by anonym about 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF